[Guide] How to flash a modded AMI UEFI BIOS

@okokokok :
Before you can try to flash the modded BIOS.ROM file by using AFUWINx64.exe and the /GAN suffix, you should flash the original BIOS.CAP file without /GAN.
Here is the related part of the start post:

  1. Copy the original (untouched) BIOS file into the same directory as the file AFUWINx64.exe.
  2. Flash the original BIOS by running the following Command Prompt (as Admin):

    afuwinx64.exe <NAME OF THE ORIGINAL BIOS>.CAP
  3. Replace the original BIOS within the AFUWIN64 folder by the modded one (must have the extension *.ROM!).
  4. Flash the modded BIOS by running the following Command Prompt as Admin:
    afuwinx64.exe <NAME OF THE MODDED BIOS>.ROM /GAN
  5. The UEFI BIOS should now be fully re-flashed and updated! Reboot and give it a try!

Thank you,
I understand, but I can’t flash original bios (cap) with afuwinx64.exe 3.05.04 …

AFUWINx64.EXE image9s.cap
| AMI Firmware Update Utility v3.05.04 |
| Copyright (C)2013 American Megatrends Inc. All Rights Reserved. |
46 - Error: Problem getting flash information.

@okokokok :
If you cannot use AFUWIN, try the ASUS AISuite method as written within the start post of this thread.

I downloaded AI Suite II and III but it is not possible to install, because I Havn’t Asus board. There is Lenovo board… :frowning:

@okokokok :
Ok, I didn’t remember the manufacturer of your mainboard.
Since I don’t have any experience with Lenovo mainboards, I cannot help you.
Maybe @Lost_N_BIOS knows a solution for you.

my.own experience flashing modded bios on supermicro x10drh-cln4…i used ami flash tool 5 (aptio v), because flash tool 4 was not compatible with my rom/motherboard. used windows gui tool, downloaded from website of ami.
nothing extra options on gui clicked, just loaded modded bios and flash main bios image
now my board recognizes m2 nvme in pci-e adapter

SuperMicro X11 motherboard Must the main BIOS be corrupted to enter recovery mode?
Why can’t I go into recovery mode after inserting the flash drive into the super.rom file?


I used Acronis True Image 2020 to clone my c:\ hard drive running Win 10 to the ADATA XPG SX8200 Pro 1TB SSD using the VANTEC UGT-M2PC200 M.2 NVMe adapter. When I removed the old hard drive and rebooted, even the latest Asus BIOS would not recognize the ADATA SSD and therefore would not boot windows.

After a lot research, trial and error, and a tons of frustration I found a method that worked to fix the problem:

Modding the BIOS

Downloaded latest BIOS from ASUS: H87-PLUS-ASUS-2003.CAP

I learned that the .CAP extension means there is a file header that makes the BIOS harder to modify and so it must be removed BEFORE you modify the file.

To remove the .CAP file header you must load the .cap file into AFUWINGUI.exe program and press Save. This will save the file as H87-PLUS-ASUS-2003.rom Now the file is sightly smaller (by about 2 KB). The header has been removed.

Now this H87-PLUS-ASUS-2003.rom file needs to be modified to add the NvmExpressDxe_4.ffs file to it. I did this using MMTool and followed Fernando’s Guide #1 directions carefully. This file should have the same name when you are finished: H87-PLUS-ASUS-2003.rom

The H87-PLUS board does not have the “USB Flashback” Port. To load the modified BIOS onto the computer that is running Windows 10 OS: Using an elevated command prompt within Windows 10, run the AFUWINx64.EXE file using the ORIGINAL UNMODIFIED .CAP file:


let it finish

now run the program again using your modified ROM file with the /GAN tag after it:


let it finish

Now shut down the computer.

I unplugged the old hard drive(s) and left only the SSD with Windows 10 on it. Turn the computer back on and press Del to get into BIOS and voila! The SSD is now recognized! Set the BIOS to boot to the Windows Boot Manager on the SSD and exit. Computer loads up Windows 10 just fine. Now shut down and plug in old hard drives and make sure that the SSD is the 1st boot priority. Also make sure to disable Fastboot in the BIOS as I read that this can cause data loss.

Hope this helps someone. Many thanks to all who contribute to and run this forum!

just wanted to report in with another ASUS flashing method that worked well for me.

on an ASUS Z9PR-D12 I was able to use the included BUPDATER.EXE DOS tool to backup the bios of the motherboard into a unsigned ROM (rather than the CAP it would be if downloaded off the ASUS site), add the NVME DXE to that backup, and then flash the modified rom back via BUPDATER.EXE

seems simpler than some of the other processes if your motherboard has a tool to make a backup of the existing BIOS

I’m looking for somebody who can help me to modify bios on P8H77-I Asus mainboard. I’m stuck at no booting NVMe m.2 disk.
I know how to insert NVMe module and save bios file (MMTool or Uefi Tool) but still i have a problem with upload cap or rom mod file to moinboard.
I downgrade bios from 1102 to 0816 as #Bucho in this post: [Guide] How to flash a modded AMI UEFI BIOS (4) but all the time asus protection stops me.

Here [Guide] How to flash a modded AMI UEFI BIOS
Follow instructions for Asus motherboards without Bios FlashBack on first post.

@OldGuy : @stealthwang :
Welcome to the Win-RAID Forum and thanks for your reports, which may be interesting for other users, who are trying to get a modded ASUS *.CAP BIOS file properly flashed!
Dieter (alias Fernando)

Hi. I followed the guide to update the modded bios on my Asrock x470 board but I still get the security check failed. I used UBU. Does anyone have any advice? Thanks.

@devast8ndiscodave :
Welcome to the Win-RAID Forum!
Which tool and which procedure did you use, when you tried to flash the modded BIOS?
Dieter (alias Fernando)

@Fernando Thank you.

I used the method on the first page. Allowing UBU to remove to security marker the flash in bios with instant flash. I also tried using afugan /gan from another forum. Both gave me an error.

This is what I am trying to flash.


@devast8ndiscodave :
You should better ask our BIOS Guru Lost_N_BIOS for a solution. I cannot help you.

@Lost_N_BIOS :
Do you know how to get a modded ASRock X470 BIOS properly flashed? The removal of the ASRock “Security Flash Check” code done by the UBU tool obviously doesn’t work with some ASRock mainboard BIOSes.

Bloody brill mate, just modded and flashed a uefi bios to my ASRock AM1 AM1H-ITX motherboard.

I have problems successfully flashing my Asus ROG-Strix-X570-E-Gaming.

I can easily replace the RAIDXpert2 UEFI driver with UBU tool and after that it shows the correct version - I am doing the standard Asus flashback via the special USB port. It shows that it’s flashing as per normal - the light is blinking and so on. After it’s done, I reboot it, reconfigure the UEFI settings and everything looks fine. However, when I check the RAIDXpert2 UEFI driver in the BIOS, is still shows the old version - 9.2.x.x. I am wondering how is this possible since the module has been inserted successfully by the UBU tool. I tried every recommended method, but all of them give error when I try to flash it. Only the flashback is working, but then it still shows the old RAID version.

Any ideas?

@bobypf :
Retry to flash the BIOS by using another (small sized FAT32 formatted) USB Flash Drive. The USB Flash-Back procedure is very picky regarding the used disk.

@Fernando :
It’s not that for sure. I’ve used the same USB memory drive to do flashback before a few times and it works.