[Guide] How to get M.2/PCIe connected Samsung AHCI SSDs bootable?

Sorry to bother you, I think I need some help.
I have a similar Apple SSD (gen4, SSUBX, product by samsung), but it cannot boot my PC(Dell Optiplex 7010 with Q77 chipset), I have already inserted SAMSUNG_M2_DXE into bios.
The SSD can be recognized by the Windows installer and it can boot my other PC(Z170 chipset).
Is the bios missing other modules?

According to my knowledge your Apple SSD uses the SATA AHCI protocol and should be bootable after the insertion of the SAMSUNG_M2_DXE module into the BIOS. A simple clone of an NVMe SSD will not work, because the SATA SSD needs another boot sector (EFI Boot Partition).
A clean install of Win10/11 should be successful.

Thanks for your reply.
I tried to make a clean install of win10(I already set SSD to GPT), after file copying finished then reboot, I still cannot find this SSD in UEFI boot option.

You may not find the SSD’s name as bootable device, but after having done a clean install of Win10/11 onto it you will see the “Windows Boot Manager” (= EFI Partition of the SSD) within the “BOOT” section of the BIOS.

Thanks for your reply again.
The question I met was Windows installation cannot finish normally, windows installation interupted after first reboot because bios cannot find the EFI Partition of the Apple SSD.
Then I tried another way, I cloned the whole data(includes patition table and a complete clean install of win10, of course also includes EFI partition) from a bootable SATA SSD to this Apple SSD, but still no success.
So I think the most likely reason is Dell Optiplex 7010 bios cannot recognize AHCI SSD via PCIe, even though SAMSUNG_M2_DXE has been inserted into bios, bios still missing some module for recognizing AHCI SSD via PCIe.

Provided, that
a) your currently in-use mainboard BIOS contains the properly inserted Samsung M.2 SATA AHCI EFI module and
b) your Apple SSD has been formatted by using the NTFS file system,
I agree with you.
Are you able to detect the HardwareIDs of the SATA AHCI Controller, which is used by the Apple SSD?

Yes, I find the Hardware IDs of the SATA AHCI Controller which is used by the Apple SSD in Windows device manager(boot by another SATA SSD) is

Thanks for posting the HardwareIDs of the in-use SATA AHCI Controller. Since its manufacturer is Samsung, the inserted M.2/PCIe BIOS module should be compatible.

I tried many things but nothing worked. So this Apple SSD seems cannot be a bootable disk in my Dell Optiplex 7010. Things maybe change after I find the missing driver to make the bios recognize this SSD, because I’ve seen someone succeed on Gigabyte GA-H81M-DS22 and Asus B85M-G MB.

Provided, that
a) the in-use M.2/PCIe connected SSD is a Samsung one and uses the SATA AHCI protocol,
b) the module named SAMSUNG_M2_DXE.ffs has been properly inserted and
c) the modded BIOS has been successfully flashed,
the M.2 SSD should be bootable in UEFI mode.
If the SSD should not be detected by the BIOS as being bootable, I recommend to create the required EFI boot partition named “Windows Boot Manager” by following “Step 4” of >this< Guide, which has been written for NVMe SSDs, but should work with M.2/PCIe SATA AHCI SSDs as well.

a) the in-use M.2/PCIe connected SSD is a Samsung one and uses the SATA AHCI protocol

Yes, my Apple SSD is a Samsung product with AHCI SSD Controller. here and here

b) the module named SAMSUNG_M2_DXE.ffs has been properly inserted and

Done. I’ve tried 2 versions of the SAMSUNG_M2_DXE.ffs(6,796Bytes and 6,741Bytes).

c) the modded BIOS has been successfully flashed

Done, with fptw64.exe.

Now I finished all steps of “Step 4” what you suggesed in >this<, but SSD still cannot de detected by the BIOS, I mean there is no device in legacy mode, and no EFI item in UEFI mode.

If you really were able to complete my Guide’s “Step 4”, you got Win10 or Win11 successfully installed onto the PCIe connected M.2 SSD and should see the device named “Windows Boot Manager” as bootable device within the BIOS.
This means, that the SSD is bootable in UEFI mode, although its original name “Samsung XYZ” is not listed within the BIOS.

I’m sorry, there is a mistake.
I followed the steps of “STEP4”, I finished 4.B.7, but I couldn’t finish 4.B.8.
The win10 installer needs a rebooted once after the file copy is finished to continue the installation.
After installer make a reboot automaticly, windows installation interrupts, because still no boot option in UEFI mode(usb device has been removed).

Please attach your modded BIOS (or give me a link to it).

How did you verify, that the BIOS update was successful?
Please make a BIOS dump and post a link to it.

Please attach your modded BIOS (or give me a link to it).

bios_samsung_modded.rar (5.7 MB)

How did you verify, that the BIOS update was successful?

I redumped the bios and confirmed that SAMSUNG_M2_DXE is indeed in the bios.

Thanks for the quick response. and the modded BIOS.
The insertion of the SAMSUNG_M2_DXE module seems to be correctly done.
Interestingly the DXE Volume of the BIOS contains additionally 2 mysterious modules named “AHCI” and "PCI_Express_DXE. Their function is rather unclear for me. Maybe there is an interference with the SAMSUNG_M2_DXE module, which prevents the ability to boot off the Samsung M.2 SSD.
My support ends here, because I don’t know how to solve this specific problem.

Thank you all the time. I’ll try more and I’ll reply here if there are good news.

I have a Samsung PM951 128GB Nvme that i will like to use in my Abit IP35 Pro.
The PM951 is an AHCI type Nvme.
The last official Bios (ID 17) for Abit Ip35 Pro has AHCI fonctionality.
Does this mean that motherboard will recognize the SSD and accept it as a boot drive ?
Or there is more to it than simply adding 1+1.
Please advise, thank you.

@Habato Welcome to the Win-RAID Forum!

Probably not. “AHCI functionality” usually means “Support of the AHCI protocol for HDDs/SSDs, which are connected to one of the on-board SATA ports”. To be able to boot in AHCI mode off a PCIe connected M.2 SSD like the Samsung PM951 an additional “DXE Driver” module is required within the BIOS.
Good luck!
Dieter (alias Fernando)

My apologies for jumping into a completely different topic.
Thank you for your help. I will be more cautious from now on.