[Guide] How to get Win7 installed onto a Samsung NVMe SSD

Good morning folks!
I’ve tried reading through this thread to solve my problem, but I’ve quickly gotten lost, so I’m hoping you guys can help me out.
I’m trying to build a new workstation (specs below), and cannot install Windows for anything.
I really need to install Windows 7 Pro x64, since that’s what I have a license for, and what my other office environment machines are all working on.
I have a couple different windows discs (and a USB drive) but can’t get any of them to install.
I’m sure it’s a combination of the USB3 driver issue and drivers for the Samsung 960 EVO M.2, but I’m not sure that’s the only issues.
One of the Win7 discs I’m trying to use is a custom OS that has lots of drivers slipstreamed in. That one is on a USB drive. I also have a DVD that’s a basic OEM disc. All drives (SATA and M.2) show up in BIOS, but only the SATA is listed in the “choose a drive” dialog in Windows setup. I was going to try the option to install to the SATA, then clone to the M.2 after getting the NVMe drivers installed, but when I choose the SATA drive, I get an error about windows not being able to create or find a partition. This is the case even if I create the partition manually through disk management.
Also, the machine has stopped recognizing my USB drive after boot into the PE. It will boot FROM the USB, it just won’t allow me to mount the USB drive to load drivers or anything from it. This is true whether I plug it in during boot or after. What’s odd is that I was able to do that earlier in my install adventure, but not now.
I have the motherboard support DVD in the 2nd ODD (there are 2), and it claims to have NVMe and USB3 drivers on it, but when I use F6 (load drivers) to try to load the M.2 drivers, it says there are none found, even if I browse right to the folder. If I uncheck the “hide incompatible”, then I can select the NVMe driver, but it tells me it’s unsigned and won’t let me use them.
I’ve downloaded the latest “pure” drivers from here, but since I can’t mount a USB drive, I can’t find a way to load them!

I even got desperate and tried loading Windows 10 as a test, but it gives me an error about failing to load “boot critical drivers” and setup halts.

I’m so frustrated right now. I’ve built probably 20 machines of all descriptions over the years, but this one has truly stumped me. Any help GREATLY appreciated.

Hardware specs:
CPU: Intel Core i7-7700K
Motherboard: ASUS PRIME Z270-A LGA1151 DDR4
Primary drive: Samsung 960 EVO Series - 250GB PCIe NVMe M.2
Secondary drive: Samsung 850 EVO 500GB 2.5-Inch SATA III
32GB Crucial Ballistix Sport LT (16GBx2) DDR4 2400 MT/s (PC4-19200)

@Elmojo :
Welcome at Win-RAID Forum!

To get Win7 installed onto your Samsung 960 EVO SSD, you have to
a) create a bootable FAT32 formatted USB Flash drive with the Win7 x64 image (create it by usung the tool Rufus and make sure, that you chhose the GUIMode Partition Table as boot sector),
b) prepare the 64bit Samsung NVMe driver v2.2 to be loaded at the beginning of the OS installation,
c) unplug all other drives except the Samsung 960 EVO and the bootable USB Flash drive with the OS image,
d) enter the BIOS and choose the required settings to be able to boot in UEFI mode, turn off the "Secure Boot" and the "Fast Boot" options,
d) boot off the USB Flash drive in UEFI mode,
e) load the prepared NVMe driver,
f) let the Win7 Setup delete all existing partitions from the Samsung 960 EVO SSD,
g) create a new partition with the desired size and
h) let the OS Setup do the rest.

Good luck!
Dieter (alias Fernando)

Thanks so much for the step-by-step!
I feel like I have a chance now.
Couple questions on the line items before I begin…
a) In Rufus, that’s the “GPT partition scheme for UEFI” option, right?
b) How exactly do I “prepare” the driver? I have my OS image and the drivers I need it to load before trying to installing anything, but I’m not sure where to put those drivers to make it load them first.
c) Will do. Even the ODDs?
d) I don’t see any option for ‘secure boot’. I recall seeing that on older Asus boards. Is it possible it’s been removed on the Z270 boards or am I just not finding it? Fast boot will be disabled.
e) How? Via F6/load drivers during windows setup or otherwise?
f) OK
g) roger that
h) Yay!

EDIT by Fernando: Unneeded parts of the fully quoted post and blank lines removed (to save space)


Just unzip the downloaded NVMe driver files onto a separate USB Flash drive and insert this USB Flash drive , when you get the option "Load driver" from the OS Setup.

I would do it (just unplug the data or power cable)

It is a BIOS option. If you don’t find it, look into your mainboard manual. My Z170 mainboard BIOS listed it within the section “Security Screen”.

You will get the “Load driver” option, when the OS Setup doesn’t find the target drive (and it will not find it without the driver).

Good luck!

Well, made some progress, but still a no-go.
I found the secure boot (didn’t notice that page scrolled) and disabled it.
Disabled fast boot.
Prepared USB drive with Rufus using settings suggested.
Added NVMe drivers to separate flash drive.
Flashed latest BIOS updated from ASUS, just in case.
Unplugged all other drives, including ODDs.
Booted from USB. PE loaded, but no option to install appeared, since no drives were found.
I tried a different (non-customized) Windows 7 image, also prepared in the same way using Rufus, and I get an error about a required CD/DVD driver being missing. I recall this actually being a USB error.
Additionally, the second flash drive also doesn’t show up at all, so I can’t load any of the drivers that I have ready.
I know it’s reading USB, since it’s booting from the USB drive, and my keyboard and mouse are working, all from USB3 ports.

I’m currently using the ‘EZ-Installer’ tool provided by Asus to build another USB drive, hopefully with better results. That tool claims to load USB and NVMe drivers, so we’ll see…
This thing is really kicking my butt at the moment! >:(

EDIT: The Asus tool failed. It got stuck on the “mounting .wim file” step and never moved on, so I terminated it. I went back to Rufus and built a new USB drive, using my OEM Win7 image, and some instructions I found on the Asus site that suggested using the support DVD to load the drivers.

SUCCESS!! I had to plug in the ODDs, but with the DVD drive, and both USB drives, I was able to get it to boot into Windows setup (from USB1), load the USB drivers (from the DVD) and then let me load the NVMe drivers from USB2.
What a mess! I really wish Windows 10 didn’t suck so bad, so I could migrate our office over to it and be rid of all this hoop jumping.

@Elmojo :
Thanks for your feedback and your report about how you managed to get Win7 installed onto your NVMe SSD. It is fine, that you succeeded.
To make it easier for other users with a similar problem to find the solution, I have moved our discussion into a separate thread and gave it a new title.
I hope, that this is ok for you.

Enjoy the performance of your NVMe SSD while running Win7!

Absolutely! Thanks so much for your help!
Splitting it out to a separate thread was a great idea.
You might want to add "Samsung 960 EVO" and "Asus Z270" to the thread title, to help others with similar issues find it.
I suspect my troubles were somewhat specific to the combination of Win7, that NVMe SSD and the 200 series motherboard, since I built a nearly identical system, but with a 100-series motherboard about a year ago and had very little problem.
On that other machine, all I had to do was load the USB drivers and all was good from there.
Thanks again!

On the other hand a too specific thread title has the disadvantage, that a user with a Samsung 960 PRO or an ASRock Z270 may start a new thread without having looked into this one.
My step-by-step guide within the second post is valid for all Samsung NVMe SSDs and for all mainboards, whose BIOS natively supports NVMe (all Intel Chipsets from 9-Series up).