[Guide] How to make Z370 chipset MBs compatible with 128GB RAM

Ohhh to clarify, I think I made a typo, I mean 8000 to 0001, but when I do it with the small s -s, the bios seems not to work, since I tried to backup the bios after update and still see the hex in 8000, that’s why flash with -S the second time. What can I do now, the PC is stuck in a boot loop >_<

@bios_guy - send me your BIOS dump not modified by you, and I will modify it for you to disable the ME FW. Sounds like you aren’t doing something right, and I would not suggest using ME Cleaner for this anyway.
If you cannot boot your board now it’s probably bricked and you will need flash programmer setup (CH341A + SOIC8 test clip w/ cable)

For Gigabyte , you need remove MeRecoveryDxe GUID:F1FCD66F-8966-441E-909C-77F211AB9C3E , if it exists. Or it wont let you boot into system when you set HAP bit.
And do not change 0001 to 8000 , just set HAP bit, it’s enough.

@dsanke - I asked at #16, but maybe you missed it, do you know how to do this for X79 (Asus)? Many models have BIOS already put out for 128GB, but not Asus Rampage IV Extreme
I tried to find in various BIOS modules, but nothing looked similar. If you have time to check that would be great, thanks

I dont see anyone using R4E and 128G and found problem. I think there is no need to modify. I think all X79 should support 128GB initially.

@dsanke - Thanks for checking on this! I was asked by user to fix here in the forums, maybe he didn’t test? I will ask him if he’s tested 128GB yet or not.
All I know is MANY Asus X79 got latest BIOS update with +128GB fix added in change logs, and that board and few (2-3 I know of) others didn’t get update or new change logs etc.
[REQUEST] Enable Bifurcation settings +++ on Asus Rampage IV Extreme

@Lost_N_BIOS , Here is the Bios without any modification that I was using, F8 for Gigabyte Z370 HD3
https://gofile.io/?c=9QzVNz is the download link, I can’t upload it here because it is bigger than 6MB

@bios_guy - is your system bricked now, or what’s going on? You could have linked me to the Gigabyte BIOS download, if that is stock BIOS (I assume it is, and will download from them now since I know your board now)
I asked for dump assuming you were using programmer, so MAC ID would be preserved in BIOS and any other board specifics such as serial, UUID, NVRAM etc. Since this is Gigabyte, please tell me how you are flashing etc, that way we get things correct.
If you are using FPT I need you to dump your BIOS with FPT (FPTw -d SPI.Bin), then zip it and then send to me. if you are using Qflash then I can just mod the stock BIOS. If you are just reflashing ME FW region with FPT, then I can use stock BIOS too and send you only a mod ME FW region to use
Need to be sure what/how you are doing things before I proceed with any edits.

Also, please confirm, since it’s not latest BIOS, you are using F8 from this page (HD3, not HD3P) correct?

I think it is bricked now, there is no way to reset unless I got those hardware to actually reflash it, I flashed with efiflash.exe modified by dsanke, I think it is 0.72 version, so now my PC is just in boot loop. Could you upload the .F8 bin you have modified???

@bios_guy - There is no “Think” only brick or not I have not modified anything, was waiting on answers to all my questions above before I did anything. And if you can’t boot to BIOS/Qflash or DOS, then you can’t flash anything anyway.
You can try PSU trick method to make backup BIOS kick in, if it will work on your system (See method #2 - do not use method #3 it’s not for this BIOS type) - https://www.overclockers.com/forums/show…te-motherboards
If you can’t get with PSU trick, and your board does not have BIOS switches, then yes you will need flash programmer + SOIC8 test clip with cable.

Flash via Q-Flash in BIOS, use “Intact” mode.

I fixed my PC with flash programmer + SOIC8 test clip with cable, thx!

just wondering if asus Z370-i supports 32Gx2 ram.
would you please look into it and do the modding for me? thanks

Every LGA1151 motherboard can support 64G RAM without BIOS modification.
Just do not use some 4Rank double size memory.

thank you

hey, dsanke, it works, thank you so much

@dsanke - is ME FW version OK to do this with, or need older one?

@Lost_N_BIOS No ME FW version requirement, but must set HAP bit.

Can’t get hackintosh to work afterwards, what exactly did you change @dsanke ???

@dsanke The instructions are kind of vague, I’m having trouble on how you found the offsets to hex edit, I understood step 1 but not the rest and also did how you set HAP bit?