[Guide] Manual AMI UEFI BIOS Modding

You should ask ASUS, not me.
I had a similar problem with my ASUS P8Z77-V, where the ASMedia AHCI ROM was missing.

Thanks for the clarification, which may be useful for other users with a similar problem.

@ all:

Due to the fact, that there is a new AMI Aptio UEFI MMTool v5.0.0.7 available now, which is able to modify all AMI UEFI BIOSes incl the new X99 mainboard ones, I have totally revised my guide, which is layed down in the start post of this thread.

Update of the start post


  • new: complete guide
  • replaced: all pictures

All suggestions for an improvement of the guide are welcome!

Good luck!
Dieter (alias Fernando)

I believe that both MMTools (4.5 & 5) need to be linked at the start of this guide after explaining that 4.5 is for Aptio IV and 5 is for Aptio V. The only reason I’m saying this, is because MMTool v5 is not fully compatible with IV images (cpu microcode etc according to SoniX, lordkag) and so it may lead to problems (preparing an Aptio IV image with MMTool v5 and end-up with a corrupted image without knowing it). It’s the same “advice” (not that I have an Aptio V system to test) I gave at the UBU thread.

Other that that, it looks perfectly fine.

thanks to the author for his work.
I’m new to editing the BIOS, and I can not decide for himself.
be saved (CPU microcode) of the BIOS №1 and add (micocode bios#1) to the bios №2.

@ Nippy:
Welcome at Win-RAID Forum!

Decide between what?

If you are unsure regarding the CPU Microcode, I recommend to use the UBU tool (look >here<).

Dieter (alias Fernando)

my CPU (ES)
because I want to add microcode from a working version of the BIOS.
UBU tool delete my old cpu-microcode and add new.


Was wondering if its safe to not just update device modules but other modules like mousedriver, and core_Dxe and a bunch of the other modules that are in the bios file? For example I have a z87x-ud5h and was looking in the z97-ud5h bios file which looks very similar.


Any change of such modules is risky. Furthermore you may not benefit at all by doing it.

Does anyone know how to integrate Gigabyte’s 3D BIOS from BIOS Version F14 to the latest BIOS F20?
It was removed from version F16 and onwards.

Here is the F14 BIOS: http://download.gigabyte.ru/bios/mb_bios_x79-ud3_f14.exe
Here is the modded F20 BIOS that I made: https://drive.google.com/file/d/0BwnCOMH…VBUaDhwVGc/view using your UBU Tool.

@ rootuser:
Welcome at Win-RAID Forum!

I don’t know it, but I hope, that you will get help from someone else.

Dieter (alias Fernando)

I tried to use MMTool 4.5 but I can’t find the Module that specifies the 3D-BIOS when I was opening BIOS F14.

EDIT by Fernando: Unneeded fully quoted text removed (to save space)

Your 3D GUI is in the attached file. You have the GUID of images location and also an offset in that specific GUID. The problem is that Gigabyte is using a header for each image, that stores info related to its properties or placement in GUI, so any image change will have to be reflected in that header. You said you just want to port this GUI, so this problem is out. But the new file is changed, images are stripped, the GUID is different. Even if you insert the old GUIDs, the menu won’t change, since it is likely that there is nothing in the BIOS code that will try to use them.

However, if you have Dual BIOS, you can try to insert these old GUIDs and see if the menu is changing. Notice that two GUIDs are already present and don’t contain relevant changes, so you might just leave them as is.

Gigabyte_3D.rar (1.35 MB)

Gigabyte_new.rar (58.3 KB)

Will try it now :smiley:
@lordkag What tool did you use to extract all these files?
I tried to insert the files and rebuild the BIOS by using the UEFI Tool 0.20.5 and I flashed it to my computer but the GUI didn’t change.
Am I doing it right?
So how do I reflect the change in the header to make the 3D-BIOS as a option in the GUI and make the menus useable like BIOS F14?

Lordkag had written a very good post somewhere on how these work based on manufacturer and how to edit them (maybe even posted a small tool? don’t remember). I can’t find it now but I’ll guess someone else will post a link to it.

@lordkag Do you have the link on about what @plutomaniac said about specific manufacturer bios mod?

It is a personal tool, but it won’t do any good for you. You are not trying to change something in the GUI, you are trying to replace it entirely, or more likely create it. I don’t know why Gigabyte removed it (space problem or just to make newer cards look better), but they also changed the way the GUI is loaded. My bet is it has to do with AMITSE and you pretty much are out of options. I mean, if you look at the images, they left almost nothing.

So it looks like they rebuilt the BIOS from the ground up. I was trying to add it as an option in the BIOS like F14 where the was an option to click on ‘3D BIOS’ and it would load up another GUI. They must of have deleted all references to it.


Does anyone know how to mod the BIOS and POST? They disabled it in the latest BIOS and I can’t flash an older BIOS to mine.

So, how do i go about updating my ASUS X99-A orom when its unsupported in these tools?

I am sorry, that obviously nobody knows a way.

If your mainboard BIOS is an AMI AptioV one, you may have to use CodeRush’s UEFITool.