[GUIDE] Modifying/Flashing Dell Bios using PhoenixTool (Updating to new RST ROM)

I couldn’t find any information surrounding this topic myself outside of posts pointing people in the direction of PhoenixTool (which based on what I’ve read is not allowed to be linked on this forum, some simple google searches will find it though).

Step 1
The first step is to identify the Bios for the specific system you have. In my case this was an Dell Optiplex 980 I was able to obtain the latest Bios A18 from the following URL:
https://www.dell.com/support/home/us/en/…lex-980/drivers
https://i.imgur.com/e5Cda0r.png

Step 2

After obtaining the executable provided by Dell open it in Phoenix tool and wait for it to finish loading, you’ll know when it’s finished based on the log output telling you it found the public key.
https://i.imgur.com/8KePZJq.png

Step 3
Click the advanced button for Phoenix tool and enable/disable options to match the image below:
WARNING: These may not be the appropriate options for your setup as you may need it to alter the ACPI tables for it to work for you. With my system this was not the case.
Note: I’d advise testing without modifying any modules and check the hash against the .hdr file that’s created and the SLIC.hdr file that’s created to determine if it’s the same without modifications, in theory this will tell you Phoenix tool is at least properly rebuilding the original bios.

https://i.imgur.com/IGqxRVy.png

Step 4
Press the Go button within Phoenix tool and wait for a popup indicating you’re able to modify the files within the DUMP folder:
https://i.imgur.com/eWlnAms.png

With the popup shown above still open, navigate to the dump folder and identify the module you’re attempting to modify, add, or update.

In my case I was looking or 20_22.ROM which is the Intel Rapid Storage Rom, I can confirm this by looking into the contents of the file using a strings application ( A hex editor will also do the job ) and seeing the Intel Rapid Storage string inside of it:
https://i.imgur.com/KNBZpGu.png

Step 5
Now that you’ve identified the ROM you need to update go to here and find the ROM that you’d like to change it with, in my case I used Intel RST RAID ROM v11.2.0.1527 which appears to be the recommended one for Raid 0 configurations.

Note: I did try a few others, and tried one I believe was unsupported on my hardware (v17). While doing this I obviously risked bricking but luckily it seemed to just not show the RST screen during the boot process so I assume this is mostly safe but always proceed with caution and double check your chipset is supported.

Once you have the file extract the .bin from the archive and replace your ROM file (in my case 20_22.ROM) with the updated ROM, I deleted 20_22.ROM pasted the new bin in the folder and renamed it appropriately.

Step 6
Press the OK button on the popup and wait for the Phoenix tool to say that “SLIC was completed successfully” even though we’ve told the tool we don’t want to use it’s SLIC functionality.

https://i.imgur.com/sgogMMJ.png

You should now have two files in the folder where the Dell bios update exe was one simply named the same as the bios update and an HDR extension (This is the original bios update in HDR format) and one with _SLIC.hdr (This is your updated file).

Flashing the updated HDR file to your system
This part took me awhile to figure out as most people say there’s a /readgzfile flag you can use on the exe with a bios.gz file that Phoenix Tool generates (while it does generate this, my bios update did not have this flag).

If you want you can try that first before continuing through the guide, but in my case it absolutely did not work.

The next method people recommended online was DCCU (Dell Client Configuration utility) you can install this on any windows system and run it, uses a web browser you provide the HDR and it generates an exe file… but again in my case this did not work. You can feel free to try it.

One of the last methods I had tried was flashrom with internal programmer option, I would probably recommend against even trying this at all considering there’s an easier ‘official’ (yet deprecated) method to write the dell bios to memory and have it do it’s standard update process which is what I’m going to go over. When attempting flashrom I ran into problems as Intel ME was locking memory regions which is why I also skipped over this.

So that brings me to the way you can do it if everything else above fails:

Using dellBiosUpdate utility in linux
1. There’s multiple distros which will have the package but I personally recommend grabbing an Ubuntu 14.04 Xenial Live CD image and booting into that.
The version here is important, in 18.04 /bionic dell started removing their bios tool from the packages on the repo.

2. You’ll want to sudo su at this point as everything we do from here on will mostly require root.

3. Once you’ve got it booted you’ll want to replace the file located here /etc/apt/sources.list with the following one: https://gist.githubusercontent.com/rohit…a9/sources.list
The reason for this is that the original sources file on the disk does not have the appropriate repositories which contain the dell tools.

4. Run apt update

5. Run apt install smbios-utils

6. Get a copy of the modified HDR you created previously into your Ubuntu Live CD instance (in my case I scp’d it from another machine after installing SSH)

7. Run dellBiosUpdate --override-version-check -u -f ./myfile.hdr

–override-version-check will bypass version checks in-case you’re re-flashing the same bios version you’re already on, or a lower version.
-u specifies that you’re updating the bios
-f specifies the file you’re going to update to, myfile.hdr would be the _SLIC.hdr file you generated using Phoenix tool previously.

If all goes well you should see output similar to the following:

1
2
3
4
 
root@ubuntu:/home/ubuntu# dellBiosUpdate --override-version-check -u -f ./O980-A18_NEW_RST_ROM.HDR 
Performing BIOS update...
Update successfully staged. Reboot the system to begin BIOS update.
No reboot option specified. The --reboot option is highly recommended.
 


I would recommend waiting a few seconds before actually rebooting as I ended up having times where the system would say it didn't have the update in memory.

After rebooting your system should boot up to this screen:
https://i.imgur.com/lDbBMIP.jpg

And if the update was successful, just after you should be greeted by the new version of RST:
https://media.discordapp.net/attachments...0309_163909.jpg

I hope this short/sloppy guide helps other people when dealing with Dell bios and trying to flash them back to their system as well. This took a good 12-13 hours to figure it out for me, hopefully this makes it an hour or less process for you.

EDIT: Removed image tags as images are large and board doesn't like the size. If an admin/mod wants to try to clean this guide up to help others that'd be cool otherwise I hope it helps as it is.