[Guide] NVMe-boot without modding your UEFI/BIOS (Clover-EFI bootloader method)


the short answer is yes it will boot that, but there may need to be some edits to the windows boot loader on the new clone drive in order to get it to boot.


one of mine did this also but after waiting a bit it failed over to legacy(non uefi) and worked anyway. as of the moment i have no idea how to address this issue and i would certainly be interested if someone figures it out.

Thank you for your reply. I’ll fool around with it for a while and see if something happens. Thanks again.

I had the same problem.

Try to rename the "boot" file into "boot-ori" and then rename "boot7" to "boot".
After this the Clover Menu comes up after reboot.

Good luck!

So You are saying i should just install windows on a test hdd connected to the system i want to run nvme m.2 from and run BDU from there to create the flash drive?
Thanks in advance!

After several weeks of research, I finally managed to successfully install Clover on a 2009 (!) legacy BIOS (non UEFI) system.

My system :

MB : Gigabyte GA-MA790XT-UD4P (2009)
CPU : AMD Phenom II X4 955 (2009)
NVMe to PCIe adaptor

I successfully installed the following OSs on the – non bootable - NVMe SSD, and I am able to boot any one of them through Clover :

Windows 10
Windows 11
Linux Mint LMDE 4
Kali Linux
Ubuntu Server [Edit : 26/06/2022]
Emmabuntüs [Edit : 01/09/2022]

I created the Clover USB key using Boot Disk Utility v.023 and Clover v.4961.

For reference, from the Clover key, it takes 13 s (thirteen seconds) to start Windows 11 and 15 s for Kali Linux. Not bad for a 13 year old rig !

Clover is a wonderful tool and I can only encourage others who have a legacy platform to use it !

1 Like

I’ll try this as soon as i can. thx.

So, i tried what Franzl_Lang said to do and it worked! i was able to boot into clover. However, i could not get clover to see the SSD. I tried the post at #596 but i did not try the post at #613. I am disinterested in continuing becaue I’m under the impression that Clover can only see a NTFS drive. Can Clover also see ext4 on a gpt NVMe drive? I would like to install ubuntu on my NVMe. If i am wrong please tell me otherwise, thank you for your replies.


This is incorrect clover is a full bootloader and was designed for osx, it can see any partition format including ext4 I have dual booted with Ubuntu via clover myself. Please ensure you add the partition guid to the config.plist file. If I recall you need to add it under the boot section.

For sure you are wrong.
Clover can boot to an OS installed on a EXT4 partition (Linux) on a GPT NVMe drive.
This is what I did when I installed both Linux Mint (LMDE 4) and Kali Linux on my NVMe drive (which is linked to my MB through a PCIe adaptor).
I have also installed Windows 10 and Windows 11 on the NVMe SSD. Everything works.
See my post #817.

Since you have created a Clover key which - apparently - works, have you tried to insert an Ubuntu USB installation drive and see if Clover can recognize it ?
Since I have recently done successfully what you are trying to do, I might be able to guide you further. Just advise…

Hello all,

I have here an old Lenovo T400 with a ThinkMods NVME adapter.
This adapter has an built-in SD card with 2 GB in addition to the installed Sabrent SSD.
The purpose of this SD card is to boot Clover from there (so without USB stick) and then use the SSD for various operating systems (eg Windows 10).
On this SD card Clover is installed with all drivers - but unfortunately I do not manage so far to boot Clover via this constellation (black screen / blinking cursor).

Therefore I have now prepared a USB stick (on the T400 via a former Win7 installation) via BDU and can get into the Clover menu with it (via boot7 as described in post #815).
Unfortunately Clover only shows the 2 GB SD card as bootable medium and not the connected SSD (GPT and NTFS formatted) or any other USB-Stick.

The plan now is:
1. exit Clover (bottom right menu)
2. boot maintenance manager
3. boot from file
4. choose Rufus prepared Win10 image USB stick
5. choose EFI/BOOT/boot64x.efi
6. Install Win10 on NVME-SSD

Unfortunately something still seems to be fundamentally wrong.
When I exit Clover and try to go into the Boot Maintenance Manager, the Boot Manager, the Device Manager or just continue the boot process, Clover crashes with an X64 exception (black screen / red text).

How can I prevent this, or what is wrong?

Greetings Franzl

I have recently succeeded in installing Windows 10 and Windows 11 on my non-bootable NVMe SSD, so I hope to be able to help you based on my experience. See my post #817.

I am not sure what you mean by “Clover does not see the ……. drive”.
From my experience, Clover does not show drives, but OS installations. So, if you do not have any OS installed on your SSD at present, as I presume, you should not bother about this.

So you have gone through:
Exit Clover → Boot Maintenance Manager → Boot from file → Windows 10 USB drive → <efi> → <boot> → bootx64.efi
This is exactly what I did to install Windows. You’re on the right track !

By the way, after you created your Clover key, did you copy the ‘EFI/CLOVER/drivers-Off/drivers64UFI/NvmExpressDxe-64.efi’ driver to:
‘EFI/CLOVER/drivers64’ and to:
‘EFI/CLOVER/drivers64UEFI’ ?
This is essential !

I see 2 possible reasons why Clover then crashes.
1. Problem with the Clover key
2. Problem with the Windows Installation USB drive.

You may like to rule out #2 first.
Which options did you use in Rufus when you created your Windows Installation USB drive ?
For me, I selected: GPT – UEFI (non CSM) – FAT 32.
With any other options, the USB drive may be successfully created, but the installation with Clover will fail.

If you think that your Windows Installation USB drive is fine, then you may like to look at reason #1 (Problem with the Clover key).

To create my Clover key, I used:
- BootDisk Utility v2.1.2018.023b
- Clover version 4961 (CloverISO-4961.tar.lzma)
With any other combination of BDU or Clover versions, I failed : either I was unsuccessful in creating a Clover key, or I managed to create a Clover key, but it did not work (I did not succeed in installing an OS then).
In particular, the latest version of BDU (v.2.1.2020.028) never worked for me.
And I never succeeded in creating a working Clover key without BDU !

See if that helps, and pls report any progress.

1 Like

Problem solved!

Just re-recorded the SD card via BDU with Clover and replaced my config.plist and copied the NVMe drivers as generally described in the associated folders and voila! EVERYTHING WORKS!

Boot via ThinkMods adapter SD card to the Sabrent 512 MB SSD installed in the adapter with Win10/Win11 works flawlessly.
Problem solved - I am happy and can recommend the adapter card without any restrictions.
Only drawback is the somewhat critical physical fit - I had to take the file to hand and file off the plastic a bit.

The problem with the Clover crash as described above still exists, but is no longer relevant, since I have found another way.

Many thanks to all!

Hi sibliss,

how can I hide entries in boot selection when they have no volume name?

If your volumes are not named you could either use diskpart to add a name easy option or if i recall correctly you could retrieve the volumes guid from diskpart and set <guid>guid of volume</guid> instead of string in the array. (note make sure it’s the volumes guid not the disks guid). i think think i’ve read somewhere that that works but i haven’t tried it myself.

Edit by Fernando: Unneeded fully quoted post removed (to save space)

Finally I made it!

It takes me some hours but after all I hide all unnecessary entries and setup the autoboot without Clover GUI - perfect for me!

Thank you very much!

Full text is below
1. What does “boot from file” mean(I did it thru clover shell but that’s all I know)?
2. Where do I get BootDisk Utility v2.1.2018.023b?
3. What the heck is a boot manager? Is it something windows made?
4. Where is the boot section of the config.plist file?
5. Whats the formating required to add the UUID into the config.plist file?
6. Is there a clover manual ( I just now thought of that)?

I can install onto the NVMe thru Clover shell and without clover shell. Instalation media is shown in Clover as well. I used an older CloverISO but not an older BDU.

Full text of my post:

SO yeah, I have a lot of questions and I’ll answer some questions others asked(thank you for your support). I think most importantly is what does “boot from file” mean? They only way I was able to follow #613 directions was to enter the shell of Clover. When I exit clover I get options like, boot manager, boot from file, and something else, but they all go to a black screen and freezes.

I was able to get the black screen with red text like #822. However, when I tried to follow #823 directions, I could not find anywhere on the internet BootDisk Utility v2.1.2018.023b. I belive that I did use Clover 4961 or something older than the presant(I forget which post told me to do that) Moreover, #820 says that I have to manually enter the UUID of the volume, (not actual drive) of my NVMe drive into the config.plist file boot section. I cannot find this boot section and, lol, I wouldn’t know how to enter the values in it even if I did know. Sorry @sibliss T.T

Anyways, to answer some questions, I can successfully install ubuntu by loading the bootx64.efi file from clover shell. Actually, I can install it without it as well. But, of course, does not show up in Clover. I don’t even think it shows up in the shell. it just says fs0:, Blk0:, Blk2:. both the blk entries say file not found when I type “dir”. I have it put in my PCIe x16 slot. (is that what a graphics card usually goes into, i think that’s what it’s called)

@Morbius Clover does pick up my installation media within the GUI.

Someone else asked something I think: I did not install windows thru clover but it shows my windows install (that’s not on the NVMe, just a HDD).

lets start with the easy ones…
2. you can find the link to the BDU in the what to download section of post #1 at the very start of this thread.
6. i am not aware of any manuals that would be nice, the best i can do is point you to the wiki i found linked in my post #493
5. the config.plist is all xml i briefly touched on how all xml parameters should look in post #826 (note the opening and closing tags on the line)
4. open the config.plist file with a text editor and look for this line that denotes the start of the boot section “<key>Boot</key>”
1. i have no idea what that is or why that would be required… at that point you should just be able to use your boot media i think
3. i’m going to assume thats just a reference to the built in utility for managing boot devices in clover or windows (i’m not sure what we are referencing here)

here is an example of the default boot key in the boot section of the config.plist yours should look similar

anything else let me know,

I friggin did it!

Thanks a lot for your reply sibliss but @Morbius said that I needed BDU 2018 version not the 2020 version. crazy, right?
I also found out that i did not use cloverISO v4961.
I finally found the BDU 2018 version on some random vietnamese website. so, im going to try clover ISO v4961 However it did not work. I had to use BDU 2018 version 024b not 023b. This worked even on boot6 and i did not have to install ubuntu(as i previous did before) it just worked.
Moreover, @sibliss , I cannot add the guid into the config.plist as your instruction. i have to write it as a string, otherwise it errors out and skips it.
<string> guid of volume </string> you said to do guid

Even so, clover did not pick up the dirve, even when i went into shell and did map -r
I’m going to write step by step what i did. Then post on here. Everything I have learned. Also i’ll post the files i got so that others don’t have to look for them as i did.

Holy crap, this project gave me a few white hairs. However, I, of course, did nothing special. The real heros are the Dev team. Thanks again. Here’s some coffee.[orange]

ah sorry i should have stated the <guid> tag is used in the other part of the file in relation to hiding drives thing not in the default boot section if i recall correctly, that was just a reference example to xml structure.
moving on i wonder what the 2020 bdu lacks that made it not work for you?

alas i am pleased to hear you got it working.