[Guide] NVMe-boot without modding your UEFI/BIOS (Clover-EFI bootloader method)

Thanks for this detailed written guide and wonderful method!

I am new to clover and I am using this method from last 1 month, it was working absolutely well, but suddenly blue screen appeared and I can no longer boot using clover. I reinstalled windows in SSD,I made new clover stick and tried. I succeeded to boot from my nvme ssd on pcie x4 adapter again using clover, but I am getting this error in clover that (PXE-E16: NO OFFER RECEIVED). I did not get this!

Please find the attached image and help me out to resolve this problem.

clover error 2021-10-31 at 00.43.11.jpeg

Clover 2021-10-31 at 02.16.50.jpeg

Hello and welcome to the forums, PXE is normally a bios setting please check that is is disabled in your computers bios.
If it is already disabled then you may have an issue within your clover configuration file. you may need to disable pxe option from the boot list within the config.plist

I hope this helps and good luck.

Hello everyone, thanks very much for the guide!

Maybe you can tell me what I’m doing wrong. It looks like the driver NvmExpressDxe.efi is not seeing the NVMe SSD.
Motherboard - Fujitsu d2912-a1.
HDD - ST3500418AS, Win10 is installed.
USB stick - Clover is installed, I’ve selectively tried versions from 4003 to 5141.
NVMe SSD - APPLE SSD SM0032L, it is visible both in Device Manager and in Disk Management, partition table - GPT. Windows installer allows me to install Win10 on the NVMe SSD (before the first reboot, then Clover is loaded - and there was no NVMe SSD, and no).

In the preboot.log - the Clover sees the NVMe SSD:
4:271 0:000 PCI (00|05:00.00) : 144D A806 class=010802

It also loaded the NVMe driver:
4:342 0:000 Loading NvmExpressDxe.efi status=Success

But it sees block devices from [02] to [127] instead of the NVMe SSD:
9:779 0:034 === [ ScanVolumes ] =============================
9:779 0:000 Found 131 volumes with blockIO
9:779 0:000 - [00]: Volume: PcieRoot(0x0)\Pci(0x16,0x2)\USB(0x80,0x51)
9:786 0:006 Result of bootcode detection: bootable unknown (legacy)
9:786 0:000 - [01]: Volume: PcieRoot(0x0)\Pci(0x16,0x2)\Ata(0x0)
9:786 0:000 Result of bootcode detection: bootable unknown (legacy)
9:786 0:000 - [02]: Volume: PcieRoot(0x0)\Pci(0x16,0x2)\VenHw(CF31FAC5-C24E-11D2-85F3-00A0C93EC93B,82)
9:786 0:000 - [03]: Volume: PcieRoot(0x0)\Pci(0x16,0x2)\VenHw(CF31FAC5-C24E-11D2-85F3-00A0C93EC93B,83)

…further from [04] to [126]…

9:789 0:000 - [127]: Volume: PcieRoot(0x0)\Pci(0x16,0x2)\VenHw(CF31FAC5-C24E-11D2-85F3-00A0C93EC93B,FF)
9:789 0:000 - [128]: Volume: PcieRoot(0x0)\Pci(0x16,0x2)\USB(0x80,0x51)\HD(1,MBR,0x04FDA583,0x3F,0x3D7FC1)
9:795 0:006 Result of bootcode detection: bootable unknown (legacy)
9:812 0:017 label : BDU
9:812 0:000 This is SelfVolume !!
9:812 0:000 - [129]: Volume: PcieRoot(0x0)\Pci(0x16,0x2)\Ata(0x0)\HD(1,MBR,0x27987793,0x3186,0x400800)
9:812 0:000 Result of bootcode detection: bootable Windows (vista,win)
9:813 0:000 - [130]: Volume: PcieRoot(0x0)\Pci(0x16,0x2)\Ata(0x0)\HD(2,MBR,0x27987793,0x40466C,0x39F80800)
9:813 0:000 Result of bootcode detection: bootable Windows (vista,win)
9:813 0:000 Searching volumes for latest nvram.plist …

I’ve tried a lot of NvmExpressDxe.efi from different sources - everything is the same. What could be wrong?

Regards, ducks_utki

Hi I follow the guide but there is no way I can fount the nvme drivers to load on the windows usb stick.
When I am trying to load the usb drive through glover there is a black screen and a blicking _ for every drive I choose.
My mother board is a Gigabyte F2A75M-D3H F5 AND NVME DRIVE IS A SA2000M8/500G. Please a litle help here cause we don’t have money for a new pc to support booting from nvme. thanks in advance

Unfortunately I am unable to get past "*** Scan Entries " in Clover. Tried searching the thread and a few others have had this issue - but could not find the solution.

Update: I have tried an alternative imagine of Clover however I still hang at "
Scan Entries ****". I have tried disabling all SATA devices but it still hangs at this.

Hello knowledgeable forum - I have just joined. Happy Holidays from NYC.

I have come here to learn how to install and use Clover for a specific purpose. I want to clone the HDDs of two older Dell Optiplexes to NVMe SSDs (using adapters to insert the NVMes into the PCs’ PCIe slots) and then use Clover to make those PCs boot from the new NVMes. I have a Dell Optiplex 7010 and a Dell Optiplex 3010, which won’t boot from NVMes in PCI slots. [And if this works, I might even try it again on an older Dell Optiplex 780 !!]

This is obviously the best place for Clover knowledge, but – believe it or not – it’s still not clear to me exactly HOW to install Clover onto a small USB stick, or how to add any extra drivers that are needed. The github pages for Clover are not self-explanatory, and I’ve never installed anything from github before. What exactly do I download from the github Clover site, and then what do I do with my downloads?

So, if possible, please point me to a link – maybe a page on this thread – that helps me with these very basic initial steps (which I admit are more basic than most folks here expect).

Once I’ve managed to install Clover onto a USB stick so that I can boot from that stick and see what Clover looks like, I know I’ll pick up more basics pretty fast.

Later (now now), I’ll ask about cloning my existing HDDs to the SSDs – I don’t want to reinstall OSes or apps or data, etc. But first step is to get Clover up and running.


PS - EDIT - Hey - is it possible to use EasyBCD to do what Clover is doing? NEW EDIT - Apparently not as EasyBCD is not a boot loader. (?)

NEW EDIT - the link for the downloader at cvad-mac.narod-ru doesn’t work any more. What to do?

Continuing my post directly above -

I had difficulty with http cvad-mac.narod ru / index / bootdiskutility_exe / 0-5 but finally managed to download BDU_v2.1.2020.028b.zip!

Its instructions are not entirely clear. If I run the exe, what happens? Will it give me the opportunity to install Clover onto a USB stick?

Also - I am not going to use this or Clover to boot a Mac. I intend to use Clover to make a Dell Optiplex 3010 or 7010 boot from a NVMe M.2 SSD that is inserted into an adapter which in turn is plugged into a PCIe (x4) slot.

In such case, what should be my choices when I run BDutility.exe?



can anyone tell me if this method as described in 1st post , allow me to boot win7 system that was cloned from SSD to PCIeNVME (both partitions as disk clone) given the fact that my MOBO is not supporting nvme (windows mounts nvme disk okay and i can use it no problem , just i’m not able to boot directly from bios).
so NO INSTALLATION … booting to clone .
i cloned the system to another SSD to test it and this works flawlessly as SSD boots from bios .
machine is HP Z210 workstation - updated bios but realized that they did not add nvme support…



I just succeeded in creating a Clover USB key, and in installing Windows 11, Linux Mint and Kali Linux on a non bootable NVMe SSD in a legacy system.

The NVMe SSD is installed on a 2009 legacy Gigabyte motherboard with an AMD Phenom processor through a PCIe adaptor.

I used Bootdisk Utility v.023 and Clover v.4961 to create the Clover key.

Everything works great !

So i’ve been looking around the comments trying make sense of this.

I followed the instructions just as said in relpy #493 and the main page. I don’t think my BIOS supports UEFI at all, though.
When booting to the USB clover all I get is a black screen with a “_” then a “6”. I think someone said theres a problem with windows install, but arn’t i supposed to install windows after i get Clover to work as said in reply #489.

I didn’t look through every comment, so i’m sorry if this has been addressed before. I will donate what i can if I am helped.

@glnz The BDU from cvad is an installer it will install clover to a usb for you and attempt to configure it for the system you are installing it from, so i hope that is the same machine you wish to boot.

follow my add-on post as well as the op re what to select. I have used this to boot several non uefi bios systems from an nvme. how this works is you install clover to the usb, clover runs first every time you start up the pc and clover then passes off to the nvme for normal windows.


the short answer is yes it will boot that, but there may need to be some edits to the windows boot loader on the new clone drive in order to get it to boot.


one of mine did this also but after waiting a bit it failed over to legacy(non uefi) and worked anyway. as of the moment i have no idea how to address this issue and i would certainly be interested if someone figures it out.

Thank you for your reply. I’ll fool around with it for a while and see if something happens. Thanks again.

I had the same problem.

Try to rename the "boot" file into "boot-ori" and then rename "boot7" to "boot".
After this the Clover Menu comes up after reboot.

Good luck!

So You are saying i should just install windows on a test hdd connected to the system i want to run nvme m.2 from and run BDU from there to create the flash drive?
Thanks in advance!

After several weeks of research, I finally managed to successfully install Clover on a 2009 (!) legacy BIOS (non UEFI) system.

My system :

MB : Gigabyte GA-MA790XT-UD4P (2009)
CPU : AMD Phenom II X4 955 (2009)
NVMe to PCIe adaptor

I successfully installed the following OSs on the – non bootable - NVMe SSD, and I am able to boot any one of them through Clover :

Windows 10
Windows 11
Linux Mint LMDE 4
Kali Linux
Ubuntu Server [Edit : 26/06/2022]
Emmabuntüs [Edit : 01/09/2022]

I created the Clover USB key using Boot Disk Utility v.023 and Clover v.4961.

For reference, from the Clover key, it takes 13 s (thirteen seconds) to start Windows 11 and 15 s for Kali Linux. Not bad for a 13 year old rig !

Clover is a wonderful tool and I can only encourage others who have a legacy platform to use it !

1 Like

I’ll try this as soon as i can. thx.

So, i tried what Franzl_Lang said to do and it worked! i was able to boot into clover. However, i could not get clover to see the SSD. I tried the post at #596 but i did not try the post at #613. I am disinterested in continuing becaue I’m under the impression that Clover can only see a NTFS drive. Can Clover also see ext4 on a gpt NVMe drive? I would like to install ubuntu on my NVMe. If i am wrong please tell me otherwise, thank you for your replies.


This is incorrect clover is a full bootloader and was designed for osx, it can see any partition format including ext4 I have dual booted with Ubuntu via clover myself. Please ensure you add the partition guid to the config.plist file. If I recall you need to add it under the boot section.