[Guide] Using CH341A-based programmer to flash SPI EEPROM

I would not use those though… If anyone needs, I still have a CH341A Writer in Germany.

Are there any official sources to get drivers and software for these CH341A devices? Also, is there a consensus on which programmer is best?

I really don’t want to buy one of these, and have to experiment with various questionable Chinese programs/drivers.

Hello, I have not finded the sources of CH341A for Windows operative systems however you can download the 1.30 cracked official version of CH341A in the followings links:



For unsecurity or unlocked usb dongles of CH341 by the moment the latest official version is: 1.31 (for security or locked usb dongles of CH341A actually the latest version is: 1.33). I hope in comings months the cracked version 1.31 at least

@plutomaniac ,

I’m trying to flash a bricked MSI Z97 Gaming 5. The chip (MXIC MX 25L6473E) is soldered. As you had the same issue, I was wondering how you solved it. I have I think the same usb CH341A dongle and the same clip as you do. I tried the clip but I couldn’t get the chip to be recognized. Should I try to power the board? Desolder the chip?

Thanks in advance for your feedback.

@ abstract:

Personally I couldn’t get the chip to be recognized without power and with the laptop’s power it would just sort. So I payed someone to dissolder and resolder after I flashed the chip with a proper firmware with the FD unlocked so that I wouldn’t have to do something like that again (hopefully).

Ok Thank you. I guess I’ll have to do dissolder it too.

I just wonder what’s the use of the clip.

I flashed 16-pin chip with this programmer. No problems, chip was detected and flashed

Short Q:
Could be a problem if I’ve used CH341A v1.17 Programmer software that have in list only W25Q128BV instead of W25Q128FV the last one being my original Chip too?

According to the manuals (BV version page 71 Ordering information section and FV version page 97), 128B or 128F the same density 128M-bit, V=2.7…3.6V in both cases.
I don’t see any difference, more than that, I have successfully writen / verified the Bios chip and get into the windows again.
Any thoughts? thanks

How must I put the chip on?

Depends on version, the chip is in different places.

This is version 1.18


And this is 1.29



Hi there, any recommendations for 1.8V converters? Don’t need one right now, just want to have one for the future.

Thanks in advance!

I have one of these ch341 boards with just 16 pins http://www.chinalctech.com/index.php?_m=…=view&p_id=1220
I’ve just downloaded the 1.30 software
I think different versions of the software map to different pins?
Can anyone direct me to the mappings to figure out how to connect to eeprom chips?

The 16 pins on the board from the top are:
Vcc Vcc

So, I’m trying to connect to AT2402 with pin layout

I’m using a chip clamp with cable finished in 8 pin socket. It seems to me that it’s not just a case of plugging into any of the 8 pins - I need to map the pins?
VCC, GND, SCL & SDA are clear but where to map A0, A1, A2 & WP?

DoI need to connect A0, A1, A2 to CS0, CS1, CS2?
Do I need to connect WP?

This is assuming the software isn’t changing the pin names printed on the board (if that’s possible)

Use version 1.18
Version 1.30 indicates improper connection of the chip and not running correctly.

Sorry, I was editing my post when you posted - I really need the pin mappings for any downloadable version of the software - is there any such mapping available for any of the software?

I worked it out, thanks

Hi there, did any one has the right Driver?
I use Windows 10 32Bit and the USB CH341A Programer, but can’t find a working Driver, that Windows accept it.

Good to know, I just wrote the GigaDevice GD25B64BDIG with the software, which seems compatible to GD25Q64!
Also, I had no problems using the Windows 7 x64 Driver in Windows 10 x64

You should give it a try, at least MXIC MX 25L6445E and others are supported. Look at the specs and you will se that they are all very similar.

EDIT by Fernando: Natively 2 posts merged into one and unneeded parts of the quoted text removed (to save space)

Thanks to share cracked version 1.30. Did you ever crack 1.31?

Did you manage to crack 1.31?

I own an asrock z77 ext3. For a few days now, i have an corupted bios, a think. After a bad restart and cmos clear i realised that my oc settings are gone. No more k on my 3570K and no more integrated graphics. Guess the ME is screw up and need to reflash. I did the classic way but no success. If i take the chip off and reprogram it with an updated bios version will it restore my ME? The realtek audio pin mod is kind of difficult cause i have old age related problem with my eyes :slight_smile: .Thanks in advanced.

Ok, i bought the 341 programer. What are the steps for reflashing the chip bios? I take it off insert on programer and use a bios from asrock support?