HDA_SDO/GPIO33 (a.k.a. "Pinmod") not working

I shorted two pins and it’s not working. I tried it five times. I’ve de-blobed me region already, but i want to disable it in descriptor region too.
chipset → ALC255
ME 11.8

Read the Intel Management Engine section on the forum and Plutomaniac guides.
You’ll have to rebuild the ME FW image

EDIT: The HDA is one of the methods… as you already noticed it doesnt apply to all systems, has to much to do with hardware board design… and yours a laptop…

I’ve already done.
It’s a laptop and have realtek alc255 with me 11.8

  • Shutdown the system completely (S5 power state)
  • Locate the two HDA pins and start shorting them
  • Keep shorting the pins and power on the system
  • Once the BIOS/OS starts to load, stop shorting
  • The Flash Descriptor should now be unlocked
    Thats what i tried.

But it’s not working.
Regions are still locked.

Doesn’t hda work with laptop? I saw somewhere it does.

It does… can we say its valid for all laptop motherboards around… i wont bet on it so im not surprised.

EDIT: Not if following the guide, and i dont need no info… the methods on the guide works or not, to your system motherboard, period.

1 Like

Am i doing something wrong? I can provide more info if needed.

Anyone can ask for it.