Help adding CPU Microcode to Dell 7060 BIOS?


Use actual versions - Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

Hello guys !
Happy New Year to you all !
Thanks a lot to @Sleinous , @Lost_N_BIOS and @DeathBringer for this amazing work !
Have you had a chance to extend it to 3060/5060?
I just got a cheap 3060 MT that I am very eager to upgrade to an i9-9900.
After dumping my bios, I managed to do the MMTool insertion of 90EC and 90ED without any issue (dates were right…)
The size of the GUID 17088572-377F-44EF-8F4E-B09FFF46A070 has inflated from 34828 to 65028.

I am not sure if, at the end of the day, @Sleinous tried the MMTool modified firmware he produced or if he only flashed the ucode part provided by @DeathBringer with FPTW
I am ready to flash my modded file (service jumper is on) but I am worried about the FIT part of it mentioned by @Lost_N_BIOS and scared of screwing everything up
I could try and figure out the right offset to flash the ucode part provided by @DeathBringer but I would still need a confirmation that I am on the right track…

Would you guys care to have look to my patched BIOS file?
Not sure if I am able to share files as I have just registered…

Thanks a lot in advance !


Hi All, Sorry to resurrect this topic. Would anyone have a fulldump of the bios. I have bricked mine trying to update this. I do a fptw64 -bios -d backup. The size I got was about 16MB. Will this alone be enough or will I need the full dump of the whole chip. I can see @Sleinous dump size is about 32MB.
Thanks

Bios region seems to be 16MB, so you need the rest of the firmware- Desc, GbE, ME, too.

What did you do precisely to brick your bios?

I dumped the bios part with fptw64 -bios -d backup.bin .
I was trying to apply the microcode update with fptw64 -a 0x1D20000 -l 0xF0000 -f ucode_2020_04.bin
I completed without any error until I restarted the PC and now it wont post. Just amber blinking away. Corrupt BIOS. Only later did I realise that this was for the older firmwares. Not for the newer ones.
I now only have 16MB of the bios. Do I need the entire bit including the Desc, GbE, ME or just the BIOS part would do?

I cannot dump the Dell Bios with /writehdrfile command to rescue either. The system will not boot to bios recovery. I am waiting for a CH341A hardware flasher to arrive to see if I can flash the backup.bin file to recover. If this does not work I would be grateful if someone could post the 32MB dump or another recovery method,

You don’t need another dump. The first part of the firmware should be fine.

Just read/dump your complete chip with the programmer, check the structure in UEFItooleNE and make at least two a 100% identical dumps!

Which version were the old bios? Post a link to your dumped bios region or attach it here.

The microcode update here only works with older 1.4.2 too. I had 1.18.0. I tried updating the microcode on this. :worried: without reading the entire thread. I dumped the bios part of 1.18.0 before I ran the code, so it seems like I have that dumped. I will attach a link here soon once I upload to a sharing site.

If both 7060 & 7070 motherboards are identical, wouldn’t it be enough to flash the 7070 bios into the 7060 motherboard?

1 Like

Hey dudes,

I try to give some new life to this amazing thread. I do have little different interests as the previous guys, but still within the topic.

Recently I crippled the intel ME down to the bare minimung. Thanks to the nice tutorial work here. So here I have a Dell 7050 micro and wondering if the xeon V5 and/or V6 CPU microcode can be flashed AND ecc RAM can be used.

I am unsure if ECC has to be activated within the BIOS or if the must be chosen an other BIOS platform (C236 chipset)

Any ideas?

2 posts were merged into an existing topic: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15)

does anyone have a working bios update that will work with a i9-9900t es?

Sorry to necro this post
i read it top to bottom with hopes and dreams due to the mention of the 35w and 65w mobos

I am in dire straights as here in Australia im struggling to track down a 130w Brick to work with the 2 65w i got from ebay (they seller only ever had 90w bricks)

i have purchased a few bricks which all meet spec but there must be something in the dell bricks that it looks for, sadly I can not find any resonably priced “Genuine” bricks after essentially being scammed twice with after market ones

I bit the bullet and bought 2 8500t CPU’s in hopes that reducing the wattage cpu would allow the mobo to accept the 90w genuine adapters i had on hand from the seller to no avail
thanks to you I now know there is a differnt board for the higher wattage cpus which is what i have
was wondedring if its even possible to have the bios from the 35w added to the 65w to have it check for the 90w brick not the 130w as i know this cofiguration will not sturate the 90w brick as i have a 35w board with the 8500t and exact same attached hardware running fine as we sepak

I know this is an Older Topic, However I just acquired a Dell 3060 SFF with an i5-8500 in it and would love to be able to update to a 9th Gen CPU. I already applied the PCIe Gen 3 hack for the NVME drive to get better performance, but I figured if I can get this upgraded to a 9th Gen, the Plex performance of this machine should increase.

Thanks in advance

H370… but around the web they all say cant support it. Does the bios lack the mcodes?
Present: 906EA 906EB
NOT present: 906EC 906ED

EDIT: Yes we know that the H370 can support it… your issue is being a Dell brand model motherboard and bios.
So why not adding the remaining missing mcodes… since you hacked it already, one more flash/dump shouldn’t stop you. The CFL GOP and vbios are already present also.

Get the motherboard in Service Mode by its jumper (JMP1), dump the bios region and add/replace the mcodes (depending on available volume space), use the correct ME Intel FPTtool to dump/write.

The H370 Chipset can support it,

The Socket can support it

Dell never enabled the microcodes in the Bios to enable 9th Gen support

Can anyone share a working bios for the 7060 micro to use my I9-9900t ES ?

hi,I’ve been following this post for a few days and read all the posts. I saw your follow-up support in bios-mods. I’d like your advice. (I wanted to consult you on bios-mods, but I haven’t been approved for registration and the review process is too slow.)

My machine is also an Optilex 7060 SFF. I noticed that the machine’s label said I7, and I upgraded to the latest BIOS v1.27.0 from the official website. The official website supports 8700 CPU, but when I installed the 8700es (qn8h) on the machine, it wouldn’t light up, the fan ran wildly, and the power indicator flashed 2 or 3 times. I found out on the official website support that it didn’t detect the memory, so I thought there was a problem with the memory. But when I replaced it with i3-8100t, it could boot normally. So the problem seems to be that 8700es (qn8h) is still not supported.

I’ve searched a lot of information and everyone said that the process for 8700es (qn8h) is the same as the official version of 8700. However, it can’t light up on my 7060 SFF. I have a few questions:

  1. Is this a BIOS or CPU problem?

First of all, the CPU problem. 8700es (qn8h) can be lighted up on another b365m motherboard. But I wonder if it’s because of a bug in the es test version? Or is it simply that the q370 motherboard of Optilex 7060 SFF doesn’t have the required microcode added by the official?

Can I solve this problem by flashing in the OptiPlex_7060_1.27.0_ucode.zip that you provided? I’m a beginner, so I apologize if I ask any stupid questions. Thank you.

hi,
According to your request, I have extracted desc.bin and bios.bin. I saw “a specific Intel microcode for a retail or ES/QS CPU” when discussing another post. I checked my CPU “Processor core” in cpu-world: Coffee Lake-S. I saw “906EA Coffee Lake-S, Coffee Lake-S Xeon E (U0)” in the ES post, but I’m not sure if it includes my CPU 8700es (qn8h). If possible, could you help me to add the microcode “906EA Coffee Lake-S, Coffee Lake-S Xeon E (U0)” under “Socket 1151v2 (LGA)” in the ES post to my BIOS? Thank you very much. By the way, where can I learn this tutorial on how to add microcode?

ES post: [OFFER] Intel CPU Microcode Archives
cpu-world: https://www.cpu-world.com/sspec/QN/QN8H.html
Dell_7060SFF_v1.27.0_bios.zip (5.3 MB)

A successful application of the above on a 7060 SFF to install an i7-9700.

Download CSME Tools v12 (e.g. r24).
Download MMTool (e.g. MMTool Aptio 5.02.0024).

  1. Open an elevated command prompt:
    1.1) Navigate to Intel CSME System Tools\Flash Programming Tool\WIN64
    1.2) Get a dump of current BIOS via >fptw64.exe -d 7060SFF_bios.bin -bios

  2. Download latest 906EC and 906ED microcode files from CPUMicrocodes/Intel at master · platomav/CPUMicrocodes · GitHub

  3. Use MMTool to:
    3.1) Load and insert 906EC and 906ED to CPU list (use microcode files)
    3.2) Save 7060SFF_bios_06ec_06ed.fd

  4. Shutdown the computer.

  5. Put 7060 SFF motherboard in service mode: move jumper to middle pins (near front centre of motherboard under DVD drive).

  6. Reboot. You will see a message and need to ‘retry boot’ to get into Windows.

  7. Open an elevated command prompt
    7.1) Navigate to Intel CSME System Tools\Flash Programming Tool\WIN64
    7.2) Flash BIOS using >fptw64.exe -f 7060SFF_bios_06ec_06ed.fd -bios

  8. Shutdown

  9. Restore ‘Service Mode’ jumper on motherboard to default.

  10. Check the computer starts up.

A post was merged into an existing topic: [TOOL] Easy automated Mod tool for Coffee Lake bios