[HELP] Asus Sabertooth x79 not detecting working MSI RX 480 4G Gaming X

My Asus Sabertooth x79 motherboard with an i7-3930k will not detect my MSI RX 480 4G Gaming X. I know this GPU works because it works on a MSI MPOWER MAX Z87 motherboard with an i7-4770k. I’m using this older PC because it has more cores and single threaded performance is similar. Right now the Asus motherboard is running an Asus RX 470 8G STRIX but I want to have better performance with this other GPU if I can. I’ve seen on UserBenchmark a submission with the same motherboard and GPU (userbenchmark.com/UserRun/29626091) although not the same CPU. With the same CPU and motherboard, I only see results with the Asus RX 480 8G STRIX OC. It also doesn’t work with a MSI RX 470 4G Gaming X.

Things I’ve done:
Update to latest BIOS (Beta)
Turned CSM on and off.
Turned Secure Boot on and off.
Boot into Legacy and UEFI Windows 10.
DDU and reinstall AMD drivers.
AMD Pixel Clock Patcher.
Different DVI and HDMI cables and ports.
Used other GPUs, an ASUS RX470 or a GT610, in combination with the RX 480.
Tried almost all of the BIOS versions.
Flash the card with a VBIOS that doesn’t have UEFI, both entirely deleting it or setting last image bit.
Tried flashing with a seemingly similar VBIOS, corrupts output.
Cleared CMOS, jumper and battery.
Turned it off and on.
Another PSU.
Used the buzzer to “debug” but it beeps to say it’s connected and disconnected?
Tried 2/3 PCIe slots (the third is blocked by the PSU and pins)
Tried Gen2 and Gen3 PCIe modes.
(There could be more, it’s just that I’ve lost track)

Worked with:
Asus RX 470 8G Strix
MSI OC Armor GTX 960 4G
PowerColor Red Dragon RX 460 4G
Inno3D GT610 2G

It seems that when it’s only the RX 480, the VGA_LED turns red. But when I pair it with a working GPU it doesn’t?
When I pair it up with a working GPU the RX 480 doesn’t even output anything, nor is it detected by anything.
I’ve Googled this problem and the one thing that keeps on popping up is the hybrid VBIOS. But as stated earlier bios mods didn’t work (from my attempts at least, haven’t requested a bios). This Asus RX 470 I’m using right now has a hybrid VBIOS according to “amdvbflash.exe -ai”, how weird.

Here’s the problematic GPU, VBIOS included too (I’ve lost the original BIOS years ago and flashed it with this, I’ve checked the memory modules when I was repasting and they’re Hynix):

Specs (as I’m writing):
i7-3930k @ 4.4GHz
Corsair H100i v2
Asus Sabertooth x79 w/ latest beta BIOS
Patriot Intel Extreme Master Limited Edition 8GBx8 DDR3 @ 1866MHz
Asus RX 470 8G STRIX @ Stock (Can’t OC the dang thing without it crashing the next day)
Sound Blaster Z
Corsair AX 860i
Samsung 850 EVO 500G

I’ll be forever grateful to whoever is kind enough to give their time to help me solve this problem. It might as well be a problem that can’t be fixed. I’ve been told by the “tech support” (As seen by their broken English and scripts) of MSI and Asus that it’s incompatible. I’m ready to just give up as I’ve ran out of ideas and don’t have the knowledge to mess around with the VBIOS or motherboard bios. I’ve sunk too much time into this and it’s finally time to ask the internet. I’ll try to give out more information, just ask.

PS: MSI GPU works with MSI motherboard and Asus GPU works with Asus motherboard??? Woah!
Also since I’m fresh I got this funny error when posting, “Your posts contains to many links. A maximum of links is allowed.”

Your bios doesn’t support VGA cards fully which run on UEFI mode.

So then, is there no fix to this? What’s weird is that I modded the bios to only have the legacy portion by deleting the uefi portion in a hex-editor and also tried marking the bit of the legacy portion as last rom while keeping the uefi portion. After flashing the card it still worked on the z87 motherboard, but not on the x79. Does the legacy portion of the rom not work or am I doing something wrong?

Thread I followed to mark legacy portion last:

Thread I followed to remove uefi portion:

Hi same issue here my XFX Radeon™ RX 470 4G - can you delete gop ? cant use card @Asus Ex-b150m-v3 intel its not detecting

Please make 2 files one is legacy and other uefi so i can check which will work Thanks!

rx 470 orignal bios.zip (109 KB)

Hi! Did you fix that? I have XFX RX 470 4gb. Motherboard does not see it, but card work good on another motherboard. My motherboard Machinist X79

And another UEFI gpu on that pos chinese motherboard works in Legacy or UEFI?
Other options, flash a more recent vbios from XFX or AMD, look in TPU db.
If the card is need to boot in UEFI mode, can try to update GOP driver, here:

Other than that, pack it all nicely and send it to the Chinese.