[Help] Bios recovery for Asus laptop


It has past a few months until I decided to downgrade my laptop’s bios, an ASUS X555QG, more specifically, with an AMD A10 APU. It seemed it went correctly, but when I tried to turn it on, I realized that it never boots. It’s symptoms are these ones:
It turns on with all the fans spinning and lights, and also the disc tray seems to try reading a disc always, like when an AMI bios gets corrupted. When I plug a USB on the 3.0 ports, nothing happens, but when I plug it to a USB 2.0, the USB light starts blinking, like trying to read a recovery file. I have tried:

Connecting it through HDMI to a TV, putting my bios file with very different names like AMIBOOT.ROM, AMIBOOT.BIN, X555QGAS.BIN, X555QGAS.258 and many other combinations to make it work, nothing seems to happen. Also tried to hold CTRL + HOME, FN + HOME, CTRL + F2, F4, F8, and also SHIFT + WIN + B and also nothing works, I have removed the battery, for days and nothing works. PhoenixTool generates not a recovery name for this laptop’s bios, but it does with other variants what results weird to me. I’d love to hear any advice from you, no matter how simple it sounds. I’m thinking of purchasing a flasher with the clip, to avoid desoldering and soldering the bios chip, but I don’t really know if it would work with my board and my chip, that is a Winbond 25Q64FWSIQ 1805. Thank you in advance.

Hey bro!

I have the same issue with the same notebook. Really, the same issue and i don’t know have to do.

Do you know how to fix it or not yet?

@deity999 - since it’s scanning USB 2.0, make FAT32 USB 2.0 drive, put the BIOS file on root of USB (not in folder) and name it , X555QG.BIN + copy named X555QG.258. Also, if you have the original driver CD place that into the CD bay too.
@Markezz2 - same as above

If that doesn’t work for either of you, then you need CH341A + SOIC8 test clip with cable, these are less than $7 shipped total together if you get them shipped slowest way from China.

@Lost_N_BIOS thank you, i really appreciated your fast answer.

I tried to download the bios bin files from asus web site. i made the usb 2.0 that contained the same file with the different names you proposed and i tried with recently and older files versions. i tried with the different usb ports that my notebook could read. but I didnt succeed. i still a blackscreen after update the bios. i can hear how my computer is running as normal but i can see nothing.

I wanted to be really persistent in the alternative solution since I realized that it is a very common problem with this asus model. this is because asus havent a usb boot tool to repair bios automatically.

Some people lose hope of repairing, other people decide to visit a technical service $$$$. Instead, we keep trying, sharing our experiences and helping more users. So, please, if you have any other suggestions that not been mentioned, a related link, I would greatly appreciate it.

and thank you again.

@Markezz2 - Sometimes BIOS is messed up in a way that recovery can’t run to fix the BIOS. Get the tools I mentioned, price for both shipped is less than $7 total if you take the cheap shipping route and wait 3-5 weeks for delivery, you can get them quicker for more $$
Then it will only take you and me a few back and forth replies to get you back up and running

If you need linked example to the tools I mentioned on ebay let me know

Thank you for replying! Mine at least does not revive even with the original CD. It seems our only option is to purchase a flasher with a clip, but I have got a question about this: on many laptops it can not be done with the chip still stuck to the board. In most cases it can only be done taking off the chip from the board or it won’t read. How would we know if we could do it avoiding soldering?

You don’t have to solder. here is examples of what you need on ebay, but you can get at many other places, sometimes in a bundle/kit

Hello again!. I have already bought the programmer, and it works perfectly! the first thing I did was making a dum from the old bios. Tried to open the oficial bios, and it tells me "file lengt beyond range of will be ignored. I will send the dump as you told me, but what do you recommend us to do?

@deity999 - do not try to erase or write anything to the chip until I’ve looked at your dumped BIOS and said it’s OK dump. What is your BIOS chip ID, please read it off the chip itself

* Edit - You need 1.8v adapter like this for W25Q64FW, it’s 1.8v chip


This is the link for my old bios dump. I will reupload it to another site when I’m able to, but it should be able to be download anyway

Yes, I got the BIOS finally, thanks. Please wait, I will make you new BIOS.

Great! Thanks to you! :slight_smile:

Let me know once you have the 1.8V adapter, also still waiting on image of BIOS chip if you wanted me to confirm you have the 1.8v chip

I already have it. And it’s an FW, but I can’t take an image since it’s very foggy, the chip is black and the letters are some gray. I will try to capture it many times and show you :slight_smile:

i bumped to this thread after frustratingly facing my X555QG that been bricked in the time i really need a laptop… i really hope this thread are still alive. i’ve checked all the chip usb programming tools are available in my country. i really want to jump to the BIOS recovery using that method if there a light in it. please help me also guys.

and in the meantime, actually i havent yet try to recover using usb keys… from what i understand is that i need to plug a FAT32 formated usb flashdisk into the USB2.0 port where inside that USB flashdisk are BIOS ROM right? i’ve downloaded the most recent BIOS update from Asus Global Official. i get a X555QGAS329.zip file, the inside of it are X555QGAS.329 file… so which is the one i need to put and rename so the board can read it to recover flash?