[HELP] BIOS rewrite with FPT failed(z77 + 3570k)

Hi guys,

I had the exact same problem Ray had in this threat with the same PC Specs.
I couldn’t overclock my i5 3570k and also my system detected half of the installed memory Ram so it seems to be related to corrupted ME region. I tried everything in that threat with the same results, including the ME firmware update. meinfowin -verbose and MEInfo -fwsts outputs looked like Ray’s outputs to me.

Then I tried fptw -rewrite -bios -f Z77EXT43.00 and then the progress got stuck at 7% and the screen froze. After rebooting the screen does not turn on, I clear CMOS without result. I think the BIOS could be corrupted. After that I extract the SPI BIOS chip and buy an CH341A programmer, It should arrive tomorrow.

Would be possible to extract serial, LAN MAC ID etc. from my possibly corrupted BIOS dump and apply those changes to a new BIOS image with fixed ME?

I am interested in keeping the windows license.

Thank you very much for your help.

M/B: Asrock z77 extreme4
Bios Vers: 3.00 Beta
Proc: i5 3570k

@Jotas - Yes, BIOS would be corrupted now since you rebooted in the middle of a BIOS region rewrite. LAN MAC ID is probably in GbE region, outside of BIOS region, so that info should still be on the chip, if not it’s on a sticker on your board
Everything else in BIOS region such as serial and UUID, if stored in your BIOS which sometimes Asrock does not do, would be gone due to you using re-write option which first erases that region and because you used a stock BIOS which would also erase those details too even if you had not used rewrite.

Stock BIOS should not usually be used with FPT, since I mentioned to write stock BIOS region with FPT in that thread back then I must have known serial/UUID not used in this BIOS.
All that doesn’t matter anymore anyway, it’s only used for RMA generally and even then only if they check the BIOS when it’s used in BIOS, which they’d usually just look at the sticker.
However, you have now lost all your NVRAM, which after checking that other thread, I see is where MAC ID is stored in this BIOS too. Do you have any BIOS backups, from any software, before you did this?

Give me a zip with all images from the stickers on your board, be sure to look on sides of 24pin, top/.bottom sides of PCI/PCIE slots, front and back of board, on/around/near the LAN slot etc (All/any sticker)
Then, once you programmer arrives, slow down! Do not erase or write anything to the chip until you hear back from me about the file you send me. Dump the BIOS, send me that file, and wait.
This is done for two reasons, one is to make sure you first find the correct software version that works with your BIOS chip, and two in order to try and get a copy of any details that may remain on the chip.
And, actually, I think Asrock does not use a UUID in BIOS, or at least it’s always a generic one, but I’m not sure how long they’ve been doing this. Serial I cannot remember if they put in or not

Here is main driver and general software package, I suggest you start by trying a 1.30 or 1.34 dump, and send those to me. What is your BIOS Chip ID?
http://s000.tinyupload.com/index.php?fil…257455007472602 << Latest package, includes 1.34

CH341A Image Guide
https://www.bios-mods.com/forum/Thread-G…341A-programmer << Same as one directly below, but with all images expanded/visible at once
[GUIDE] Flash BIOS with CH341A programmer

@Lost_N_BIOS - Unfortunately, I don’t have any BIOS backup.

I attach the photo of the two stickers I found on the motherboard and the corrupted BIOS dump.

Thank you so much for your help.


Hey! Any Update about the status of my BIOS? Thanks!


@Jotas - sorry for delay, I’m just one guy over here

First, please test this, if it’s OK then we’re done (This meant as NVRAM test, I inserted your non-corrupted dumped NVRAM volume, only one, second is corrupted) If it fails, I will have to remove those and insert stock ones only, or from another dump
Please check to be sure your LAN is working (Ethernet). I can’t find your LAN MAC ID in your dump, but the entire main BIOS volume is corrupted and compressed too so searching it wouldn’t find anything anyway due to corrupt/compressed at same time.
Hopefully MAC ID is stored onchip instead of in BIOS, otherwise I will have to PM Ray from that other similar thread and ask for his MAC ID so I can find location in his dump, then correct into your dump, since this BIOS does not have Intel GbE region.
This is stock BIOS 3.00 + your single NVRAM volume, unlocked FD, with ME FW updated to latest

It worked flawlessly! I can now overclock my CPU and Windows detects all installed memory Ram, ethernet works perfectly too. Thank you so much, you save my computer!

@Jotas - Awesome news!
You’re welcome, and thank you for the quick test report back!

* Since you now have unlocked FD in there, you can fix any future ME issues with FPT flashing, no need for programmer anymore unless you need to recover from brick

Great news! Thank you!