[Help] Bypass Software Controlled TDP - Razer Laptop

I have a mid 2019 Razer Blade 15 (core i7 9750h, RTX 2080mq) in which I have unlocked access to all BIOS options. The original version of the BIOS can be obtained from here.

Razer Blade laptops use Synapse software which has control over the TDP of the laptop. I know this because if I run the laptop with Synapse closed, it throttles to 45W instantly (this is the TDP of the 9750h) and will not go above. If I have Synapse open, it will let me boost past 45W for 10-20 seconds. Within the synapse software these is a power slider for the cpu and gpu with 3 settings each. CPU settings result in 1 - 35W, 2 - 45W no boost, and 3 - ~60W for 10-20 secs before throttle to 45W. GPU settings result in 1 - 88W, 2 - 90W, and 3 - 100W for the GPU. If I run a fresh install of windows without Synapse ever being installed, I max at 45W on CPU without being able to boost over at all. So I know these TDPs are definitely being controlled by the synapse software. Because my BIOS has all options available, I can change the TDPs in there and the set time for them, but there is no impact.

Somehow, the Razer Synapse software can override the BIOS TDP settings, and in fact it seems that Synapse is required for full >45W boost performance period.

I am trying to figure out how Synapse is doing this, and how to stop it, so that I can control the TDP set points via BIOS.

I’ve used RWEverything to read all relevant MSR offsets, and none change when I change the power slider. Similarly there is no connection between these options and EC either.

As a final note. Yes, I am aware the CPU is designed to run at 45W, but changing the IMON Slope and offset, the machine can run stably at full power with reasonable temps, so I am not concerned with running at a higher TDP, I just want to be able to control it.

Any help would be greatly appreciated. I’m sure someone out there has an idea of how to do this.

I have the exact same ‘Issue’ with my new Stealth 13" 2020, the Gaming profile seems to increase (Mostly) the CPU performance here on a mixed cpu/gpu benchmark.

So far Ive tried throttlestop and tinker with TDP stuff, Installed/uninstalled Intel Dynamic Tuning (Which can expose TDP settings with proper powercfg command), doesn’t seem to do jack.

Seems we’re stuck with having to run Synapse in the background unless we know what exactly the software does.

Looks like my new system cant be bios flashed either with the AMI tools. Once I disable the secure flash, it does reboot but then a split second blue screen shows that the ‘image could not be found’ and just reboots.


Edit: Looks like I can see a change in one value going from 00 01 and 03 (power saving / balanced / gaming) in the embedded controller here.
Edit2: Also in acpi power management tables

However changing these while synapse is closed has no effect :C

Hi guys.

I am NEW and would like to know whether you have made further progress with your project or whether it is hopeless?

While I don’t believe it is hopeless, it is beyond my abilities. I ultimately made no progress on that front, ultimately just modified my IMON slope and offset to get my TDP to always stay under 45W with temps reasonable.