[HELP] Corrupt BIOS on MSI GS60 6QE-055AU (Ghost pro 4k)


After a bit of assistance, i was given this MSI GS60-055AU Ghost pro 4k from a friend in a non working condition after he had tried to update the bios which has failed.

I have tried flashing the bios with CH341a programmer with multiple bios files from msi website E16H7IMS.10C, E16H7IMS.107, E16H7IMS.117 with no luck all i will get after a successful flash is power cycle followed by no post, i have a .bin of the original corrupt bios and also the EC i have a feeling something has gone wrong there

Bios flash is an en25b64 and any flash program i use now it seems to fail writing to the chip, i have even removed the flash off the MB and still the same issue



Dump may be corrupted further too if you didn;t use correct tool/version that was compatible.
You should have waited, never erased/wrote to the chip until you or someone looked at your dump to confirm it was OK (even if corrupted, or broken from failed flash, it would still look like a BIOS usually)

Are you sure it’s EN25B64 not EN25Q64? If yes, OK, only checking.
Also, what do you see as the ID’d chip if you dump it with FPT from DOS? I see some looking at chip and seeing model you mentioned, but FPT showing GD25Q64 But they said dump/write with either was OK, so doesn’t matter I guess)
CH341A software 1.30 and 1.34 both have this chip ID in them (@ EON), as does ASProgrammer 1.41 - what software/version are you using to write files? Do you erase, blank check, then write and verify?
If yes, and chip/buffer match at end, have you dumped that file and compared in hex with what you wrote, to be sure it’s a match?

ASProgrammer 1.41 here - https://github.com/nofeletru/UsbAsp-flash/releases/
General CH341A software package here with versions I mentioned - http://s000.tinyupload.com/index.php?fil…695330485827902

I see plenty of success stories in google with general CH341A software and that chip, so maybe something in your process (and maybe, you can’t just write the BIOS from MSI and have it boot, at this moment I have not looked at any files yet)

Yes, EC FW may need updated, I see messages at MSI download page, update to xx BIOS before xxx BIOS.
This usually due to EC FW needs updated at same time or before newer BIOS can be used, so you can’t skip BIOS (unless you are updating EC FW and BIOS via programmer, but for that you need to extract EC FW from BIOS, if it’s there)
I tried to find EC FW in BIOS, but no luck. Hopefully your EC FW is OK, and you just need to write back 10A BIOS, then update as mentioned on their site.
If no luck ever, EC FW may be messed up, or updated and you don’t know which BIOS version matches, so you may need to ask MSI Directly for a BIOS + EC matched set you can write with programmer.

I checked your dumped BIOS now, good it’s OK So you should be able to write properly too, maybe not using same software version or chip ID, but it should be possible since dump was OK.
Sometimes you can dump with one version or ID, but not write, so can be tricky to find what works

The BIOS You dumped is E16H7IMS.10A - http://download.msi.com/bos_exe/nb/E16H7IMS.10A.zip

And finally, yes, these BIOS are directly programmable and should boot, provided write is done proper (ie dump after write, matches what you intended to write) and EC FW Is OK
This method would loose your serial, UUID, LAN MAC ID etc, but you can put all that back later from your dump, after you get it running again.

Thankyou I have ordered another eeprom chip as I could not get to read or write to it anymore, I’m awaiting for it to arrive in the mail and I will give it a try then,

Thanks for your help :slight_smile:

Probably clip issues, sometimes I have to clip 10+ times or more and it pisses me off too and I think I will never get it, but then I get it So chip itself on the board was probably fine
You’re welcome!