[Help] Dell PowerEdge R710 Gen II Mainboard BIOS Bricked after Power Outage while Updating

Hello People,

I have a “small” Problem here on my Site. I recently bought a Dell PE R710 off from ebay to start my little homelab.
Since the Server came without HDDs I ordered a bunch of these and while I waited I tried to get everything else Setup.
As Im a young SysAdmin myself I first tested everything and the machine seemed to be in a really good shape.

I installed ESXi on the Machine via internal USB, configured the iDRAC 6 Interface and also wanted to Update the BIOS and other Firmwares of the RAID Controller etc.
After diging around in the Web I created an Update ISO from Dells EMC Repo Manager and started the Upgrade.

Everything went smooth without any errors. Happy Message that the Server will Reboot now to finish the Updates and so I did.
Server startet to reboot, Fans spun up and then ZAP No more Power in the House… ( Funfact: Nope was not the Server since we had no Power for about 2 hours ).

The Server does not POST, hovever I can access the iDRAC Card but really cannot do anything from there. Even there the Console Stays blank.

I opened a Post on Reddit to see if anyone knows a way to fix this board. ( I don’t want to spend another 80-100$ on a Gen II Mobo :confused: )
Someone hinted me to try this Forum here since a Member of this Board helped him to restore a R720 BIOS after a brick.

What I’ve done so far with the Help of /r/homelab:

* Ordered a CH341A Programmer with a SOIC8 Clip
* Install Ubuntu on a spare Notebook with flashrom
* Try to dump all CHIPs possible on the Board since the one with “U_SPI_BIOS” gave me EEPROM/FLASH Drive not found errors.
=> The only Chip wich was dumpable was the “U_IBMC_SPI” but this is only 2.048kb in size while the BIOS File wich I extraced from the Dell BIOS Exe results in a 4.097kb.

A Link to the Chips I took a Picture of you can find here: imgur

The Result of Flashrom is the same on Windows & Ubuntu:


I don’t know if the CHIP itself is dead or not or if I’m missing something important.

Hope someone can help me with this :slight_smile:

Greetings, pabumake

The one with SPI or BIOS would be correct ones, there may be two. Show me an image of the board in full, some boards have SOIC16 BIOS too, split BIOS, some split BIOS between two SOIC8 chips.

The error you got may be due to bad connection, try again etc. IBMC SPI is not BIOS, I assume, doesn’t look like a usual BIOS chip, maybe EC FW or whatever IBMC means FW
None of the images you provided look to show any of the BIOS chips. You may need to move the Management CFG Force jumper, but I’m not sure if that is CFG to unlock BIOS CFG/Locks, or more a management thing, plutomaniac will probably know since he’s already helped with similar system.
You may also need to connect or remove all board power before you can read that chip, some systems need it removed, some need it supplied (not powered on, just all cables connected etc)

You may have better luck with CH341A software. http://s000.tinyupload.com/index.php?fil…257455007472602
The U_SPI_BIOS - SST25VF chip is most likely the main BIOS, but there could be a second chip too. Show me an image of the board and I’ll be able to better advise you. It may just be that chip alone too.

Please link what version stock BIOS package you are using as well.
Is it this one - https://downloads.dell.com/FOLDER0501285…64_6.6.0_01.EXE


plutomaniac must be the one who helped the other user with R720, that’s all I see in search results.

Hey, thanks for your response.

I did remove the BIOS Battery and the Board is not longer built in the Chassie ( tryed to order a replacement board wich was then a Gen I Board and the CPUs are not supportet so everything that could go wrong, im in xD ).

I tryed to use the CH341A Software wich again leads only to be able to pull the “U_IBMC_SPI” Chip. Same result for me like with flashrom on ( Ubuntu,Windows,Fedora )
The BIOS package you linked is exactly what I was installing. Before there was the 6.4.0 installed.

More Detailed pictures of the Board here: IMGUR Link

Greetings, pabumake

hi @pabumake ,

have thee same issue that i flashed an new BIOS and ended in a bricked mainboard of my R710.
Did you find finally a solution and were able to flash the EEPROM on the mainboard?

thanks

hi ,
as mentioned i have the same issue.
i had 1.3.6 installed and updated to 6.6.0 and ended in a bricked main board.

i order now a eeprom programmer and already identified the bios chip on the board.
how did you proceed? did you download the old BIOS to recover, or did you us the new one?
how did you extract the necessary filed for the programmer from the dell BIN file?

thanks

Today evening i spend more time to give the requested details.
1. MB piture showing the 2 chip
MB area with BIOS chip -> 20200305_200730.jpg
Both bios chips have a sticker
2. Chip with sticker AA4A labeled U_IBMC_SPI
U_IBMC_SPI -> 20200305_200755.jpg
For this chip i was able to read the data with flashrom.
3. Chip with sticker D1C5 labeled U_SPI_BIOS
U_SPI_BIOS -> 20200305_200804.jpg
Here i cannot get the flash with same message as shown in the thread.
4. Chip with sticker D1C5 labeled U_SPI_BIOS / sticker removed
U_SPI_BIOS chip type -> 20200305_200946.jpg
Here the details of the chip type SST25VF032B
5. According the Dell information the U_SPI_BIOS in Statement of Volatility is the system BIOS
Statement of Volatility – Dell PowerEdge R710
It should be 4Mbyte
6. flashrom

sudo flashrom -V -p ch341a_spi -c SST25VF032B -r old2.bin
flashrom v1.2 on Linux 5.3.0-40-generic (x86_64)
flashrom is free software, get the source code at https://flashrom.org

flashrom was built with libpci 3.6.4, GCC 9.2.1 20200304, little endian
Command line (7 args): flashrom -V -p ch341a_spi -c SST25VF032B -r old2.bin
Using clock_gettime for delay loops (clk_id: 1, resolution: 1ns).
Initializing ch341a_spi programmer
Device revision is 3.0.4
The following protocols are supported: SPI.
Probing for SST SST25VF032B, 4096 kB: RDID byte 0 parity violation. probe_spi_rdid_generic: id1 0x00, id2 0x00
No EEPROM/flash device found.
Note: flashrom can never write if the flash chip isn’t found automatically.
7. Flash programmer is ch341a_spi, as i was able to read the first flash i assume it is properly working.
8. The original BIOS was version 1.3.6 before the flashing.
The new BIOS i tried to flash was 6.6.0
i was able to extract with binwalker the hdf file which is of size 4Mbyte hdf file

Is there anyone who was able to read with flashrom from above chip type?
would be the best option to un-solder the chip from the board and solder it on the programmer ?

thx

20200305_200730.jpg

20200305_200755.jpg

20200305_200804.jpg

20200305_200946.jpg

Dump both chips labelled SPI/BIOS. Sorry, I can’t help with flashrom. If you are having trouble dumping a chip, use windows software instead.
http://s000.tinyupload.com/index.php?fil…695330485827902 Or ASProgrammer - https://github.com/nofeletru/UsbAsp-flash/releases/
You will need to remove the stickers so you can see the chip ID

For chip w/ ID SST25VF032B see post 393 and 396 here - [Guide] Using CH341A-based programmer to flash SPI EEPROM (27)

HDR file is not used for this process, maybe in rebuilding a dump for you, but not directly.

You can desolder if you know how, then put chip into spring SOIC8 to Dip8 adapter like this (or solder to programmer) - https://www.ebay.com/itm/312933454453 (Choose 200mil)
Or just get SOIC8 test clip with cable, if you need a link to this on ebay for example here - https://www.ebay.com/itm/382486015977

Hi,

tried both programs on my windows with test clip. i am using window 10

CH341A v1.34 does not detect the chip.
AsProgrammer 1.4.1 shows some chip ID which are not detected by the program.

Both programs show FF when trying to read the flash
As indicated in my post before it should be a

ASProgrammer.JPG

CH341A.JPG

hi,
final found a way to get the bios read from the chip.
i had to unsolder it as the chip on the motherboard was not detected.
i will now work on to prepare the new bios file and write it back.
will share the results

i checked the BIOS that i read from the chip .
At a certain position i only see FF , while the .hdr extracted from the DELL BIOS download shows data at that position.

can i use the .hdr file to flash it back to the chip??

finally…

i edit the hdr file and remove some bytes in the beginning to match the start and remove some bytes in the end to prepare the BIOS file for the programmer.

after flashing with flashrom i soldered the chio back on the mother board and … hurray the server starts up again.

Great to hear you resolved this issue yourself finally, good work @kreutpet