HELP disable HPET on asrock Fatalt1ty b450 Gaming k4. Bios version P1.80 :(

Hello there! I am new to the site and to the bios modding. I am stuck with the program hex editor trying to figure out how to disable HPET in my .rom file . Asrock wrote me an email that they enabled auto HPET overall in coorporation with AMD. So now im stuck with HPET auto enabled. I pray there is an angel out there who knows how to help me out!


@pPAKKE - here, you can enable/disable at will now, setting is at Advanced >> Advanced >> ACPI Configuration page (ACPI HPET Table = HPET Function Switch)…602161958376831

This BIOS may have Asrock’s new security protection in it, so flashing mod BIOS may not be possible without you following this dance (Post #20-22), but it looks like UBU removed old type security with a run through UBU so you may be OK
[PROBLEM] Flashing a modded ASRock Z370 MB BIOS (2)

Or instead of mod BIOS, you can use this method to disable without having to flash BIOS. Boot to grub via this guide, starting at step #6 - [GUIDE] Grub Fix Intel FPT Error 368 - BIOS Lock Asus/Other Mod BIOS Flash
Your efi file needs to be named Shell.efi, and here is your variable to edit >> 0x266
So at grub prompt you will enter >> Setup_var 0x266 0x0
To re-enable again >> Setup_var 0x266 0xFF

You are the best!!! Thank you so much!! Im on vacation with my wife and son ubtil thursday then i will go home and try it out mate!

It wont work mate. When i boot info efi shell from usb it just says: Shell: and when i write those setup_var commands it says command unknown… That attached Shell.efi file is that the one getting me into Grub? Im not in Grub… Im in Shell something lol

Setup_var is not recognized as an internal or external command

@pPAKKE - Then that is the wrong thing, sounds like “Shell” not "Grub"l, did you follow all steps exactly? You should not be choosing “UEFI” USB or anything like that, nor booting to USB per-say. This is done from the exit page. Yes, you use the file as mentioned, no need to try Setup_Var until you see the grub screen
Keep at it, follow the guide, you will get there, I checked your BIOS it’s setup exactly like all the others for this process. Forget anything you know about booting to “a Shell” or booting to USB etc, this is not that, follow the guide and you’ll get there.

If you continue to have trouble, format your USB using windows right click format, format to FAT32, and place the Shell.efi file on the root of the USB. That is all.
Then if you’ve disabled and set all BIOS settings per the guide, all you do is go to the exit page of the BIOS and choose launch EFI From Shell.

Remember as I mentioned, you may not need to do that anyway if this process keeps holding you back, try flashing the mod BIOS I made for you, I think it should work but not certain since there’s no way to detect the new security measure until you try to flash a mod BIOS.

It gives me security fail report when i try flashing directly! I will keep trying mate!

i think i got it!

i cant seem to get pass security check mate… i did the grup thing perfectly now but cant instant flash still…

@pPAKKE - Then your board has the new security feature, you have to either follow link above “[PROBLEM] Flashing a modded ASRock Z370 MB BIOS (2)” method
Or, change the setting via grub. Unless you have a flash programmer (Hardware, like CH341A)

Grub has nothing to do with flashing, grub was to do instead of flashing, in grub you change the setting directly so you don’t need a BIOS mod.
Show me image of you entering grub command and it’s return comment (Yes, you can do it again, will just return already 0x0)

it just says excatly the same as in your guide mate. It is oki with Grub, its the FPTW i cant seem to get. Im on windows 10 home and only have PowerShell. It dont know the command FPTW.EXE -bios -f B45GK4_1.80.ROM :slight_smile: what to do mate+???!gFdWiY4J!2k5TKp7dbKvFE…gywVqn1J9lKRkb4

What can i do mate?? Cant get the fptw to work :confused: im on AMD Ryzen 2600

@pPAKKE - Sorry, I didn’t realize this is AMD! Anyway, even if your system was Intel you cannot run FPT from powershell, it’s ran from command prompt only - for anyone reading later.

Please show me image of grub commands being entered and reply back. If you did grub correctly, and were on the correct grub not shell (that has some yellow text), then the change is already done (HPET Disabled)
Show me grub image.

Please edit your posts instead of making many posts in a row, thanks!

Can i change the bios via the Grub? i didnt use the flash rom file yet? How can the HPET be disabled then. 2 sec i will attach picture :slight_smile:

Here is GRUB!VB131CRC!k6nR4GhdaaC-Z…lKPwVhvEQKpthF4
But hpet is still enabled in Windows. So it is not working mate :confused:
If i set hpet Disabled in bios it Will auto enable. As it is doing now…

@pPAKKE - Again, please edit your post if you need to add more comments or thoughts!

This is not working because there is a grub error, you didn’t mention that. Try this grub file instead, rename it the same (Shell.efi), replacing the one you are currently using.
Then use the following command instead, and show me image of the input and reply again

Setup_var2 0x266 0x0

You cannot set HPET disabled in BIOS can you? I thought you do not have this setting visible?

Yes, once grub works, you will not need to flash mod BIOS, this is doing same thing as the mod BIOS, changing BIOS default setting instead of making the setting visible to you (Since you can’t flash mod BIOS)

If we can’t get it, you may need to purchase a flash programmer (CH341A) and if BIOS is soldered to board not in a socket you will also need SOIC8 test clip cable

The HPET is visible yes, i can choose enable or disable. The thing is, Asrock made it auto enabled even though you can change it in bios, you cant really change it if u know that i mean. They locked it enabled :confused: I need to unlock the HPET. I will try now. 2 sec!

New try with var2!BUllkArT!CTOyilI2rvpsw…emyTJO-lwMNRkRU

You now understand My situation mate? I can disable hpet in bios but it is locked to auto enable. So My disable button is false… :slight_smile: i need to make the button work again

Why is this so impossible :frowning:

Its still not working hm

@pPAKKE - Please stop making multiple posts, bumping your thread does not help anything, if you need to add more thoughts please edit your post!

Did you see this, @POE_UK showed you how to disable in windows [OFFER] Gigabyte GA-AX370-Aorus Gaming 5 BIOS mod (73)

There is two hidden HPET settings in debug you could change for testing, but since you cannot get grub to work you would need to be able to flash modified BIOS to test those changes

Yes, I always understood! But I didn’t know until now you could already see BIOS setting. You have it set to disabled now, via grub, but the debug ones are still enabled.

Please test disable these via regular grub (Not second one/setup_Var2)
ACPI HPET Table >> 0xA0
MsiDis in HPET >> 0xA1

Set both to 0x0

Setup_Var 0xA0 0x0
Setup_Var 0xA1 0x0

If you still can’t get it, quit fighting it, and order a CH341A programmer and SOIC8 test clip cable, then wait for delivery, it’s all you can do if you cannot flash mod BIOS, it’s that simple no amount of continued stress about it can fix it.

The system Hung and cant get picture on blot now mate… Hm fuck hehe

What did that? If it was due to changing those variables above, then clear CMOS for extended period without power (Remove PSU and CMOS Battery) overnight or while you sleep etc. Then it will reset BIOS to stock

This wont make the system hang, and if your games are running so poor id be looking elsewhere for issues. theres no need to mess with HPET in the bios

Windows or driver issues for you mate not hpet