Help extracting MSI bios.exe please? [SOLVED]

EDIT: I figured it out by using a program called B2MB.exe.

Hello again,

Recently one of my clients sent me a MSI H67MS-E23 (B3) motherboard that had a failed bios flash. However, during bootup I see that it is simply looking for the files. He told me he had launched the bios.exe from his desktop and NOT from the USB drive as MSI had requested in the instructions (not sure if this is accurate). Thus this board appears to be in an endless loop looking for the files on a USB pen drive.

MSI BIOS instructions:

He also told me he tried the latest BIOS, so I assume that means 13.2. I do NOT know what cpu he tried it with, but I only have a Pentium G2130 22nm CPU here to try to recover this board. However, the board is working with the G2130, ctrl-alt-delete reboots his PC and I see the video error screens below. So I can also only assume it already had a updated bios for 22nm.

This is the screen I see when first turning it on (without USB inserted)

This is what I get when I insert a USB pen drive and then turn it on.

So, obviously it is still stuck in the flashing routine looking for the files, even after I cleared cmos via the jumper.

I have tried extracting all 15 bios revisions and putting them onto the USB drive, in the hopes it would see something worth flashing but it still does not see anything. The last THREE bios releases are in “exe” form and thus they will not extract for me on my PC because it is the wrong board obviously. His MSI board also will NOT enter the bios, it only shows me the above two screens no matter what I do.

Here is what I think I need to do, I need to extract the latest bios “E7680vD2.exe” and put all the files onto the USB drive? This is what I thinnk I need to do, but I have not found a extractor that works yet. I have tried 7zip, UniExtractor and MultiExtractor and Windows 10 built in extractor and none of them work, all giving me one reason after another why it can’t be extracted.

This is what I get (on my PC) when I try extracting (running it normally) by using “Run as Administrator” from the USB pen drive on MY PC.

So, lol if anyone knows of a tool that could extract the bios files so I can put them on my USB pen drive to see if that allows his machine to complete the update, that would be HIGHLY appreciated. I am sure there is a tool to extract this BIOS.exe, right?

Thanks again
Best Regards

OK, haha

Right after posting the above I found the program B2MB.exe and it extracted the needed files and sure enough it updated just fine and now I am in the BIOS on his machine. Strange that I didn’t need a single reply here, but gave up far to soon trying to extract it with normal tools. Just had to change the Google search term somewhat to get the right results.

Anyway sorry for creating this thread for something so simple. Thanks again.

Hi dear …
I rejister for this forum just for thank " SkOrPn " for great and usefull post
Because i have some problem and fully fixed this problem by your post

thank you from Iran

hey I have to the same issue but find that b2mb.exe

Edit ur post and specify model and bios version / Link the bios file

EDIT: Presumably its MS-7677 (H61I-E35 B3)… ur responsibility to confirm and point/link to the right product web page, agree?

EDIT: @Drjay Here u go E7677IMS

msi h61-e35 b3

yes that’s correct MS-7677 (H61I-E35 B3)

I found the b2mb.exe app but no luck
bios update is not yet completed please insert the USB pen drive