help flashing asus ROG maximus xii EXTREME custom rom

hello guys,
i come to you today after 48h without sleeping trying to mod my MB without succes. what i need to achieve, is to change motherboard UUID, serial number and mac adress ( as you may guess, trying to bypass and game HWID BAN). Sadly, every single attempt with every single tool has failed.

Attempt number 1 : Switch to 2ndary MB bios :
my UUID and MB serial number still the same

Attempt number 2: DMIEDIT V5.20.0042:
i can change values here and update them, sadly they do not stick on reboot

Attempt number 3: afuwin

after dumping bios into a .rom with afuwin v5.14.01.0015, i cannot reflash it with afuwin.x64 /p /k /n ( means i cant flash my modified rom file neither)


attemp number 4: afuwin with .rom extracted from official .cap file

then i proceed to download original rom file from asus documentation, extract the .rom with UEFITOOL, and flash it with afuwin like in attempt number 3, sadly it gives exact same error c8- Error: Invalid ROM image file

attemp number 5: afudos

loading it from a USB FREEDOS, dumping or trying to flash any room leads to different error: "Error reading flash information " i guess afudos is way outdated for my mother board

attempt number 6: afuefi 5.14

same stuff than in attemp number 4 , says c8 -Errror

attempt number 7: FPT

so i went in and checked my CSME VERSION:, so following the win-raid Intel-Management-Engine-Drivers-Firmware-amp-System-Tool thread i downloaded the CSME System Tools v14.0.20+ r11 - (2020-12-05)

then i proceeded to dump than to reflash the bios section only , but i have PRR error on fptx64:


i cannot even use PRR as i cannot find FPT DOS version for my ME…

i am now running out of solutions, can somebody help me to flash this damn motherboard, i would very upset to have to change it knowing it costed me 1000e

Hello guys,
Still noone has any clue what must be done on this motherboard ?

[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing

"To check if your SPI chips’ Flash Descriptor is locked or unlocked, you can simply try to dump its contents via software-based general purpose SPI flashers such as AMI AFU, Intel Flash Programming Tool, Flashrom etc. For Intel systems, it is recommended to use Intel’s Flash Programming Tool from the Engine CS(ME)/CS(TXE) System Tool packages by running the command "fpt -d spi.bin". If it completes successfully, by dumping the entire contents of the SPI chip, your FD is unlocked. However, if you encounter any CPU/BIOS Access or similar errors, your FD is locked for system security purposes, as per Intel recommendations."

I can succesfully dump with fpt,hence my spi flash descriptor is already unlocked isnt it? Or am i missing something ?

Dump ir reading…read the post #659