[HELP] I cn not locate BIOS chip in ACER Aspire 5920 motherboad (DA0ZD1MB6G0 REV.G motherboad)

Hallo all,

I do not know if this kind of question goes in this forum… If not so, sorry.

I need reprogram my Acer 5920 BIOS with CH341A, but it is impossible to me to find the BIOS chip in th MB. I have downloaded the Service Manual, serar the whole net, on phots, videos, etc. without result

I have even searche in all my 8 pins chips in the motherboard, searching for Phoenix logo or something like that, but nothing till this moment. Does anyone where is located the Phoenix BIOS chip in this MoBo?

Thanks in advance

well, going on searching…

I found the DA0ZD1MB6G0 REV.G schematics and from it, what I think is the BIOS diagram

spi_flash.jpg



From it, searching for the "U11" chip in my MB, I found this close to the Winbond

placa.jpg




As you can see that is the U11 chip (I supouse that the number 8 beside it, may be the 8th connector of the BIOS chip)

Is this one the BIOS chip really?..

@Haplo - dump that chip and see, it may be BIOS, or may not be, it could be EC FW or other FW or other controller programming etc
Only way to know is dump it. Can you read the chip ID?

This does not match the schematic, which I also found and downloaded, but I assume you have same one and it’s for Rev B board.
I mean, this chip is not at U11 is all, but that means nothing. What do you see at U11?

Send me a zip of a few images of front and back of the board if you have it completely out of the casing

Thanks for your answer @Lost_N_BIOS.

The ZIP with the images is about 68MB, Can you download it? And this is the schematic I have

MoBo images
Acer 5920 Schematic



It too small, but this is what I have read: “MX15G - 25L8005M12C - 2X345400 - TAIWAN - 1074914”



That is another problem, every position I connect the dam clip, nathing happens (programer vers. 1.34 on Windows 10 x64)

programmer.jpg



And this how I have connected the programer

IMG_20190921_113235.jpg



IMG_20190921_113318.jpg

Acer Aspire 5920.zip (1.42 MB)

Hallo @Lost_N_BIOS .

As it seems anyone can find my BIOS chip, I am trying the trick with the USB recovery option. For Acer laptops the keys than make the trick are Fn+Esc, as I have read in a lot of forums… but I am not able to flash anything

I am using a very old USB 128MB, formated in FAT32, but I do not understand the process. I have tried it with WinCrisis, created a bootable USB with Rufus, leaving only the BIOS file in the USB. Nothing works.

I downloaded th original BIOS file from:

Acer 5920 BIOS

I have tried with the original file name (ZD13813.wph), renaming to bios.wph, BIOS.wph… I do not know what more to do.

Some idea?