Help modify my ThinkCentre M900 Tiny Q170 for Kabylake?

could anyone smarter review what is wrong with this rom after adding kabylake microcode gives a flash error message
Note: The BIOS update process will continue after system reboot. Please do not
remove your power!!!

afuwin.exe imageFW.rom /p /n /r /sp /b /defans /capsule
| AMI Firmware Update Utility v5.09.02.1384.07.B608.LV |
| Copyright (C)2017 American Megatrends Inc. All Rights Reserved. |
Reading flash … done
- FFS checksums … ok
- Check RomLayout … Ok.
Loading capsule to secure memory buffer … done
18 - Error: Secure Flash Rom Verify fail.

Child process failed. Return code: 24

i will put here an oem and a modified rom.any help is welcome.

win raid pilt2.jpg

oem.rar (5.59 MB)

modded.rar (5.61 MB)

M900 Desktop (ThinkCentre)


are those correct?

bios includes 506E1,506E3

[Guide] How to flash a modded AMI UEFI BIOS

USB Drive UEFI BIOS Flash Package version FWKTB5A dated 19 Jan 2021

M900 Tiny with mentioned microcode

[GUIDE] AMI INTEL CPU Microcode Update Guide (30)
[GUIDE] Coffee Lake CPUs on Skylake and Kaby Lake motherboards
[Guide] Transfer of specific Intel OROM VBIOS and GOP VBT settings by using Intel BMP tool

hi onuracengiz.
thanks for the help. i got a nice biose flash and my old cpu 6700t works fine with it but the 7700 does not .pc goes to work and you can see that the pc detects the cpu because the impeller works according to its heat which is ok but no boot win. it was expected since here in the forum gathering wisdom I noticed that just adding a micricode is not enough. it seems that it is necessary to update the intel firmware me and also the gop. this is already a new challenge for me. if you could help with this it would be very grateful and I would pay for your efforts if the thing works.

updating management engine is easy.just follow the seems overwhelming at first sight,but actually takes a second to do
Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

the bios zip has more than a dozen files included as you already know.hard to tell which one is actually belongs to your device.maybe there is a clue on the back panel? cause it would consume too much time to modify them all

what should i look for in the back panel?it is not clear which firmware the tools should use. currently we have the firmware ver.11.02.1003

drag and drop the bios file (or dumped) onto MEAnalyzer and it will give you the necessary informations
Or use hwinfo


File does not contain Intel Engine firmware

As this is an OEM machine a CHA programmer is a must and ur safeguard in this kind of risky operations. A backup of the current working system is advised.

The update files for ur system from Lenovo r not full bios updates as they do not contain ME.
Update the machine to the latest bios version then u have to make a full dump of ur SPI to work with.
First verify the ME type/version from the dump…its not always possible as it fails, the upgrade to ME 11.8, 11.12 or 11.22, this is the first test regarding any mod to the mcodes…or not, ur choice to go straight to mcode modification.

The flashing of mod files fails due to security from the OEM, use FPT or CHA…be aware that the machine can be killed during try outs.

There r success reports of Lenovo machines with H110 just adding mcode.

Quoting a M700 user in Lenovo forums: "If you want to try it download the file below and unzip it. In the folder you’ll find “wflash2” and “wflash2x64”. Open the first if you have a 32 bit operating system, the second if the operating system is 64 bit.
now you have a command line. there type: “wflash2x64 XXXXXXXusamod.bin” (without quotes) and click enter.
It should reboot."

A note…keep in mind the TDP of an T processor against a normal 65w or a K.

Reference to M700/M900 Bios Mod

thanks for the help MeatWar. it seems that without the programmer CH341A you can’t catch it. in case something goes wrong then you will get a pc brick. it is incomprehensible that the volume of the bios is 16mb but the bios file is 8mb.
I know that 7700 is 65w and I already ordered a suitable cooler here

hi onuracengiz
can you give me a link to which forum or topic this bios file is from. since oem products so easily without programming time the bioses firmware does not change then the idea arose that maybe you would benefit from this bios source because it went without problems and now i am more than sure the thing is behind the firmware. i have already researched a lot and it ver. which i have does not support kabykake and and the newer one is offered wants intervention by the manufacturer. i think the microcode. anyway it would be grateful if you could give a clue where the seee bios are from.

that bios file is based on official one

i already understood that but who added this microcode

i got the firmware apart but the picture still doesn’t come up.…e%20switches%29

readme file says 11.8 corporate
you need this tool,CSME System Tools v11 r39 - (2021-03-05) from Intel (Converged Security) Management Engine:Drivers, Firmware and Tools
open up the meinfo tool in cmd and get the detailed info of your ME
that file might be older,so instead of downloading it,get the known latest from given page then update it according to that info
either, CSME 11.8 Corporate H D,A v11.8.83.3874 or CSME 11.8 Corporate LP C NPDM v11.8.83.3874, or CSME 11.8 Corporate LP C YPDM v11.8.82.3838

thanks for the help but there is no way to make a real bios or 16mb because on protection. i tried flashrom but can’t. just need to make a dump file of my own full bios. I would see what is the difference or missing. at the moment .I am trying to force kabylake without a programmer that is the point but the programmer will get it right …

@rycyve The problem is that the M900 only ever supported Skylake and never had Kaby Lake support added to any BIOS.

You might want to read this thread as someone did get it to work by combining the BIOS region from a M910 but unfortunately didn’t upload the modified BIOS, although they did say there were several isues.

chinobino thanks for the reply. i am fully aware of these topics and i have working bioses on my device but they can only be flashed by a programmer. I want to first know the dump file so that the program can basically flash it back. i tried fpt and flashrom but they can’t open them due to oem bios protection. can’t find threads where it can be done.



@rycyve Yep, you have PRR that are preventing software tools from flashing - you’ll need to use a programmer to flash any unnofficial/modded BIOS.

in fact there is a bios dump that can be used on a program basis but not by its creator.
Lenovo M900 Tiny Coffee Lake…us.30734/page-2

then i finally got this result when modifying 8mb bios by changing gop, gop vbt and vbios. flash is not daring yet because ch341 is still coming and vice brick to make a pc. who has ch341a can try this bios. left oem and right mod bios. I’ll upload it here too.



imagefw.rar (5.69 MB)