[Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN

@Lost_N_BIOS :
Still 208 error

208 ERROR.JPG

What is FS0, a hard drive you are trying to map? If yes, none of that is needed, once at grub shell follow the guide from shell prompt.
Although, “Shell” is not the goal here so maybe guide is wrong, it should be a grub prompt so what I linked may be all wrong.

When using Setup_var xxxx 0x01 it will give feedback, like you see in the images in the guide, saying setting found is at 0x1, new setting 0x0 etc.
If that does not happen from “Shell” prompt then nothing is changing in regards to what we need, so no surprise FPT still cannot flash.

Set that aside, can you simply boot to USB with the EFI file from guide in root (Put two copies there, one as its named in download, one renamed per the guide)

You may need to purchase $3 CH341A flash programmer, and $2.50 SOIC8 test clip jumper cable.

* Edit * I just did quick test and it works! I am not sure which is correct placement of files for this, so do all of these.

Make USB Bootable per this guide I outlined, do not double copy over file contents for DOS stuff, only use the HP Tool which puts only three files onto the USB
<Request> Flagship X470 Gaming 7 Wifi Motherboard BIOS Fix

Then make two copies of the bootx64.efi, one named that and one named Shell.efi, put one set of those in root of USB. Make a new folder at root named EFI, put copy of each inside there, and in that folder make another folder named BOOT and put two more copies inside that.

USB-Grub-Shell-Working.jpg



Go to BIOS and choose boot override to UEFI USB HDD, or set UEFI USB HDD to your first boot device. Then boot to USB, grub command should launch

Nothing Works, Time to surrender? :frowning:

280.jpg

shell.jpg

shell2.jpg

Sweet, you got to grub! From your images, you still need to set 0x11c to 0x0 And while were there, go ahead and make sure 0x11A and 0x11B are set to 0x0 too (BIOS Lock), they should be per your BIOS setup file but best to check while were in there.

So you want 0x11A, 0x11B, 0x11C, and 0x11D all to be 0x0 and then on immediate reboot go to windows and use FPT. By default only 0x11C and 0x11D should have needed changed.

You can verify each ones current setting once you are done by entering name only one at a time without setting value and it will show you current setting
Setup_var 0x11A
Setup_var 0x11B
Setup_var 0x11C
Setup_var 0x11D

All = 0x0

Never give up!

shell.jpg

shell2.jpg

shell3.jpg

shell4.jpg

208 ERROR.JPG

OK, tonight I change the settings in stock BIOS without any other mod and we try again! In the meantime, have you tried AFU?
And did you already order $3 CH341A flash programmer and $2.50 SOIC8 test clip cable, if not order those now so they’ll be on the way, cheap but long wait from China, or pay more $$ and get locally.

Also, while we wait for me to have more time to dig into BIOS, please download this and run the included commands from a separate command prompt at each #'rd folder (Not sure which version will work on your system)
Whichever folder does not give you the error, upload and send back to me, if it’s two folders great, send me both - I think we can change lock here too, can’t believe the setup_Var did not unclock it!
http://www.filedropper.com/checknvram



I cant get locally, from china it is a long time to my country

nvram.JPG

No one sell on ebay or amazon to your area? Yes, it’s usually 3-5 weeks or so from China for me too, for most sellers. You might need to order this no matter what, since price is so cheap I would go ahead and order now, that way they are on the way to you if we can’t fix otherwise.

Few things on the above test, I am not sure, maybe that is due to windows 10? Please try installing all 32 and 64 bit C++ and try again, this time reboot after installing all C++ and then try 32 bit again, if that fails try the x64 command included now.
https://www.microsoft.com/en-us/download…s.aspx?id=48234 << Install this

Then install these if win10 will let you
https://aka.ms/vs/15/release/vc_redist.x86.exe
https://aka.ms/vs/15/release/vc_redist.x64.exe

Then try again, here is new package with 32/64 files and separate commands for each
https://nofile.io/f/C3u1O6AASMM/Check+NV…64-Included.zip

And please run meinfowin -verbose
Then upload image total here, split image OK, or copy entire text and put here in spoiler tags.

Do you have a spare HDD you can put in this system, so if needed you can setup Win7 quick install so we can get this NVRAM info and possibly re-write the NVRAM to unclock if setting locking you out is held there?

Have you already tried modified BIOS flash from DOS, using the included DOS utilities with stock BIOS (DOSFlash.exe + flshuefi.cpu in same directory as mod BIOS)? Filename may need to be exact as original (J52_0276.BIN)

Is there any labeled or unlabeled jumpers on the motherboard, like FD, Service, MMode, etc? Please check and upload some images if you are unsure, there might be a jumper to put in service mode so you can flash all BIOS including an unlocked descriptor too.

Please also test this nugget for HP I found - Shutdown the system. Press and hold WIN+[left arrow]+[right arrow] then press the power button. A bios message will indicate the SPI flash descriptor is unlocked. Does this happen? May only apply to their notebooks?
If yes, I can send you unlocked descriptor to flash via FPT, unsure if this will get around the 280 lock, but it will be a great start because flashing via FPT is much easier than other methods.

Hello!

Same error with SCEWIN and X64 " LoadDeviceDriver returned false
ERROR:1 Unable to load Driver"

, Says INVALID ROM

OK, so DOS is out. Please reply about all the other things I mentioned (meinfowin -verbose, spare HDD/Win7, jumpers on the board)
Aside from that, if you don’t want to mess further with trying things, only way to do this is CH341A flash programmer and SOIC8 test clip (If BIOS is soldered to board)