[Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN

Hi everybody,
To begin, I would like to thank the creators of this forum for all informations.

I have a first generation HP Z1 and I would like to offer him the opportunity to unlock his possibilities by unhidding Advanced menu.

I downloaded AMIBCP v4.53 to opening the last firmware : J52_0274.BIN but i’m afraid to make mistake.

Please, is it the right software for my needs ?

Could you confim me i need to activate USER at Access/Use in Setup configuration ?

Thank you in advance for give me the procedure to follow for making a perfect bios.



Normal advanced menu


Hidden advanced menu


Just to ask

Have you unlocked hidden menu?

I tried , but i cant :frowning:

(Sorry for my Bad English)

@skam2420 Yes, this is possible. Were you able to flash your modified BIOS without issue? If yes, I can mod for you, or if you have flash programmer even better.

Please link me to stock BIOS you want unlocked.

Thanky so much, this is the STOCK BIOS https://ftp.hp.com/pub/softpaq/sp88501-89000/sp88794.exe :slight_smile:

Thanks, I will look!

Have you already flashed a modified BIOS at all before on this board, or do you know someone that has before? Do you have Flash Programmer like CH341A or others?
I ask because sometimes it’s difficult to flash edited BIOS, so wondered if you already knew working valid method or not.

I wiil try to flash in this model for the first time, I flashed ALIENWARE INTEL PROTECTED FLASH , I will try to do something like I did on alienware to bypass the security

Sometimes we just have to figure out what tool will work (AFU or FPT, or maybe standard non-OEM phlash etc) vs the stock flasher which will not work with modified BIOS. I will know once I extract the stock exe contents.
If you have some spare $, only $6-7, go ahead and order CH341A flash programmer and SOIC8 text clip jumper cable they are $3 each usually or less. That way you have it on the way in case either it’s the only way to get modified BIOS into board or in case of bad flash and you need to recover BIOS

@skam2420 - I am unfamiliar with that BIOS flashing tool, and even unpacked and viewing the internals of the HPQFlash tool itself DOS or Win I cannot figure out what they built it around/with, maybe their own flash program instead of one of the usual suspects.
Can you please download these Intel Flash Programming tools package - https://mega.nz/#!CF1l1LJK!K2l6_74FPsGig…Rvp8Efj8a5drZSc

Unzip and go into main root folder where you see several sub-folders. Go to “Flash Programming Tool” go into that folder, and on the “Win32” select that folder, hold shift and then right click, choose open command window here.
Then run the following commands one at a time, take an image of each one if there is error (So I can see error, and command above that causing the error). And zip and upload or attach any/all files output from these commands (spi.bin, desc.bin, and biosrgbackup.bin)

fptw -d spi.bin
fptw -desc -d desc.bin
fptw -bios -d biosrgbackup.bin

ok, I will do that at night (13:05 here), I am at Job, but I will do it soon as possible

No hurry, I’m leaving shortly too and wont be back until tonight either

When you get back to this thread, please show me images of your current BIOS, advanced section, main section, file section, and security section.
And please be sure to make all top tabs/sections viewable, so I can see all current visible sections and their names.

@Siem - if you still need this, I will be modifying this BIOS over next few days - probably take a few revisions before we get everything unlocked and visible - heads up!

Hello, Here are the files http://www.mediafire.com/folder/4speqhdsh796a/

Siem bios and my request are the same model (my request is the last update) :slight_smile:

Thanks, looks like we can update "BIOS Region" via FPT, and that is all we need for this! I still need all images mentioned in post #9 before I can get started

LINK UPDATED with pics of BIOS options n_n

What is in File “Replicated Setup”? Please take more images in new folder at mediashare, if that is another big set of menus.
Never mind, I see this is to save current settings so you can load them again later vs the default settings application option directly below that

@skam2420 - you said you already tried, but can’t, does this mean you set “User” to some menus in AMIBCP, and flashed that BIOS, but still no change in BIOS?
Asking to confirm you did this already with AMIBCP, so further edit is needed on top of that, and so that I know you’ve already been able to flash modified BIOS and it accepted it. How did you flash modified BIOS?

I tried with AMIBCP but give me an error when save the file , replicated setup only give 2 options, SAVE TO EXTERNAL USB DEVICE or RESTORE

Thanks, I was just curious what you had tried and it’s outcome. I do not get any error when saving edited file with AMIBCP? I did use 4.55 though, so maybe that is why no error?
Anyway, usually change to “User” does not always work, but it’s sometimes needed to leave that way on main/root menu entry and then user another method or two on top of that, so that is why I asked what you set and the outcome of your testing.

Thanks for the info on replicated setup, I found answer in AMIBCP shortly after I asked.
I will probably have test BIOS for you tonight to try, this may take us a few times to get things how you want them (If I can enable at all), so be ready for many tests. First will be enabling the menu’s themselves, that might take a few tests/attempts w/ different methods.

For now, here is quick initial test with 3x Root Menus set to User via AMIBCP - do not expect them to be visible now, but we have to test this anyway first

Flash using FPTw and the following command
fptw -bios -f J52_0276-AMIBCPTest-3x-User.BIN

If there is error when running that command please show image, thanks!


Error 280: Failed to disable write protection for the BIOS space! :frowning:
I used the PRR TOOL to unlock de protection but….


What does “PRR Tool” actually unlock? There are several BIOS type locks that can be set, by name, which is this supposed to be fixing?

Please show me image of the FPT error as shown, thanks! I will check if I can disable within the BIOS, if not you may need to boot to grub and do a setup_var edit, not sure.

I checked BIOS, and I see SMI lock and BIOS lock are disabled by default, but “BIOS Interface Lock” is enabled but I’m not sure this applies to this, but possible since it’s the only lock I see enabled. Also RTC RAM Lock is enabled too.
I guess for now, we can disable both of those and see if it helps, I think it should. Give me a second if you’re reading this now, I’ll be editing in how to unlock these.

* Edit - here is the guide to use, this is for Asus board specifically, but after reading I assume you’ll be able to find the same things in your BIOS to get you where we need to go
[GUIDE] Grub Setup_Var Guide - Fix Intel FPT Error 368 - BIOS Lock Bit Set HSFS W/ Asus or Other Mod BIOS

And these are the variables we’ll changes for your board vs what the guide talks about.

BIOS Interface Lock >> VarName >> 0x11C >> Change to 0x0

RTC RAM Lock VarName >> 0x11D >> Change to 0x0

If this fails still after you change above and boot to windows, don’t worry I will give you another method that should for sure help you get it all unlocked via NVRAM edit

EFI SHELL OPTION does not exist in this bios :frowning:


In secure boot options, disable legacy boot (Or enable UEFI USB Boot), and set USB as first device, then reboot to it and it should load the EFI Shell. (Don’t rename the bootx64.efi)
If we can’t figure it out, there ill be no way around this, without flash programmer. I’m sure it’s possible since this BIOS has secure boot, UEFI Options etc.
Asus is the only BIOS that specifically says boot to this EFI Shell, other boards you just boot override to USB and it loads

You could try the DOS flasher with mod BIOS, but I bet it checks some signature like the windows one does, maybe not though? Try and see

You may also see EFI option on “Boot Manager” when pressing the boot manager hotkey at startup. I read you don’t need to disable legacy boot as I initially thought, only ensure that secure boot is disabled.
Here’s a guide for another HP I found, should apply the same - https://blog.inf.ed.ac.uk/neilb/2017/03/…irmware-update/

Also found this guide, for directly booting to USB EFI Shell - BIOS aside, like booting to DOS USB Style - It’s for Asrock, but that doesn’t matter

I can verify this is possible one way or another due to the HP DOS flashing BIOS utility runs similar shell flshUEFI.CPU, which is flshuefi.efi really, a flash shell driver.

@Lost_N_BIOS :
Shell not working

I use map -r, all is showing correctly, but the commands does not work


MAP -R.png