[HELP NEEDED] Load DMI data from original ROM to modded BIOS

Please find the file here (Download results20.rar from Sendspace.com - send big files the easy way)

Thank you.

DMI information is in bios region (that’s the firmware region you backed up):

Address in bios region is 0x1C5000, for a complete image (possibly 4 MB spi) this would be 0x345000

There’s a possibility that you might find a SONY DMI tool for editing, but I suppose it’d be easier to simply update the image you flashed and flash again.

What was the reason that you used a dump from another model?

Thanks for your quick reply.

The reason I used a dump from another model is because I was dumb thinking it is just as simple as install a program. What motivated me to do that is because I had the SSD installed but the original BIOS only enable RAID, so I was trying to enable AHCI for the drive and upgrade to Windows 10.

I hesistated to use the mod BIOS at first but I can’t resist it; therefore, the catastrophe now. :pensive: After the flash, I try to reinstall the OS with the recovery media from SONY but it wouldn’t allow me to, and that moment I realized that I was F (pardon my language) and it’s been 2 long nights for me recently :melting_face:

So for next step, I take your advice. Could you please guide me through the process to update the image and flash again?

On another thought, if the info can be updated into the modded BIOS, is it possible to unhide the menus in my original ROM so the BIOS is modded for my own VAIO?

Best regards,

How did you flash the modded bios?

Please post the modded bios, too.

What works and what doesn’t work?

Can you boot a Windows or a DOS USB stick?

This is the link to the modded BIOS that I used (Bios.Wynna_R2087H4_Mod_IFR)

I just unpacked it and run the Write.bat file.

The modded BIOS unveil all the hidden menus, and allow to choose between the mode (IDE, AHCI, RAID) and other stuff like graphic card, CPU temperature etc. My laptop was able to switch to AHCI after the mod. About what didn’t work I think I wouldn’t be able to say coz out of my knowledge :sweat_smile: and I was too freaked out after finding out the info was replaced.

OK, thanks.

Download from Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15)

ME System Tools v7

Unpack either in Windows or on a DOS bootable USB stick. (Windows version requires properly installed ME driver)

fptw64.exe -d DMIwrong.bin -A 0x345000 -L 0xA0 (Windows) or
fpt.exe -d DMIwrong.bin -A 0x345000 -L 0xA0 (DOS)

Post DMIwrong.bin

Thanks for your prompt respond and sorry for the wait, it took me a while to digest the instruction :sweat_smile:

  • I did backup an image of the Windows 7 after the modded BIOS flash; and I have managed to update the OS to Windows 10 now.


To ensure the correct info, I go with the DOS bootable stick

  • I created a boot USB with Rufus 2.1 as below

and stucked at copying the right folder to the boot USB

Please advice the right one to copy over to the USB.

Thanks and regards,

FPT stands for “flash programming tool”, use the version according to OS, in Windows as written with properly installed driver and in an administrator command window, But I recommend to do this in DOS.

It’s just a try to maybe keeping you from disassembling and using the programmer. First step is to dump the dmi area with fpt, check if address and range is correct. If the addresses are correct you’ll try to flash back the same little piece, if that’s allowed one can update the dmi information.

Thanks for your guidance.

I’ve extracted the DMIwrong.bin in DOS and uploaded it here (DMIWRONG)

Looking forward to the next steps.

OK, thanks!

Was thinking a little complicated here, after checking how you did the update it’s clear that you can reqrite the complete bios region with fpt, there can’t be any protected ranges.

Just out of curiousity try to dump the complete firmware:
ftp -d spi.bin

(Might give an error because of ME locked for reading in Flash Descriptor, then ignore this command)

Download and put it in the same directory where fpt is located:
DMIOK.zip (312 Bytes)

fpt.exe -bios -d biosreg1.bin
(=> Backup of the bios region before flash)

fpt.exe -f DMIOK.bin -A 0x345000 -L 0xA0

Please be absolutely precise, fpt writes without checking the content or the area it writes to!
If you write the DMI information into relevant firmware code you get a brick.

fpt.exe -bios -d biosreg2.bin
(=> Backup of the bios region after flash)

If you can remove the usb stick and have another Windows pc accessible you can do the following to be absolutely sure:
Open biosreg1 and biosreg2 in a hex editor (HxD), compare them (Ctrl-K), they should (using DOS version of fpt) only differ in the small region with the DMI information, should look like:

After a reboot you should have the correct DMI information again.

Just out of curiousity try to dump the complete firmware:
ftp -d spi.bin

(Might give an error because of ME locked for reading in Flash Descriptor, then ignore this command)

Is this the error that you mentioned?

I did again with “fpt” instead of “ftp” as directed. This is probably the error that you mentioned before

Before proceeeding this part, I would like to check with you about the command to make sure I read your instruction correctly (kind of nervous when you said the laptop can be bricked :sweat_smile: :sweat_smile: :sweat_smile:)

fpt.exe -f DMIOK.bin -A 0x345000 -L 0xA0
the 0 in “0x345000 -L 0xA0” are all 0 as in number (zero) and not the letter “O”

0 = Zero

It’s the same numbers and letters as in the command you executed to read, it’s just -f instead of -d = flash instead of dump.

What can I say now? It worked perfectly! :star_struck: :star_struck: :star_struck:

THANK YOU SO SO SO MUCH @lfb6, you saved my VAIO :face_holding_back_tears: :face_holding_back_tears: :face_holding_back_tears:

The recovery USB recognized the laptop again and allowed with the VAIO recovery

Attached below some screenshots of the BIOS for reference

1 Like

Good to hear this worked out, thanks for the feedback!

Keep the backup of the bios region, might come in useful sometime later… (But you don’t have a complete image, you’re missing at least FD and ME region)

1 Like

I did save everything, thank you :sunglasses:

Do you think I should do a complete image backup? :nerd_face:

It’s ‘nice to have’ in case somthing will happen to your firmware.

But you’d have to deal with the flash descriptor or using a progammer, meaning possibility for damaging things in the process. For now definitely not worth the effort!

1 Like

Noted and thanks again for your help :pray: :pray: :pray:



  1. I reinstalled Windows 7 and ran the Windows assessment, the score for the processor was different from the original BIOS which was 6.3. So I wonder if this has something to do with the modded BIOS (the machine from which the modded BIOS was built has an i7 processor, while mine is an i5)

  2. The machine freezes a lot both in BIOS and Windows. I read that if the BIOS is loaded from another machine, the ME region is mismatched hence causing all the glitches.

  3. I wonder if the BIOS update utility originally from VAIO BIOS Update Utility.zip (5.5 MB) will get the machine back to previous state or the modded BIOS has tampered other parts of the firmware.

Please advise on this :sweat_smile: