[Help needed] Medion H110 modding for XEON v5 support

Hi all !

I’m trying to make a Xeon v5 working on my Medion H110 motherboard.
For now, I’ve tried the FIT / ME Kernel mod but with no success. The board can’t boot.
I have an USB EEPROM programmer so I can do some tests if needed.

Thanks for your help !

Edit by Fernando: Thread title shortened and specified

Medion H110.rar (3.76 MB)

I would have liked to test an ECS BIOS version but the file seems to be not compatible with FIT.
I’m unable to find an older version of my BIOS to test it. I Only have the 1.11 one.

mCode is present, wots the exact model of the Xeon V5?

Thanks MeatWar for your answer.
It’s an E3 1225-V5

it seems that ME version can be the bad one but I don’t know how to change it.

Even so it may still not work, follow this guide: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

and u may try to update with the Intel ME FW tool from CSME System tools 11 r41, to the latest CON H presented here on the repository: Intel (CS)ME, (CS)TXE, (CS)SPS, GSC, PMC, PCHC, PHY & OROM Firmware Repositories

U cannot use higher than (Minor version) 10.0 (No 10.5/8/12)

EDIT: The ME version on ur file is

Thanks for your answer but I’m not sure to be able to do all this stuff alone.

How can I check the current ME version of my BIOS ?
Should I try a newer version of the current one or an older ?

Is the FIT / ME Kernel / Reserved -> Yes a prerequisite ?

Thanks ! :slight_smile:

  1. which MB Version do you have? H110H4-CM2 (Aldi-PC Medion Akoya P2120D)
    2. do you have a KBL aware BIOS? - there you will have ME version 11.6 or higher.
    In your BIOS there is one CPU µcode only: 506E3 = SKL R0 version E2

    possible KBL aware BIOS: https://www.computerbild.de/download/BIO…D-23467137.html

Thanks Datascock for your message.

1. My motherboard is the H110H4-CM2 version from Medion.
2. My BIOS is Skylake only. The XEON 1225 v5 is a Skylake isn’t it ? It’s the same R0 revision of the i5 6400 I had before.

The H110H4-CM2 motherboard is a DDR3 motherboard, the P2120D has a H110H4-EM which is a DDR4 one I think.

With the only BIOS I have, the 1.11 :
- Without any modification : the board is starting for 1s then power down, then power up for 1s…
- With the FIT > ME Kernel > Reserved = “YES”, the board stays powered but no POST.

I haven’t been able to find former BIOS version for this board to try others BIOS.

Check if you can find MB description pointing to a H110M MB by ECS: https://www.ecs.com.tw/en/Product/Motherboard
May be you can use any BIOS there for your MB (as this Medion one had been produced by ECS)

attached are 2 files
one with updated Microcode for all Sklylake
one with additional updated ME (11.7) and Vbios

May be one will fit.

Revert for the ME updated File- the Xeon may work with ME 11.0.xy only

Medion H110.skl.bin.zip (4.16 MB)

Thanks Dataschock for your answer.

Yes, the ECS H110M-C3D looks quite the same as my Medion board.
There are two BIOSes for this board (one is supporting Kabylake) but when I try to import the file into FIT, It says there is an error.
ECS file is a *.BIN file that makes 6,4MB instead of 8MB and even when renaming it as .ROM, I can’t import the BIOS under FIT.

Thanks for the BIOS, I will try it today !

ECS-C3D.rar (4.17 MB)

Hello !

Unfortunately, I broke one leg of my EEPROM chip trying to bend it to fit into my USB programmer…
I haven’t been able to test your BIOS Dataschock and now i’m in search of a new EEPROM.
Thanks for your help !

Have a nice day !