Help needed to recover from a botched BIOS Flash on the ASRock Z77 Extreme4

So, this is what happened:

I downloaded the modded BIOS from MDCLAB for my ASRock Z77 Extreme 4 and went into the BIOS, and then on to Instant Flash, and tried flashing it.

The system froze during the "Processing Crashless Feature" and never progressed further. I tried restarting the PC to no avail. It boots into the UEFI Recovery Mode, only to freeze up at the exact same progress.

Luckily, I have a dead ASRock Z77M motherboard, from which I was able to extract its BIOS chip, which allows me to boot up the system. But since the features for this motherboard is vastly different, a lot of options are non functional.

What are my options now? Is Hotflashing possible? Thank you in advance.

Update: I have manage to brick both BIOS chips now tying to flash the MDCLAB ASRock Z77 BIOS. I don’t think the edited bios that was uploaded there is meant to be flashed using Instant Flash. Avoid their modded BIOSes.

@Lost_N_BIOS can you please help me out? Would you take a look at the MDCLAB BIOS for me to see if it’s corrupt or something?