Help Please, Dell 5410 that doesn't have bluetooth enabled

Hello all, can anyone help me please, I have a Dell Latitude 5410 that doesn’t have bluetooth enabled, by that I mean the internal bluetooth on the wireless card.
I have removed the wireless card and fitted it into a 5420 which uses the same card, and bluetooth works in that laptop, so I know the wireless card is fine, the wireless card from the 5420 also doesn’t have bluetooth available when in the 5410.

When I go into setup, under wireless, the bluetooth option is greyed out, if I look the service tag up on the Dell support page, it seems it was supplied without bluetooth, my question is does anyone now how I ‘un grey out’ the bluetooth in bios setup so I can use the internal bluetooth for my headset / mouse.

I have upgraded the bios to the latest version on the Dell 5410 support page, which made no difference, there are no passwords set at all on the bios either.
I am guessing (hoping even) that there is simply a ‘flag’ in the bios somewhere that tells the system it doesn’t have bluetooth, the motherboard seems as far as I can see exactly the same as the one in my wife’s 5410 so I am hoping it is a simple mod.

Anyone else had to do anything similar, or know how to get internal bluetooth enabled, I would be most grateful.

Maybe a stupid regard from my part on your pov… but i must.
You know that the BT function can enable/disable in OS or some machines have its own software app switch from the OEM (Dell) or even an external switch on the chassi itself…

Hi, there is in the bios an option for wifi enable disable, which I can select, but below that there is a similar box for blutooth select, that is greyed out, I am unable to select it.
I cannot see any way to enable bluetooth from a switch or keyboard function either.
The bluetooth option in Windows is not visible, in device manager, bluetooth is not detected.
Apparently ‘for security’ Dell supplied the 5410 to certain customers without bluetooth, even though the wifi card actually does have bluetooth fitted and the wifi card works in another laptop so it is not the card that has bluetooth disabled.

Well, if there’s a bios option, that’s greyed out. then one way is finding the setup, use one or IFR Extractor and try to find out if it can be changed by setting NVAR variables for example.

@lfb6 thank you, there is definately the option for bluetooth, but as I said it is greyed out so I cannot select it.
Could you possibly elaborate on how I go about using the IFR extractor and changing those NVAR variables?
Is that something I would need to read the bios using a programmer? if that is so i’ll get a CH341A programmer ordered up, or can it be done through the UEFI ?

Sorry, there are lots of examples in the forum, mostly this is used for reverting the bios region write protection setting, but I used this kind of procedure once for enabling SATA3 in an IvyBridge Laptop where the option not was visible in the bios:

That’s by far not the best example, but it might explain the steps.

Thank you i’ll take a read of that thread tomorrow, just off to work right now.
It looks like i’ll need to get a programmer to dump the bios, so i’ll also order that forst thing in the morning.
Quickly looking, the thread mentions AMI and Phoenix, bios’s which the Dell is neither of those (I don’t think it is anyway!).

You don’t need necessarily a programmer, but you need to make a valid backup/ dump before writing anything into the firmware!
You may try Intel flash programming tool to dump the firmware (ME tools)

Otherwise you can start with a stock bios, but there seem to be two configurations, so you have to confirm which variant your machine uses.

Ok, I tried the only versions of ME Tools I could find and each version when I tried to run fptw64 says something like cannot run on this platform.
I have run Hwinfo64 and it tells me the Intel ME version is 14.1build 2046 hot fix 67, the bios version is 1.21 and is 24Mbytes.
I have ordered a CH341A so when that comes I will do a few full dumps of the bios IC and verify them several times, at least I then have a backup just in case.

Stupid question, but I am assuming it is not possibly to copy the bios IC from another identical Dell 5410 that DOES have the bluetooth enabled and write that into mine? I know the serial and stuff will be copied too, which I don’t really care about, but if it gets the bluetooth working…

Theres no tryout in ME FW tools versions, if the system uses ME FW14 then the tools must and only can be the v14.
The issue here is the access to the spi regions, it can be read only and blocked for writing.

This normally means that it’s the wrong version. You’d need ME14.

The command for dumping the complete firmware
fptw64 -d spi.bin

The command for dumping the bios region
fptw64 -bios -d biosreg.bin

In a Dell update file there are two bios region updates, one with bt enabled, one disabled afaics, but there seem to be other differences, too.

@Meatwar, are you saying then that I am probably not going to be able to do this then as the version 14 is not writeable?
The CH341 programmer has now arrived, I don’t want to risk damaging the laptop if the end result is that even if I can read and upload the bios actually enabling blutooth in is is not possible.

The bios IC is accessible, I can easily dab some thin wire onto the relevant pins and extend them to the CH341 header to read / write the IC.

FPT operations are software based, CH341A are physical operations…
Why so surprise if a bios has its own switch’s/OEM closed manufactured point in the FW, for security measures?
Seems you need a little more reading on the subject…
For now answering your question and the use of the Intel FPT tool regarding regions access, start here and give a good reading:

you are correct, I have almost zero knowledge of bios, the last time I did anything with a bios was back in 1985 and that was a 2716 UV eraseable eprom!
Which was exactly the reason I joined here hoping people with far more knowledge and experience would be able to assist, yes I could possibly learn how to do it myself, but at 67 years old, it isn’t so easy to learn new stuff, and when or if I can get hep doing it, then I am probably never going to have any more need to do anything with a bios for the remainder of my life.

I’ll surely read through the links that you have kindly given, I may then have at least some basic knowledge of the subject, I have fallen flat at the first hurdle, what the hell is a ‘FPT’ ?

I am more than happy to read the IC with the CH341 programmer, but how I read your mail made me think that I would not be able to change what is in the bios in which case it would have been pointless me either removing the IC to read it, or tacking bits of wire on to the pins to read it.
Once I have read the bios and produced a dump file, I would still have zero clue as to what bit would need changing to enable the bluetooth, hence the original request for someone with experience to assist.

So, I found the correct version of the flash programming tool, did

fptw64 -bios -d biosreg.bin

and I have 16Mb binary file, would there be any point me uploading this somewhere so one of you guys with way more experience and knowledge be able to look at it for me and see if there is any way to enable the bluetooth?
I have a programmer, so assuming there are just a few ‘bytes’ that need changing, re-programming the bios IC using that is not an issue.

For info, running fptw64 -I gives

Reading HSFSTS register… Flash Descriptor: Valid

--- Flash Devices Found ---
W25Q64FV    ID:0xEF4017    Size: 8192KB (65536Kb)

W25Q128FV    ID:0xEF4018    Size: 16384KB (131072Kb)

--- Flash Image Information --
Signature: VALID
Number of Flash Components: 2
    Component 1 - 8192KB (65536Kb)
    Component 2 - 16384KB (131072Kb)
    DESC     - Base: 0x00000000, Limit: 0x00000FFF
    BIOS     - Base: 0x00800000, Limit: 0x017FFFFF
    CSME     - Base: 0x00103000, Limit: 0x007FFFFF
    GbE      - Base: 0x00101000, Limit: 0x00102FFF
    PDR      - NOT PRESENT
    EC       - Base: 0x00001000, Limit: 0x00100FFF
Master Region Access:
    BIOS     - ID: Read: 0x000F, Write: 0x000A
    CSME     - ID: Read: 0x000D, Write: 0x0004
    GbE      - ID: Read: 0x0009, Write: 0x0008
    EC       - ID: Read: 0x0101, Write: 0x0100

Total Accessible SPI Memory: 24576KB, Total Installed SPI Memory: 24576KB

So there appear to be two devices, not sure which is which I need to disassemble the laptop next to look inside.