[Help] Problems when trying to reflash bricked 3080

Hi, got a MSI 3080 Gaming X Trio that I tried to update the bios of to get support for Resizable Bar. Used the specific MSI flash tool to do it, it flashed the card and then did a restart and after that the sreen was black. Tried some different things but realized fast that something had gone wrong with the flashing.

Since i didnt have an iGPU i went to my brothers house to try and do a normal reflash with NvFlash but it kept saying “No NVIDIA display driver found” and couldn’t find the card in the device manager no matter what i tried. Tried flashing both in BIOS and in Windows and both times it gave me “No NVIDIA display driver found”. Googled around and found that the only way to fix this was through pick it apart and flash directly into the BIOS memory, so I orderred one of those CH341A USB sets with clamp and everything and thought this doesent seem so hard.

Fast forward to today and i have picked apart my GFX and connected the clamp as instructed but I just cant seem to get the BIOS to write correctly to the chip. Tried both CH341A software program in different version (1.18 and 1.29) and AsProgrammer in version 1.40 and 1.41 but nothing seems to work. Read and saved the bios that showed up and then followed the guides on the internet how to flash it. As said both programs recognizes the chips and can read them (for example the CH341A shows a bunch of zeros instead of FF when reading it) and i can erase and verify it while nothing is on it. However it gives me “Chips are not null” when i try to blank read it even after i have erased it and it only shows Zeros in columns, also it seems to write the new bios correctly if i try to but then i cant verify it cause it says “Main memory with content are in disagreement” and if you try and read the chip again after it just shows up as loads of zeros again.

The chip seems to be one of these www (dot) macronix (dot) com/Lists/Datasheet/Attachments/7521/MX25U8035F,%201.8V,%208Mb,%20v1.1.pdf (MX25U8035F) but non of the programs have them in the list, they only have the non F varitaion or one with an E instead of the F in the en. I have tried using both of them but non of them have worked.

Need all the help i can get cause im really lost atm and it would suck having to throw away a $1000 card cause of a problem that MSIs own software have caused.

Ok fast update, I have been sitting with this for 5 hours straight with the same problem as discribed above, tried one last time before giving up and waiting for answer and this time it found the chip using the non F or E option and could read it so must have been my clamp that was wrong all the time.

Tried fast flashing to the bios that I downloaded from techpowerup but still blackscreen, when I did a fast compare between what was read from the flashed bios and what I downloaded it seemed off but didn’t have time to compare much atm, will continue later.

Any tips in the meanwhile is welcomed.

Ok, got two questions that could help me once I get back home and continue trying.

First of, if flashed correctly the bios on the card and the downloaded flash should look identical row for row right?

Also if flashed correctly, the card should work exactly like it did when new. Like the computer should start normally and show a screen etc? You don’t have to flash again with Nvflash or smth before it works?

Sorry for tagging you but you seem like the most knowledgable @Lost_N_BIOS

Please specify ur MSI RTX3080 card model page product and direct link to that oficial MSI…tool.

This is the update tool msi.com/page/live-update-5-manual

And this is the graphic card page msi.com/Graphics-Card/support/GeForce-RTX-3080-GAMING-X-TRIO-10G

You have to manually write in the “www” part cause I’m not allowed to post links

Yes i know what is ur card…MSI have not released any official updates/tools VBIOS for RBAR to end users, so i dont even want to know what was flashed…
Moving along… u can find plenty of information on using a CH341, just search in this forum for related topics.

Pretty sure it tried to flash the same bios that was already on it, just glanced at the bios names mentioned in the tool and I couldn’t really see any differences in the names.

The "Tool" mentioned is the general MSI software update manager that supports motherboard/vga update services… so looking at the oficial GPU page product the latest vbios is from 2020.
Assuming that u were running the default/original VBIOS in the card… what was the update that the "Tool"found for u to update?
Presumably the software manager detects the current hw and will only engage in updating if the PN/HD ID matches and vbios is older than the server presents itself…
MSI server error/mismatch?

Resuming if the HW itself is not detected…the card is dead, u can check this using it as secondary and if so, no NVidia tools/Flash is useful here.
Only option here if no successful flash with original MSI files, is using a dump of the same model.

How exactly could a bad bios update brick the card on a hardware level?

Tried both of the Gaming X Trio bioses and non of em seem to work. The lights on the GFX comes on but the fans doesent spin up at start (dont know if GFXs still does that at startup) and the VGA light on the motherboard stays on.

UPDATE: Apparently why the fans weren’t spinning was cause you needed to use all 3 8pin power cables… And i only used two cause i was sure you could boot with only two. Well now instead the fan are constantly spinning at full speed at startup and i get the VGA light constantly on and no signal to the screens. Will try a different PCI-E slot when i get home.

NO effect… ur GPU initialization is broken due to corrupted VGA bios/bad flas/bad programming.

Shouldn’t it work with the Bios from their product page? As said I have managed to flash BIOSes over correctly now so I thought it would work.


Were you able to resolve the issue?

My 3090 trio stopped working couple of days after resizable bar bios update.

I have bought EZP2019+ and will try flashing the stock bios image that I had saved when I got the gpu.

Also, I read somewhere that CH341A uses 3.3v & 5v and the bios chip that MSI is using are 1.8v therefore an adapter is required to lower the voltage and to flash properly.

Edit: I was successful in reading and writing the bios chip with EZP2019+ and 1.8v adapter.

Edit 2: I sent the gpu for RMA and their diagnostic is that its completely dead so I will be getting a replacement in next couple of weeks, hopefully.