Help recovering asus k75vm bios

I recently tried to update the bios on an Asus k75vm from version 208 to version 234, using the bios itself (ez flash), I got “verify error!! ROM Update not Success” while it was flashing.
After a reboot, I just got black screen and nothing else.

I tried to remove the cmos battery but I wasn’t lucky and I still got the black screen at boot.

I dumped the bios content with flashrom using a raspberry pi + 8pin soic clip (I setup that I already used to install coreboot on a thinkpad t430, without any hassle) and I wanted to flash the stock bios from asus website. Here the problem begins.

The file downloaded from asus website have a size of 4327424
The bios dump have a size of 8388608
I can’t just flash the file downloaded from the site on the bios chip, because of the size difference.

I tried to:
- add 4061184 of zeroes and append the bios rom: Can’t flash the file, I got errors during flash process
- appending 4061184 from the bios file to the bios file itself: flashing process is ok, but the computer doesn’t boot
- adding 4061184 from the bios file and appending the entire bios file at the end of those 4061184 bit: flashing process is ok, but the computer doesn’t boot

What am I doing wrong? Is there anything to do to make the bios downloaded working?

Asus bios update files r not complete images, u need a donor full dump.

Hello MeatWar, thanks for your reply.

Can’t I use the dump I’ve take from the bios chip and combine it someway with the bios downloaded?
Or just check and recover the dump I’ve take?

Thanks again!

Ull have to post a request for that operation…if possible, with a possible corrupted dump that maybe unusable.

gotcha… what if I got a donor? will I be able to extract and edit the bios details with uefitool / mmtool?

Yes UEFItool/HEX editor, MMTool is a bios module manager not the tool for ur problem.

EDIT: Off course that the original bios from ur machine has its own data.
U better post a request for the whole operation as this envolves several steps, time and knowledge.
And all the possible recovered data/dumps before/after the issue.

Are there some values to look for for finding and replacing mac / serials / hdd or setup passwords? thanks

Show original BIOS dump.

@temp_222 Still relevant?

Asus bios doesn’t contain complete firmware image, but only bios regios (see picture). In addition first 0800 are AMI capsule, and there’s some padding at the end


Your bios got bricked when updating the second last volume (dxe drivers), see comparison to stock:


"Extract as is" second last volume from stock 234 bios (since last volume is already on 234) with UEFItoolNE, open bricked bios with UEFItool025, "replace as is" second last volume with the volume you extracted from stock bios 234- you should be good to go. (You might as well just exchange all after 450000 [for a omplete firmware with FD, ME] with the corresponding part of a stock bios with a hex editor, or try the attached file) (3.57 MB)

Hello, I just registered an account to say: Thank you so much for that !!!
I had the exact same issue as op with an ASUS K75VM after attempting to upgrade the bios to the latest version ( from asus).

With this, I was able to compare all volumes from those 3 files (using UEFItoolNE “Extract as is” then beyond compare hex diff):
A) K45VMAS.234 from
B) unbricked.rom from
C) my bios rom (bricked) which I dumped using a ch341a programmer

I figured some “volumes” (sections called EfiFirmwareFileSystem2Guid under “Bios region”) were the same:

  • volume 1 (A) = volume 1 (B)
  • volume 2 (A) = volume 3 (B)
  • volume 3 (A) = volume 4 (B)

So I replaced those 3 volumes using “Extract as is” and “replace as is” from A to C using UEFItool (note: the NE version can’t edit, take an older version which is not NE) and then flashed the resulted rom.

It seems that it worked well,
Thanks again.

1 Like