[Help Request] Asrock P67 Extreme4 Gen3 2.20 bios

I’ve been doing some research on my old motherboard because it’s not responding well to my windows 10 install. I’m seeing that I needed a bios update, but my problem is that Asrock’s official website only has an update through windows that isn’t working with windows 10.

On their website they don’t offer a flash bios update. I’m told there’s ways to extract the bios from that exe file. Looking for help on how exactly to do that.

@mayor : Welcome to the Win-RAID Forum!
Unfortunately none of the related tools (incl. the “Universal Extractor”) is able to extract the “pure” BIOS file from the Windows Installer *.EXE file.
According to my own experiences with ASRock BIOSes I recommend to contact the ASRock Support. >Here< is the related form.
Good luck!
Dieter (alias Fernando)

Awesome I just submitted the request. Thank you for the help.

Here is extracted bios file for P67 Extreme4 Gen3 with version 2.20.

I need a ROM for 2.10 or 2.20 that I can use with the UEFI Instant Flash utility with this ASRock Extreme4 Gen3 board. The link above is broken, and so is every link on Google that I can find for such.

Unfortunately ASRock’s BIOS update Windows executable at ASRock’s website does not work for me even in Windows 7, or 10 as I get "Error: Firmware does not have flash (AFUWINGUI) support." I try to run it while booted from FreeDOS, SafeMode, or Repair Disk Command Line, and get that it either requires a Win32 environment, driver not installed, or ""The subsystem needed to support the image type is not present," respectively. Furthermore, putting the Windows executable and sys files in the root of a drive, and loading UEFI Instant Flash simply return "No image file detected."

I’m running BIOS p1.10 but need 2.10 or 2.20 to upgrade beyond Windows 10 1909 without getting kmode exception not found errors blue screen loop forcing me to down grade from any 2xHx version of Windows 10 back to 1909.

My understanding is that 2xHx versions of Windows run into some sort of memory collision on some driver load post-upgrade to any 2xHx version due to bad coding for memory on the ASRock 1.10 and below versions of the BIOS. 2.10 or 2.20 is supposed to fix this.

What’s worse is that I can not find any working ROM links for 2.10 or 2.20 anywhere that are active. I tried extracting the 2.20 ROM but I must be doing it wrong since I put the extracted rom and rename it to P67E4G32.20 and move it to the root of my C drive, go into UEFI instant flash and it says no image file found (it’s not possible to boot from a USB with this board as it only recognizes SATA sources for boot drives - one of the reasons I’ve had an uneasy relationship with this board since I bought it in 2011). I’ve tried clearing CMOS, booting to a FreeDOS drive and running the ASRock Windows zip extracted P67E4G32.20.EXE with it only coming back saying it requires a Win32 environment. So…I think I need a working ROM for 2.10 or 2.20 that can work with the UEFI Instant Flash Utility rather than the Windows executable, if anyone still has it.

I should also mention that ASRock Support says the board is no longer supported, and that they no longer have the older versions of the BIOS nor any BIOS versions that are instant flash anymore for this drive because of it. They did suggest I do all the steps above, but it has been to no avail. There really needs to be a 2.10 or 2.20 instant flash rom available for the p67 Extreme4 Gen3 for those who still have the board who need to upgrade to Windows 20H2 21H1 21H2, and beyond. There was one that existed for 2.10 on ASRock’s european server, but that link has been inactive since 2018 per the wayback machine.

Here u go, the 2.10 and the 2.20 fro the P67 Extreme4 Gen3

Didn’t found the 2.20…how???


Unzip Asrock file P67 Extreme4 Gen3(2.20)WIN.zip, open P67E4G32.20.exe with AMI_UCP_Extract.exe (https://github.com/platomav/BIOSUtilities)

@MeatWar thank you, but I just now got this. Do you have the 2.10 and/or 2.20 ROM files again? Link to zippyshare obviously expired. Feel free to email me inigmatus at gm.ail.