[HELP/REQUEST] Dell Optiplex 980 - Intel RST Option Rom upgrade?

Hey guys, new to the forum found it through some random googling and have been crawling it for a few hours now trying to find a solution here.

I’ve got a dell system I want to install some large drives into and use the built-in Intel Raid drivers to create a raid volume. Only problem is it only sees the drives as being 1.2TB, narrowing that down to the version of the Intel Rapid Storage Option rom ( I had decided I wanted to update that and introduce a new option rom…

I found the appropriate thread on here containing the necessary new option rom, I ran into Phoenix Tool and was able to extract the original option rom using it… but it doesn’t appear to have any capability of introducing a new one. So I’m wondering if I’m missing some magic here? Is dell just not touched very often? The latest bios for the OptiPlex 980 are here: https://downloads.dell.com/FOLDER04843385M/1/O980-A18.EXE

Beyond that I had looked into the HDR file which was produced by the Phoenix Tool but I haven’t been successful in fully determining if it would just be possible to copy and paste the new rom in place of the old one via hex editing (size difference, checksum, etc.)

Any help on this would be greatly appreciated. I’m honestly surprised there’s not more dell related stuff more readily available.

So I managed to figure out how to use the latest version of phoenix tools to accomplish this, and was able to generate an HDR file with the new option ROM inside of it. Now I’m just trying to figure out how to flash the generated HDR file to my system. Once I figure that out if this works I’ll actually write a guide on here on how I accomplished it for others searching; there doesn’t seem to be a lot of information out there on how to do this with PhoenixTool where no other tools have supported my specific bios.

Not to continue posting on my thread but I think this deserves a bump… after a night without sleep and a bunch of research/trial and error/screwing around and installing/downloading several LiveCDs full of crap I’ve managed to re-flash the bios and… IT WORKS!

I’m on Option ROM now on my Optiplex 980, and I think the way I did this would work for people with similar Dell systems as well, I’ll post a guide on this shortly. I’m thinking of trying to upgrade further to one of the RST(e) ROMS but don’t know much about this or how compatible it would be with what’s on board here…

I’m still getting the ROM seeing my drives as 7.2tb instead of 8tb now, which is better than the 1.2TB it was seeing before.

@permanull - Great you solved this yourself, and thanks from everyone else using Dell for posting your guide (here for anyone reading later)

8 “TB” disk is correct at 7.276 tebibytes or TiB, or maybe you should be getting 7.452, maybe you are seeing 7.2 due to something taking up some space on the drive (hidden GPT partition, or other partition from windows instalation etc)

@permanull - Thank you for the many insights that I obtained from your ever so helpful guide. Very much like you, I have 6 Tb (WD red) drives that are showing up as having only a 1.2 Tb capacity on my Dell Optiplex 980. With your guidance I was able to successfully flash the Option ROM to version Nevertheless, even though my Option ROM has been updated, my 6 Tb drives still show up as having only a 1.2 Tb capacity on my Optiplex 980 (even with RAID turned on). I wonder if there is some minor point that I might have missed to keep me from getting the same results as did you.

I note that I opted to use the smbios utility from Ubuntu 14.04 actually loaded on a hard drive (rather than from a live CD) which allowed me to flash the generated HDR file to my system without providing an alternate "source.list" (or having to jump through any hoops to access the generated HDR file). I also added the --no-reboot option to the command " dellBiosUpdate --override-version-check -u -f ./myfile.hdr " so that I could be sure that I waited the extra seconds before rebooting as you suggested in your guide.

Hey @wynn_somme the only thing I can recommend is ensuring the option rom actually got updated to (Does it show the appropriate version on the screen)

It’s been quite some time since I’ve last touched this; I’ll try to help however I can but as you could see with my stuff on the rapid storage screen the correct sizes were reported after I had my Rapid Storage option ROM upgraded to the specified version and I don’t know what other reason would make this not work. I’d also make sure you were upgrading to the same BIOS version I was at the time to be safe.

@permanull Thank you for such a prompt response!

Yes, the appropriate Rapid Storage Option ROM version ( is displayed on the screen. I note that since I was flashing an Optiplex 980 as were you, I was conveniently able to make use of the links and the suggestions that you provided for this same Dell model. In that I followed a path nearly identical to yours, I am perplexed as to why I would not be getting the same result that you did.

One oddity that I did notice however is that after I updated the Rapid Storage driver (for Windows 7) to the same version (11.xxx) that you suggested, an error prevented the driver from actually loading. However, I was then able to update the Rapid Storage drivers to version 14.xxx without any problem.