[Help Request] unlocking Clevo N650DU bios

Hi. I am asking for help in unlocking bios for Clevo N650DU.
I did undervolting in throttlestop (CPU core, CPU cache), bump CPU core IccMax from 60 to 65A. I removed ihs to replace thermal paste.
Everything is ok now, CPU temp is ok and clocks are fine under load.
I want to do undervolt in BIOS. In AMIBCP software I saw lot of extra settings to unlock. i’m asking for help because i have got no experience in bios unlocking. I’m interested in unlocking any useful functions, not only connected to the CPU.

https://mega.nz/#F!PzIj1YqY!5DykKpnfdGMGHU6FkfkFMw — bios photos
https://mega.nz/#F!evAHHQ7T!ZMB8G8wPI7XGL3TnNSJ08Q — bios from reseller (to update bios i was using “bios clevo N650DU_B10606\SKL2KBL” directory)

thanks in advance for help

@fat_bastard - Please upload the BIOS package to another file host, I’m unable to download that from there unless I’m a member or install their desktop app (For some reason?)



@fat_bastard - I only need the BIOS package, I was able to download the image package. And sorry I cannot download from above site either, and I thought he went to jail (Kim Dot Com?), too many viruses and pop-ups stop it from happening
Try there instead, thanks - http://tinyupload.com/

http://s000.tinyupload.com/?file_id=43265676183525733295 bios photos rar

http://s000.tinyupload.com/?file_id=33208616367743648732 bios

those links from mega.nz are fine. i’ve checked them on different linux machine (firefox), and android phone (firefox), without any mega.nz account or app. Mr. kim is a shady person :slight_smile:

@fat_bastard - Thanks! Yes, I usually have no issue with mega.nz, for some reason that file fails for me (tried 3-4 times, on separate browsers too). Tried again tonight too, I think it’s due to how it shows up as “ephemeral session” maybe, instead of a normal download like most other mega.nz downloads I’ve ever seen before.
Finally got it tonight from the original mega.nz link, after a few tries!

Will work on unlock and have BIOS for you soon, sorry for the delays!

I assume? That’s SkyLake2KabyLake, KabyLake2KabyLake, KabyLake2SkyLake. If you’ve already flashed once SKL2KBL, then all you need to use after that is KBL2KBL same/same
So this is the BIOS you should be using now, but as you mentioned you can keep using the other it will just keep reflashing ME and other related stuff for no reason.

* Edit - Add mod bios and replace FLASHME.NSH in your flash sequence/folder, or rename the mod file I included to stock name and do not use the FLASHME.NSH I sent (I edited this for the mod BIOS name I used)

Should be all unlocked now, if not please send images of pages where you see something missing you wanted.

Thank You Very Much.

looks good. tonight i will start playing with settings.

@fat_bastard - you’re welcome, so success and all is unlocked now? Hope so, thanks for quick report back!

lot of useful functions are now enabled. thank you for that. i can’t undervolt because overclocking feature is missing in bios. i should read more careful in AMIBCP. it is kind of a office laptop with small VRM cooling.

@fat_bastard - Thanks for confirmation. You could try >> Advanced >> CPU Config >> Voltage Optimization Set Enable = Mobile - Maybe that will help lower voltages some?
Otherwise you may need to adjust other functions to try and reach your goal via other means instead of less voltage
Maybe Advanced >> Power and Performance >> CPU VR >> Core/IA VR Settings >> Set >> VR Voltage Limit (This is in millivolts) Setting at top of this page may need enabled first -VR Config Enable