[Help Request] Wrong BIOS flashed into Gigabyte Aorus X7 DT V7

So I used their app to update my BIOS. The BIOS update installed by the application doesn’t match my SKU. My SKU was previously identified as X7Y7 in the BIOS. The updater installed a BIOS update that was supposed to be installed on X7X7 SKU. Fortunately the laptop boots and and runs fine except for one thing. The two SKUs only differ in Graphics card and as such gtx 1080 on X7Y7 and gtx 1070 on X7X7 (at least that’s as much as I know) and therefore the SUBSYS_ID on my gtx 1080 is changed to that of a 1070. Now I found a workaround to install graphics drivers using NVcleaninstall from Techpowerup but it’s still an inconvenience. I also tried installing the correct BIOS update by downloading it from Gigabyte’s website but since the current BIOS defines the laptop as X7X7 SKU the moment I try to install the correct X7Y7 BIOS the installer says the device is not supported. If there’s a way to mod the BIOS installer (smartflash) so that it it doesn’t verify the board before flashing or any other method to get it back to it’s previous state please let me know and thanks in advance for your support.

EDIT by Fenando: Thread title shortened (was too long)

@heni Hi. I have seen a similar story about Aero 15 XC in the Gigabyte/Aorus section on notebookreview forums. I do not recommend using the solution posted there as it could wipe out your board specifics like SN, UUID, windows key, etc.
My questions to you are these:
1 - is your current version of EC still the same as it was before the flash ?
2 - what is the BIOS chip on the laptop motherboard (should be something like Macronix MX25L128 or Winbond W25Q256) ?
3 - (as a failsafe) do you have a programmer ?

@nickobar Thanks for the reply.
1 - EC Version is changed from 3.0 to 4.0.
2 - No idea honestly, I tried looking around for it on ebay if there’s part numbers or any details about it are listed but no dice.
3 - Currently no, I could ask it from friends in repair shop tho.

@Lost_N_BIOS Any clue why this is happening and ways to revert this change?