[HELP] Samsung NP550P5C bricked

So I was trying to unlock the bios but Afuwin was giving me this error: “1e secure flash function is not supported on this file” when trying to flash modified bios (I was modifying my own rom file, dumped using afuwin. All I did was change main menu positions from default to user in amibcp). I’ve read somewhere that to get rid of this error you can try flashing with recovery box selected in afuwin. There was no error this time and afuwin asked to reboot the pc. Once it rebooted I was greeted with a black screen. I’ve waited like half an hour, nothing appeared. I figured that even if it was meant to be like this, half an hour is for sure enough to flash the bios so it must have completed it. I pressed the power button but nothing happened. Holding it didn’t turn off the laptop either. I removed the battery and unplugged the power cable. As you might expect, turning on the laptop now results in a black screen with only power leds turning on. I tried shorting “bios crisis” on mobo but no luck. I’ve already ordered ch341a to flash the chip. The only issue I have is that the afuwin dump is 3MB only. I guess it’s not the full thing. I also found a full, 8MB dump but im not sure how to extract personal data (serial numbers etc.) from my dump and inject them into the full dump. Could you please point me in the right direction? Thank you guys.

When you get your CH341 programmer try to dump your bricked bios to get a valid complete backup before writing anything into the spi!!

If you have got a 3 MB file via afuwin- that’s the bios region, complete firmware should be 8 MB, including FD, ME, possibly GbE region. If that’s a valid backup of your bios and you didn’t destroy the other firmware regions (I don’t know what selecting a ‘recovery box’ does for this program), then you could combine your backed up bios region with the other regions from your dump (or maybe another dump if no GbE).

Thanks for the tip! Can I combine my backed up bios region with the CH341 dump in UEFITool? Or does that involve HEX editing? Also, about that recovery option in afuwin, it’s just an option you can tick to override the secure flash policy. But instead it bricked the whole thing :frowning:

edit: It seems I might get the black version of CH341, which is known for delivering 5V instead of 3.3V on data pins. Is it necessary to mod the voltage or can I just go with the 5V?

Do you assume or do you know that the recovery option just takes away this secure flash policy? It might expect another kind of image to flash, for example? (Most Samsung bios from this time I know did contain a recovery firmware that was different in structure?)

Use UEFItoolNE for structure, UEFITool for a bios region "exchange as is".

Can you post your backup and the 8MB image you found? What is the 3 letter Samsung bios code?

I’ve read about this recovery option from an official AMI user guide. It’s for APTIO V but I assume its function is the same in APTIO 4 (I used afuwin for aptio 4 ofc). I’m attaching the pdf, you can ctrl+f /recovery.

In the dump.zip file - full_dump.rom is the 8MB dump I found on the Internet that is confirmed to work with my revision of the mobo, afuwin_backup.rom - my bios region backup

I’m not sure what you mean by “3 letter Samsung bios code”. Could you please clarify?

I think the programmer won’t arrive until Tuesday so if you have any idea on what I can try in the meatime, I will gladly test out different options. The current status is the laptop turns on, screen does not, power/charging leds light up. CPU fan never spins and it all just stays like that forever. I tried jumping the RTC pins and bios crisis pins but it doesn’t seem to do anything. Also tried powering on with a FAT32 formatted pendrive with AMIBOOT.ROM (my bios region dump) while holding ctrl+home - no reaction either.

edit: I’m looking for similar cases and I found one. Basically my story, just a slightly newer Samsung laptop. I’m not sure if I can link other forums here so I will just copy/paste:

Reading that, it seems I can save it without the programmer. I just don’t know how to get the .cap bios as the official samsung update tool is just an .exe downloader which doesn’t allow me to download the bios from a different PC.

ami_aptio_5.x_afu_user_guide.pdf (693 KB)

Those Samsung bioses had ths time(?) a 2 or 3 letter code for the different models, my np30035a hm65 was “QA”, a NP300E5C HM75 was RAP, a QM77 notebook had AAY…

Your own backup has ABI, your full dump found somewhere has AAA, so I wouldn’t use it… Might be that also ME configuration is a little different, and GbE anyway has an invalid Mac Adress. So I’d recommend backing up your old firmware and use it if it’s OK!

(Open the files in HxD or UEFIToolNE, search for .rom to find bios type)

Your own bios region seems to be fine, personal data in padding before last EFI volume and in SMBiosFlashData in last EFI volume, and it’s identical to stock despite of NVRAM.

I don’t know anything about Samsung recovery procedures, since both are AMI same procedure might work. BUt there’s always a chance to destroy what’s was left and could be used, too…

[EDIT: Didn’t see your edit, one line of text and cap added]

P09ABI.zip (2.23 MB)

Thank you for the cap. Sadly, following the procedure I posted above didn’t work. No reaction again, no matter if tried with a cap or rom file. The only thing left at this point is to wait for the programmer to arrive. Thank you lfb6 for your help. I will post an update once I get the programmer.

OK, then it’s the programmer. Be careful, putting the SOIC clip on the chip is tricky, bad contact and bad reads are quite normal in the beginning. In addition you’ll possibly have to take the motherboard out- all Samsung boards I worked with had the bios chip on the ‘hidden’ side of the board.

You can post your dump of the bricked bios for a check before flashing a new bios.

I got the programmer, but no matter how I plug the clip, the programmer turns off whenever the clip makes contact with the chip’s 1-4 pins side. Even when I connect just this half of the clip only, the power led on the programmer turns off and I can hear the usb disconnection sound in Windows. I tried for more than an hour and there is just no way to connect the clip. When I can visually see that the pins align well with clip, it just turns off. I think I will just give up trying to fix it as I don’t have the necessary tools to desolder the chip.

What kind of chip is it? And post a close sharp picture of the chip.

Check the picture in this post (in the spoiler): [GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher (With Pictures!) (3)

The chip is winbond 25Q64CV. I will try again but I think the soldering quality is not good enough for the clip to attach properly.

edit: better photo https://imgur.com/a/KTunKXA

edit2: I’m sorry, I had my sister’s wedding last night and I haven’t slept much haha. I missed the part about your post. I will check that out.

edit3: got it first try after pulling out the 3rd pin from the clamp, replaced the bios region with afuwin dump - all working!!!

Thank you so much, lfb6!

edit4: Now I’m wondering if there is any way to actually override this “secure flash policy” so that I could mod the bios and flash it with afuwin or any other tool, without using the programmer whenever I want to make changes. Is that possible?

edit5: Supposedly /GAN option in afuwin should do the trick. I will test it out tomorrow.