[HELP] [SOLVED] Asrock h110m-itx corrupted bios

Hello everyone

When trying to update my M/B Asrock h110m-itx, the instant flash tool crashed. After about 80% the screen went black and the pc never turned on again. After waiting for more than an hour, I turned off the pc. I have had this happen to me with a sus board some time ago, but I fixed it using CH341A programmer and FD44 Editor. I have a dump of the corrupted bios, but no idea how to find the UUID. I flashed bios from Asrock’s website to a blank chip(W25Q128BV) I had laying around., it is a bit different from the one that came with my motherboard (W25Q64BV). The original chip still has the corrupted bios on it. The dump was 8MB, so I cant upload it here.

The cpu currently is G4400, but I was trying to use i5 7400. This was the reason for updating the bios. The old bios was 1.6, and the new was 7.2.

Any help or advice will be muck appreciated.

Flashed bios version on a new chip, everthing works now. For some reason vesion 7.2 does not work with my pentium and ram. Both the ram and the cpu work in other systems. I have now clue what causes the problem. But with version 7 any combination of ram and cpu works fine.