HELP support all haswell desktop CPU on 400G1DM

The HP 400G1DM is an nice machine,but it prompted "unsupported CPU installed" on screen when I use some CPU such as I3 4330 or I5 4690T.But it ran normally when I hit F1.



I think it must be lack of MicroCode at the first time,but the problem still existed when I added the MC of 306c1 and 306c2.

So I think it should be that HP restricted the CPU model on the machine.
And I found the useful post ON,but I can hardly login the forum.…nstalled?page=1

@DeathBringer @Lost_N_BIOS
Could you help me to solve the problem?Thanks

I had searched the text “unsupported CPU installed” on UEFITOOL,and found it existed in the GUID 2CE70F66-AC57-4346-A91F-89281A07FAD6.
And it is that right to extract the body of the GUID and throw it to the IDA and analyse it ?
But I have no experience on the IDA.

The full bios from machine I had dumped.

@gloobox - Sorry, the thread you linked seems unrelated, it’s AMD thread? And, you don’t have to login to view that thread, so not sure what you mean about login there?
Deathbringer will be able to help you for sure, especially since CPU runs OK after pressing F1 to continue

Yes, I can bypass the error in assembly if you want to try that? Do you want me to do?
* Edit - Did you fix FIT when you added microcodes?

I mean I can see the post on,but I can hardly login the forum to deliver the request post.My country network is terrible.

Yes,I can’t fix it when I just added microcodes.
And I wonder if you could show a simple tutorial how to bypass the error?
IDA is an necessary tool?

@gloobox - Did you fix FIT table after you added microcodes? If not, that may be why, without that fixed the microcode may not load properly.
If you did not, send me your microcode mod BIOS and I will fix for you so you can test. Or, if you want, I can mod and add 306F1/306F2?

Yes, IDA and hex would be used to bypass the error, but I was just coming to tell you the text and PE32 are separate in that module, and there is no text indicating where “unsupported CPU installed” is called in the PE32, so I can’t bypass it for you
The only thing I can see in PE32 related with text is “ErrCodeInfo” which can by bypassed, it’s in sub_1800005F0, bypass by editing this >> jz short loc_18000066F (74 2A in hex) >> Change to >> jmp short loc_18000066F (EB 2A in hex)
But, I am unsure if that will bypass this issue, or if the actual test/error invoke happens in another routine

You do not have to use IDA, you can use any free assembly tool, or online assembly tool etc. The actual edit is done in hex editor, but some assembly tools you can apply directly if you want too.

Yes ,I hadn’t fit FIT yet.
But the I3 and I5 CPU I used aren’t the ES version,so only 306C3 is enough to support them?

Actually the bios had not enough rooms to add 306C2 and 306C1 at the same time by UBU.I mod 2 bioses,one is 306C3+306C1,the other is 306C3+306C2,but it’s all fail to bypass the error.

The microcode below had been composed by me.

And you could see #40 in the post,I think it a way to solve it.…nstalled?page=4

Make a photo of the motherboard near a socket.

FIT should be fixed after microcode add (correct offsets and entry count) BUT… Yes, Both CPU’s you mention are 306C3, not 306C2/306C1 at all. So, microcode for those CPU’s already there by default, no microcode edit needed here, you need some other changes, not microcode.
Yes, that could help, page #40 info, but I don’t know enough assembly for it to be helpful to me. Deathbringer would need to help you with edit like that, and then he would not need that info, and edits would be different here etc.
He will have to help you with this, microcode edit is not needed, some other changes need to be made in the BIOS to remove the allowed or blocked list, or to bypass the error as we’ve been discussing. He will help you probably once he’s here and sees you tagged him





This motherboard have two phases only. So low powered CPUs are recommended only,

As you could see below is mobo of 800g1dm,they has 2 phases too but the didn’t prompt the error I mentioned when using the I3 4330(54W) or even the 4980HQ(47W) modded with LGA.



Actually I hope the use the 4690T(45W) but it still prompt the error,so could you help me to bypass it?

Using 4590T(35W) is OK for the machine.

Have you solved the FPT problem with Error 28?

400G1DM has no FPRR,so we can flash it smoothly.And I had succeeded to flash many times

On 800G1DM,I hadn’t test because the machine was my friends and he was out on vacation.After a few days I will give you feedback.

By the way,I had just test on HP Z620 with your method.
Awesome!Error 28 was gone!!!but Error 7 came.I had tried to flash the bios region without FPRR region,and tried to only flash the modded region,the same error 7 came.
So I am afraid that 800G1 would had the same error7.But I will feedback you soon.





OK, try to flash my mod -…CzbufAOnMtIgp7/

Many thanks!
Could I just flash the Bios region or the full Bios?
I can see the GBE region of bios you modded was different from mine.

@gloobox - swap GbE first, as you suspected If you flash the entire BIOS

I’ve modified official BIOS.

@DeathBringer @Lost_N_BIOS
I had tried your modded bios on the machine and F1 was gone!everything went well!
On 800G1, I think it maybe different from SPI programmer flashing with a same modded bios.I spent hours on clearing CMOS,replacing battery and SSD,flashing several times again and again to get the new modded feature.But I just need to flash once on SPI programmer and new modded feature was shown.Certainly my modded bios may be modded not so well.

@gloobox - Yes, everything always 100% easier with programmer
Thanks DeathBringer!

Nice news!