Help to fix my ASUS G20CB Coffee Lake Mod BIOS wireless issue

Hello everyone, I have ASUS G20CB Mod BIOS support Coffee Lake, I made it by G20CI official BIOS because G20CB don’t support Kaby Lake.
Wireless is not working properly in this MOD BIOS, it can only work after system sleep, normal boot or restart can’t find wireless in PCIE.
Here are some data maybe useful:


Log Name: System
Source: BTHUSB
Date: 7/28/2018 8:39:12 PM
Event ID: 34
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
The local adapter does not support an important Low Energy controller state to support peripheral mode. The minimum required supported state mask is 0x491f7fffff, got 0x1fffffff. Low Energy peripheral role functionality will not be available.
Event Xml:
<Event xmlns=“”>
<Provider Name=“BTHUSB” />
<EventID Qualifiers=“32773”>34</EventID>
<TimeCreated SystemTime=“2018-07-28T12:39:12.162245900Z” />
<Security />

Log Name: System
Source: Microsoft-Windows-WHEA-Logger
Date: 7/28/2018 8:39:15 PM
Event ID: 17
Task Category: None
Level: Warning
A corrected hardware error has occurred.

Component: PCI Express Root Port
Error Source: Advanced Error Reporting (PCI Express)

Bus:Device:Function: 0x0:0x1C:0x6
Vendor ID:Device ID: 0x8086:0xA116
Class Code: 0x30400

The details view of this entry contains further information.
Event Xml:
<Event xmlns=“”>
<Provider Name=“Microsoft-Windows-WHEA-Logger” Guid="{C26C4F3C-3F66-4E99-8F8A-39405CFED220}" />
<TimeCreated SystemTime=“2018-07-28T12:39:15.018356100Z” />
<Correlation ActivityID="{DB7B848C-58EE-40DF-8F94-1D4BAF84CE68}" />
<Execution ProcessID=“2168” ThreadID=“3284” />
<Security UserID=“S-1-5-19” />
<Data Name=“ErrorSource”>4</Data>
<Data Name=“FRUId”>{00000000-0000-0000-0000-000000000000}</Data>
<Data Name=“FRUText”>
<Data Name=“ValidBits”>0xdf</Data>
<Data Name=“PortType”>4</Data>
<Data Name=“Version”>0x101</Data>
<Data Name=“Command”>0x10</Data>
<Data Name=“Status”>0x407</Data>
<Data Name=“Bus”>0x0</Data>
<Data Name=“Device”>0x1c</Data>
<Data Name=“Function”>0x6</Data>
<Data Name=“Segment”>0x0</Data>
<Data Name=“SecondaryBus”>0x0</Data>
<Data Name=“Slot”>0x0</Data>
<Data Name=“VendorID”>0x8086</Data>
<Data Name=“DeviceID”>0xa116</Data>
<Data Name=“ClassCode”>0x30400</Data>
<Data Name=“DeviceSerialNumber”>0x0</Data>
<Data Name=“BridgeControl”>0x0</Data>
<Data Name=“BridgeStatus”>0x0</Data>
<Data Name=“UncorrectableErrorStatus”>0x0</Data>
<Data Name=“CorrectableErrorStatus”>0x1</Data>
<Data Name=“HeaderLog”>00000000000000000000000000000000</Data>
<Data Name=“Length”>672</Data>
<Data Name=“RawData”>435045521002FFFFFFFF02000200000002000000A00200000E270C001C0712140000000000000000000000000000000000000000000000000000000000000000BDC407CF89B7184EB3C41F732CB571311FC093CF161AFC4DB8BC9C4DAF67C104C0C221FB6F26D40100000000000000000000000000000000000000000000000010010000D0000000000300000100000054E995D9C1BB0F43AD91B44DCB3C6F3500000000000000000000000000000000020000000000000000000000000000000000000000000000E0010000C00000000003000000000000ADCC7698B447DB4BB65E16F193C4F3DB00000000000000000000000000000000030000000000000000000000000000000000000000000000DF0000000000000004000000010100001000070400000000868016A1000403061C00000000000000000000000000000000000000108042010180000007001100134072074000117000B2540000004001080000000000000037080000000400000000000000000000000000000000000001000114000000000000000011000600010000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000043010000000000000002000000000000EA06090000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000</Data>

There is no wireless issue in Mod BIOS by ASUS H170i-pro but have voltage issue, i tried to use the same way to build BIOS in INTEL FIT (change all the settings like G20CB), i also tried to change PCH Configuration in the BIOS Advanced setting the same as G20CB but didn’t work.
I don’t know what can I do now and i hope you can help me to fix it, thank you!
MOD BIOS Download Link!AovXQPtIn_DyavQjRKIg9-oJv4Y
G20CB Official BIOS Download Link…

Is anybody free to help me?:sob:

Saw your useful information (especially Bis/Device/Function) and got an idea.

When opening your BIOS with BCP there is an PCI Irq Table. Check if there is a proper entry for that 0/28(0x1c)/6

I will check it tomorrow.

Reactive is the only one making any progress on this mod, sorry Zax007.
I tried to help him early on but wasn’t of much use. But, he’s made lots of progress since then, and I saw you on his thread too already and assumed you’d been following along.

That thread is the only place any progress has been made

Hello averyone! can i download this bios? link not works.

Zax007 can u reload may be u have new info about that bios.

I have a 2 asus g20cb and g20ci i can test.

seems like some irq problem, did you changed the sku? try no sku change.

See this thread guys, working links to working BIOS mods towards end of thread (Not last page, just skim through from end backwards or read all pages starting around the middle)
Patching ASUS G20CB Bios to support 7th gen I7