Help to unlock advanced menu - Pegatron IPPCV-SS-L

I am looking for ways to unlock the advanced menu of the Pegatron IPPCV-SS-L board. I used AMIBCP v4.53 and v4.55 changing the options for USER however when recording the new file on the chip using a bios programmer the motherboard does not present video and the led power is off with the fan on. After write the original dump the computer power on normally. I did not understand how to change the body.bin binaries but by analyzing the setup_extr.txt the menus remain locked even though making changes with AMIBCP. Attached is the BIOS dump, can anyone help me with modifying this file? (1.21 MB)

any to help ?

@maiconjs - sounds like bad mod BIOS, please attach your mod BIOS too I will check and see if I can find the issue.
For full BIOS unlock, I need to see all your BIOS pages and all currently visible settings (including Main and exit too).
Please make these small images, JPG or PNG, 800-1000kb max, 800-1000px wide is all they need to be. And please put in zip or 7zip archive

Setup IFR is not changed by AMIBCP, AMIBCP only changes settings stored at AMITSE/SetupData.
Both of those things these hold separate copies of same settings, some boards use setup and some use what AMIBCP changes, and some use combo of both of those + NVRAM held settings.

Many thanks for the reply. Follows the requested images in the .zip file

BIOS (1.56 MB)

@maiconjs - Thanks, I will look into this tonight for you. Please also give me your BIOS mod, so I can check it for you to see if maybe I can see the issue, so I don’t make same issue happen in case it’s something AMIBCP is causing.

The only change made was to just open the file in AMIBCP 4.53 and change the Access / Use to USER. (1.21 MB)

@maiconjs - Yes, I understood your mod process, I wanted to compare the outcome BIOS Image vs stock for a few key things that can cause bricks, maybe find the reason it’s breaking with a quick look. It could just be that you need to use AMIBCP 4.55 instead, I never use 4.53 anymore.
You may need to set Supervisor instead of User, something you need to test and confirm since Access Level is not shown on your BIOS Main page.

After having now looked at your mod BIOS, right away I see issue as soon as I open in AMIBCP, you can’t set everything to user, even if that is the access level you should use.
You should only change access level for settings you can’t see, in an already visible menu section. Such as “System Language” option within Main, or “Password Check” or “User Access Level” in Security, those are not visible, so you could try setting it’s access level (alone) to User or Supervisor
For missing main menu sections, you may or may not need to set that to User/Super later, but other edits are needed first usually (Mainly speaking Chipset here), and those need tested as-is before you make any changes unnecessarily with AMIBCP

I found the cause of the issue though, it’s not necessarily caused by the above, which shouldn’t cause a brick it’s just not proper way to unlock anything and you’ve used it on menus you can already see, the main issue is a missing padding file near end of last volume, directly below FID Module
Both 4.53 and 4.55 do this, so neither can be used on this BIOS. Any settings you’d normally make in AMIBCP must be made in either setup module itself and or AMITSE/SetupData (what AMIBCP normally changes when you make any edit)
OR, it may be possible to reinsert that padding post AMIBCP edits, testing would be needed to confirm the outcome of that kind of workaround (And I’m unable to do that successfully, after spending an hour trying to rebuild post re-insertion of this file, so this is not ideal)

Best way to do this, after we find which access level (User/Super) works for your BIOS on individual settings is to make necessary changes via AMIBCP, save broken BIOS, extract AMITSE/SetupData and replace on stock BIOS and rebuild.
That’s only for settings in already visible menus, or to make submenus visible in already visible menus, rest has to be done via Setup module edits and AMITSE edit.

I can help you unlock this, but not using AMIBCP in the normal manner. Is advanced and chipset all you need unlocked?

Here, please test these with programmer, which shows “System language” in the BIOS main page now. I am not concerned with if options for this are visible, or what those options may or may not be, only need to know which BIOS makes this setting visible to you
Please test in this order, stop when you see System Language and let me know which file it is. No need to test further once you see that, for now, other similar test may be needed later if SetOnly works and you don’t end up having to test BCPU/BCPS

I already used version 4.55 and got the same result. I have already changed only one section to USER and it also did not work. I need all the options unlocked, because I intend to build a ChromeOS on this hardware but with the current BIOS setting the system is not working. I also can not make 64 bits systems work even if the processor is 64 bits. At the moment I’m at work I’ll proceed with the suggested actions at home. Thank you very much for all the information.

@maiconjs - Yes, I know 4.55 = same, I explained that above and why it happens, good you already tested too though. No need to quote when we’re only talking to each other , editing out to save space, thanks

Please test all files in order/manner I mentioned, this is a process, I can’t simply hand you fully unlocked BIOS without knowing what all works for certain things. Don’t worry, I do this all the time, we will get there in the end!
I’ll look and see if I can find some setting limiting OS to 32bit, but I’ve never seen such a thing, I’ll see if I can find.

I write the file "SetOnly" and it shows the option "System Language"

@maiconjs - Thanks for test result #1 So, now I need to find some setting that can be a BCP only test, so we can find out if you need to use User or Supervisor, or if it matters.
After that, I can do the menu swaps and then have you send me images of all the new menus and submenus so all is visible, then I can add in the missing items via further edit.
Hmm, unfortunately for now, I cannot find any setting to use for this test, all are currently hidden from you in original menus are hidden via suppress in setup module, which you tested edit is OK in the SetOnly test.
So, if we need to do AMIBCP User/Super test it will have to wait until later after I swap menus around and you send me new images.

Please test, is chipset menu now added, if yes in which BIOS does it first appear (stop there)? Maybe this one will give us the AMIBCP User/Super answer I wanted? Unless again the first one gets it for you that would be my luck
Test in this order, stop testing once Chipset appears, let me know which it first appears in.

Again in the first file “SetMagicStrChip” and already presented the chipset option. I think we are making good progress

@maiconjs that’s what you call “my luck” in action! Ohh well, we’ll get to a BCP U/S test soon, once we get into making sure all settings in the new menus are visible to you.
Thanks for sticking with me on all these single tests, I prefer to do this way instead of doing it all at once and it fail and then have to go back and try undoing this or that one at a time trying to find the failure point.
And, I guess we can do that now probably within chipset, before moving on to rest of menus. Please take images of all pages inside chipset, put in a zip or 7zip and upload for me to compare, surely something is missing and we’ll get to do a BCP U/S test!

I am very grateful for all the help you have offered and also for your availability. I know this is not a great hardware but with your work this computer will have a great project in the future. The images are in the .zip file.

Images BIOS - (415 KB)

Thanks @maiconjs , happy to help! I hate locked up BIOS, so always happy when I can unlock for someone, companies should leave all unlock for paying customers!
There’s 2-3 settings missing from your images, so we can now figure out which AMIBCP Access Level Setting is needed, when that kind of edit is needed… Maybe
This, and the other few, are also hidden by a constraint in the setup module, so if both these fail then this cannot be our final test on this, we may never get one


Please test both BIOS, looking for the setting shown above to show up, or not. If not, then I can make visible via setup edit instead, doesn’t help our test here but that’s my luck…485662888769020

I write the two files and the computer does not start. Situation similar to what I reported at the beginning of this post the fan turns but does not give video and the power led does not light.

And in fact 64-bit operating systems run like Windows. The issue is that some systems like libreelec do not run and I suspect that any BIOS option like cfg lock is active or execute disable bit is disabled.

@maiconjs - Ahhh! Sorry, I forgot to extract SetupData and replace in BIOS, and did save with AMIBCP instead and just sent that out, sorry I forgot about this
Here, try those same BIOS again built properly! -…846032145472828

Sorry, I don’t know what your last sentence is about or in regards to? Execute Disable Bit is enabled by default (for optimal defaults), No CFG Lock in this BIOS.

I apologize for not responding so soon here. I had some big personal problems, which took me away from some projects. I no longer have the hardware above but while I did, it was a big help. Thank you very much for all the attention.

@maiconjs - Thanks for follow-up! So, the above BIOS at post #17 was OK and working, when you did have the system still? If yes, thanks, it will be helpful to confirm for future users

Yes, the latest version worked and I remember seeing some functions well. I believe that few should have this board but it is for some projects.