[HELP] Trying to Unbrick a HP Z840

Hello Forum

im trying to unbrick my HP Z840, i bought it with a dead motherboard(I dont really know whats the problem with the original Board), so i got a HP Z840 Motherboard from Ebay, everything was working, i was using windows, verified both sockets and all ram channels, this board was working allright, but i was planning on updating from Xeons E5-26xxV3 to E5-26xxV4, so i checked the HP Website and was recommended an update for the BIOS to avoid conflicts with the new CPUs, since its a change from Haswell-EP to Broadwell-EP.

Well HP recommended using the HP Assistance, i downloaded and ran the app, then it was suggested a BIOS Update in this case M60_259.bin, i proceed to install it, everything worked, the computer even rebooted like 4 times, well i just assumed the BIOS update was successful(no Errors no nothing), at the end of the day i just turned the workstation off, then at the next day, i tried to turn it on, it just didnt post, it was stuck on a black screen, no fans no HDD activity.

i inmediatly assumed the BIOS was wrong, i followed the instructions on the HP Site for this kind of issues, using the Boot Block recovery jumper and this Guide
i downloaded the same “Up to date BIOS” from HP, it was the M60_259.bin, i used the official recovery tool inside the BIOS update tool, it did not work, i contacted HP support, 3 different agents told me that the 259 version of the BIOS is know to corrupt/brick systems, but i guess they dont care because Z840 is EoL, then i tried with an older BIOS M60_258, still using the same tool from HP.

It did not work, eventually it will beep 8 times and all the fans get at 100%, so i decided to buy a Ch341a to try to recover the BIOS by hardware reprogamming it, i have the original Dump from the BIOS, then proceed to follow the multiple guides on youtube and also this forum, i can read and erase the BIOS Chip (Winbond w25q12fvsg) but when ever i try to write the working M60_258.bin BIOS it finishes Writing but fails at verifying telling me that the buffer and the chip contents does not match.

i have tried with this programs:

I can read with all of them, sometimes it ID the chip as W25q128BV instead of the W25Q128FVSQ, i can write with 3 of them but everytime it fails when verifying.

Im requesting assitance or advice, i have read that the issue its most likely the CHIP and the programmer version not working together can anyone with more experience suggest a version for this CHIP?

Thanks in advance