[HELP] (W10)->(W7) Dell Inspiron 15 7000 Gaming 7567 Install on 100 Series/C230 Chipset Kaby Lake

Greetings forum and team. I’m just around here looking for solutions.

The scenario is very simple, trying to install W7 on a Dell 7567 with 100 Series/C230 Chipset Kaby Lake. Windows 10 work just fine, but I prefer Windows 7 for many reasons after been using W10 so far.

I been searching, trying, looking and testing many things, most of this forum, without success, even Google looking videos, more info, official websites, non-official as well, and no luck.

Always I get the same error “Load Driver - A required CD/DVD drive device driver is missing”. Why I’ve done so far without results:

1- Tried the official drivers from this forum Recommended AHCI/RAID and NVMe Drivers . All Intel ACHI/RAID and OCZ (since the SSD M2 is a Toshiba).

2- Tried the official installer from Dell from this site: http://dellwindowsreinstallationguide.com/. Including OEM, UEFI and Driver Sets. And updating the Skylake iso with above drivers (all of them). Nothing.

3- Integrate drivers into a ISO Windows 7 images with Gigabyte Windows USB Tool, Win7 USB 3.0 Creator, CMD DISM (manual methods). Nothing.

4- Download many many drivers from the web, load it using “browse” option during installation. All of them end in “Driver outdated, get a new one from the provider” or “No device found”.

5- Different configs with Rufus, UEFI, non-UEFI, different Windows 7 isos (Officials, non-officials, OEM), and still nothing. Also different flash drives (discarding flash malfunctions).

The Device Manager show devices like:

VEN8086&DEV_A13A - Intel(R) Management Engine Interface
VEN8086&DEV_A114 - Intel(R) 100 Series/C230 Series Chipset Family PCI Express Root Port #5
VEN8086&DEV_A115 - Intel(R) 100 Series/C230 Series Chipset Family PCI Express Root Port #6
VEN8086&DEV_A121 - Intel(R) 100 Series/C230 Series Chipset Family PMC
VEN8086&DEV_A123 - Intel(R) 100 Series/C230 Series Chipset Family SMBus
VEN8086&DEV_A131 - Intel(R) 100 Series/C230 Series Chipset Family Thermal subsystem
VEN8086&DEV_A152 - Intel(R) 100 Series/C230 Series Chipset Family LPC Controller (HM175)
VEN8086&DEV_A160 - Intel(R) Serial IO I2C Host Controller
VEN8086&DEV_A161 - Intel(R) Serial IO I2C Host Controller
VEN8086&DEV_1901 - Intel(R) Xeon(R) E3 - 1200/1500 v5/6th Gen Intel(R) Core™ PCIe Controller (x16)
VEN8086&DEV_5910 - Intel(R) Xeon(R) E3 - 1200 v6/7th Gen Intel(R) Core™ Host Bridge/DRAM Registers - 5910

My hardware: I7 7700HQ, DDR4 24GB, TOSHIBA THNSNK128GVN8 M.2 2280 128GB, WDC WD10JPVX-75JC3T0, GTX1050Ti.

To be honest don’t know what else to do.

Many thanks for your orientation, support and help. Waiting some reply.

I have seen “A required CD/DVD drive device driver is missing” error caused not by a CD/DVD or HD driver, but by a missing USB 3.0 driver
are you trying to install windows from a usb key? if so you will need to integrate the correct usb 3.0 driver into the windows install files, or have the usb 3.0 drivers in a folder on the usb key
and use the “F6” add driver during the windows 7 install startup

note that Intel USB 3.0 drivers have at least 3 different driver versions (or more) depending on the chipset/OS being used. you can try these driver links


Older v4

some newer intel chipset motherboards bios lack the necessary support for xHCI Handoff as i recall… if you board is one of these then you have a few options
1. desktop systems buy a usb 2.0 card and boot the install usb key from it
2. laptops, buy a usb 3 addon card which will not be intel based, and again boot the win 7 usb key from it (if necessary set bios to boot from the addon card)
3. burn the win 7 setup files onto a dvd/dvd-rw disk and install from it

I’d just tried, and at least didn’t work at the first trial. Indeed I’m using an USB since the laptop it doesn’t come with a optic unit (and buying a optic unit just for this is not a plan to be honest).

But pressing F6 didn’t work. In which specific moment do I need to do the F6? (black screen, welcome message, etc…)


windows 7 should prompt you to load the driver(s) when you get the “required driver is missing” prompt simply browse where the extracted drivers are.
most drivers come in exe files, however you can run the exe with a command switch that tells it to extract the files rather than install them.
once extracted you should see a xxxxxx.inf file in the folder it placed the files in if so copy this folder to the usb key and point it to that folder

Fernando also has pre extracted inf based USB setup files for most common USB chipsets listed on this forum

last, a 3rd party USB dvd-rw can be bought on ebay for under 30.00 and as i said using this will remove the USB driver issue during install if your laptop bios does not support
windows 7 USB 3.0 functions the same can be said for a usb card for the laptop

last a quick google check on your problem shows several links confirming this issue for your model series and dell has a web page on it and a possible workaround
after reading the dell page, i personally STRONGLY RECOMMEND you skip win 7 and install win 10 as the power mgmt features are not available under win 7 this will cause your laptop to run hotter/louder/and have shorter battery life


Last is your SSD a NVME or SATA based device? if nvme windows 7 will require 3 hotfix’s slipstreamed into the windows image and several files/folders also need to be setup/added (google add nvme to windows 7 install disk for info on this) SATA based SSD’s do not require any special drivers other than what MS includes

Indeed @DeeG after been browsing A WHILE, I’m not the only one with tis issue, however, Win7 for me is much better as a OS than W10, even if this one is “new” or more advance. W7 is a mature OS, for me W10 has a lot things to fix before becoming a “production environment” option.

Where can I find that “pre extracted inf usb” I been checking the forum, but has a lot of info. And sometime they are duplicate thread with different info.

From now on, many hardware will start coming without optic drive, I could think that “sometimes” is better find the workaround, learn from it and keep moving, than just take old solutions (get an optic drive, for example)

Question regarding Intel Mnmt features, the devices manager show an entire section about Intel(R) Dynamic Platform and Thermal Framework, and in it about 6 components. Could you think that specialize tools like “Drive Booster” or “DRPU” wont find any “compatible” driver? Definitely wont be the last version (only W10 for sure), but at least one close enough to fix the missing driver and some of them suggest the “best options” which also sometimes is not the last one. Expert advice?

Right now, I’m using the default driver is SSD M2 but Sata based. Coming soon will replace it with a Samsung 960 Pro (nvme of course) and I’m aware that need to add the 2 hot-fix and a few others thing to the iso before install. Been reading a lot recently about my issue and learned a lot related to.

In my previous test I was able to edit the isos adding extra drivers and so, but always receive the error, maybe find the correct USB will fix all my issues. Cuz Alt+F10 during installation was detecting the SSD M2 so far (dir, diskpart, del, etc…)

I really appreciate all the effort. I’m aware it will take time, always has been like that with new stuff. Happens the same with my new Core2Duo laptop and Vista. It was a pain putting XP. Took 3 month until at least learned how to do it. But for the next 4~5 years with it definitely it worth the effort.

Best Regards, and still pending for some more advise.

Dell uses mostly INTEL based motherboards, as such your laptop uses intel USB hardware,

as i posted, order (if your laptop has win 7 downgrade rights) use the dell win 7 restore disk it has the necessary usb 3.0 drivers pre installed
and also has the necessary nvme drivers as i recall

go to the dell page, read/follow the section "How do I download the Recovery Image and I reimage my Skylake system with Windows 7."


or you can make your own custom restore disk using the MS win 7 sp1 iso as a starting point downloaded from here


to integrate drivers i highly recommend NTLite ( https://www.ntlite.com/ )

you might also want to read this dell link


last, and no disrespect intended… if you can not find the extracted USB drivers on this site, then i doubt you will be able to create a win 7 disk using NTLite, or any other program

USB 3.0/3.1 Drivers (original and modded)

the Intel Mgmt Features have nothing to do with your OS install they are used by IT people (like me) for remote access into the PC (even if the computer is off!)
your bios defaults should have the management engine/AMT features disabled

The Intel(R) Dynamic Platform and Thermal Framework driver for windows 7 is for pwr mgmt/CPU power modes and is not listed by dell as being compatible with your model (but should work?)

it is IMPOSSIBLE to provide help/support replies to statements like this:

In my previous test I was able to edit the isos adding extra drivers and so, but always receive the error,
(no description of the program used, HOW it was used IE-steps you took, and the EXACT error msg)

At the end, I was able to install Windows 7. And I’m so happy after all :smiley:

Indeed, looks like some USB drivers are missing in all the Isos that I tried. Then I have the idea of install the iso during boot mode (boot utility), but not the inhouse Windows procedure.

For been able to do that, I use Sergei Strelec (website here) and use the utility WinNTSetup to complet the first step (install the file into C).

At the beginning I was doing legacy installation, until after some tests and read a while over here and there, I was able to do UEFI install with the same procedure.

Now, I have Windows 7 Professional 64 bits running UEFI mode in my laptop. And of couse All drivers up to date and working.

I had to made several Win7 install through this procedure, the firsts of them was to find the exact driver (ahci, network, and so), and had to reinstall several times in a testing environment. And after official and non-official sites found all drivers, including fix to TPM2.0 in Win7.

Some picture :slight_smile:

Of course, the final result was not a straight line. Many thanks for your support, and guidance.

Best Regards.

I have the same type of laptop and I can not put windows 7 on it, can you link me to the image you use?
thank you !