Help with a HP 8460p "ME is in recovery state"

Hi there

I have an Elitebook HP 8460p laptop which run great until the last ME firmware update for May vulnerability. After that the bios complains about “ME is in recovery state”. I spoke with HP support and the only solution they gave me was to change the entire mainboard (YAY HP!). I found this forum researching and readed some threads about this issue and similar issues and I realized that the only way to recover the laptop was by dumping the complete bios (tried some times but always error 26 trying to read full bios).

MEinfo output in current state:

upload photos

(OEM tag and MEBx seems missing)

Today I received my SOIC clip and I was able to read the full bios. I did two reads and got the exact same file (same hashes). Now I don´t want to screw the laptop my cleaning myself the bios, so I wonder if its possible to help me by doing it or help me to do it. I attached my full bios dump as well as the lastest bios that hp provides (without ME section).

Thank you very much!!!

68SCF_rom2.rar (5.28 MB)

68SCF_F65_clean.rar (1.77 MB)

The (very detailed) guide for cleaning up the ME can be found here. Attached is the result of that guide based on the attached 68SCF_rom2 SPI image.

68SCF_clean.rar (4.74 MB)

Thank you very much!

Now I´m having problems programming the bios chip. When I program the flash bios attached verification process fails. But if I program the original bios that I extracted it works fine. I also created another dump following your guide and also gives verification errors.

The erase seems to be fine, I´m using a CH341a programmer and a SOIC test clip. Any ideas of what can be happening? I tried several times and if one image id flashed correctly others should be, right?

Another question, in both images Flash descriptor is locked, is there any way to left it open?

Thanks again

What verification process fails? Something HP or programmer related? HP makes some sense but not the programmer. If it can write back, it can write back.

You can leave the FD unlocked easily while cleaning up the SPI image. The settings are found at Descriptor Region > Master Access Section.

Everything is done with an external programmer (CH341a). This is very weird, I´m starting to think that the bios chip is defective in some way, but I would like to avoid soldering and desoldering.

I´m not able to program anything else other than my original dump or that dump modified to unlock FD (modified by me with fitc). The image that you kindly created for me, the one that I created or other from other previous user of the forum (also a 68SCF) gives verification problems. I pull out every component of the motherboard (CPU, cards, ram, etc…) and there is no way to flash the image without verification error (tried like 40 times). I´ll try to boot with FD unlocked form the original dump and test to flash within windows if flash descriptor is unlocked.

Thank you for your help again.


The FD does not matter when using a programmer. It could be the tool version that you’re using. Try the one(s) attached at CodeRush’s guide.

Thank you for the link. I did not know the coderush guide but I did everything as described.

I´m getting a very strange behaviour with the external programmer. I even try with a raspberry pi and flashrom software and got the exact result as with CH341a programmer. I will try to describe it.

This is the output if I flash the original bios dump:

Everything perfect, the verification process went ok.

This is the output if I flash any other rom (doesn´t matter which rom):

Verification process fails, always.

The only explanation that I can think of is a defective flash, which caused the problem at first by not flashing the ME update correctly. And for some reason the flash can only accept some values for those affected memory banks.

That is my theory. Now the only thing I can do is to try to desolder the flash chip and use a new one, but that is a risky procedure.

Thank you for your help.

That address falls into the ME region, NFTP section. I assume that you are trying to flash while the system is working. In such case, the ME is operational and probably interferes with the flashing or verification process. Do you have an unlocked FD? If yes, try flashing via Intel’s Flash Programming Tool (if I’m not mistaken, it automatically disables ME activity temporarily during flashing). If not, you can reflash only the FD with the programmer (first 0x1000, unlock it first) and then flash via FPT.

Thank you again for your help.

I´m programming the flash chip with the computer completly off, using power from the programmer only but when I connect a light is on so maybe there is some kind of ME process running, that´s why I pulled out all components of the motherboard (CPU & RAM), but same results. A very curious thing is that Erasing chip works (checked and it´s empty when you erase it).

I were able to get FD unlocked, but when I try to flash using Intel Flash Programming Tool I got an error like “unable to disable write protection” and found a similar thread here, where a SPI flasher is recommended. I´m a little bit lost in the EFI commands and that stuff. If I use AFUDOS I´ll be at the same situtation, right?

Make sure all power is removed for 1 minute (cord + battery, RTC is ok) for a fully turned off ME. But if the system is not operating and erasing works as you say, then I’m not sure if the previous tip will help at all.

Today a friend lend me a smd rework station and I was able to replace the bios chip. All the problems are solved with new chip, flashed the bios modded by you and after that I updated the ME firmware to latest version using HP’s update program.

Thank you for your help, this is the only site were actual help was provided. The only solution provided by HP was to change the mainboard, a 300$ piece that costs more than the laptop today.

Exactly, glad we could help. Enjoy your repaired system.

Hey Krasny,

Do you mind sharing your modded 8460p BIOS? Hope it do OC with XTU.

Hi there

sorry for the delay replying, I didn’t see your answer.

Modded bios by plutomaniac is in the second post of this topic and mine is in the first one. You should not need anything else.

Hope it helps.