Help with EZP2019 USB programmer and reflashing MXIC chip (from a complete newbie)

Hi, I recently tired doing a ram upgrade on my Eurocom X4c laptop that resulted in bricking the PC :’(. the same thing happened when I first got the laptop but that was due to overclocking failures… but that time it was under warranty. the laptop shows exactly the same behavior as last time (fans spin up and keyboard glows but screen remains black and power cycles) so i thought i could just do the steps that the manufacturer took the first time ( listed in their support request below) but me being stupid looked at the instructions wrong and tried to reflash the bios first as soon as I got the Programmer. the bios chip used in the laptop is an MX25L6473F from MXIC but when I connected it up initially to the programmer and tried to read the data on it, it said that it was empty… so me being so anxious i decided to write to the chip anyway with the bios provided by the support staff. every time I did this and verified the chip it just gave me errors and when I when to read again it still showed it was empty. this kept on happening even when I changed the chip parameters to match that of MX25L6445E ( which is seen as practically the same as mentioned in the data sheets).

then I saw a video that said the chip might need more power so its good to plug in the bios battery and then try, had the same result as before. mind you I also tried to re-position the clips a few times as sometimes it would say chip not detected but other times it was all good ( apart from the program always detecting it as an 24 EEPROM atmel chip ). so finally I thought maybe I should plug in everything ( laptop power, battery and bios battery) thing might finally work out… and nope I still had the same result.

when I woke up today to re-test things I re-attached the clip on the chip and now the chip is not even being detected, after doing it several times it rarely detect that the chip is connected even though I have checked the continuity of all the pins from the chip to the other end of the connector. have I somehow fried the chip ? or is the clips that I am using really that bad quality ? what else could I do to test if the chip on the board is still functioning and programmable ? I am an engineering student so I do have access to electronic equipment as some on my friends take electronics so tools should not be a problem for the most part.

I would also like to know if the chip is actually wiped or could I just try booting it with a dummy CPU as stated in the old support request. at this point any tips or suggestins will be much appreciated, also feel free to ask any questions I will try to answer them asap ,I am really grasping at straws to get my system working again :’( hoping you guys could help me out.

Attached is also a picture of the setup.

Old Support Request.png

bios chip.jpg


Hello Nyks!

Did anyone ever replied on this maybe in private message? Problem solved?