Hi Fernando, quick question on AMD raid controllers utility and the 9 series chipset

Hi Mate,
I just got a M5A97 R2.0 board a week ago. FX-6300 and Windows 10 home x64 1607+

Cannot get raid utility to install or even detect i have a raid 0 setup and offer to install possibly.
No sign of your modded driver for it currently running 15.40.43 amd ahci raid controller and console

What utility do i bloody use to manage my raids? Especially write and read caches which keep turning off during installation.
Would you still recommend your .33 driver as the best for this chipset raid
how do i get raid utility to install properly as i can manually install it, but it opens the web p[age and gives a cannot connect error. Have they rerally pulled support for this chipset from the util and still sell brand new boards?

Kind regards

@ifixit :
Hello Richie,
you should better ask the ASUS Support or experienced users of an AMD RAID system than me.
Since I never owned or used an AMD chipset RAID system myself, I cannot really answer your questions.

Well that’s sad, about as sad as Asus and gigabyte support has become. They are not what they used to be, and i had hoped you were still making modded drivers …

apparently amd’s raid utility is broken for windows 10 x64, i have tried installing it a few times and gave up.

All good though, if you don’t know, you don’t know.

@ifixit :
I am able to customize a driver’s INF file to make it compatible with older or newer hardware or with a newer OS, but I cannot modify a RAID Utility itself, because there is no textfile, which contains the easy to modify instructions about its compatibility.
The problem is, that AMD doesn’t care about RAID users.
What is the DeviceID of your AMD RAID Controller?

Hardware ID: PCI\VEN_1002&DEV_4393&SUBSYS_84DF1043&REV_40

Driver Version: 3.7.1540.43

They have all seemed to have downgraded their support to a level i hadn’t seen for a while, Quite shcoking, We used to get good support back in the day’s of NForce chipsets etc, but it’s kind of died since Intel gained so much performance over AMD etc,

Lets hope Ryzen puts this right, and competitiveness comes back, a monoploy in anything is not good IMHO.

Cheers for taking a look Deiter.

Stop Deiter, my error, you gave me the answer, i thought it was Bolton, it is Hudson and installing the Hudson version from the AMD folder worked first time.

Sorry mate, my bad.