How do I flash the GbE region of my z170 motherboard?

Hi, I have a Asus maximus 8 hero motherboard and my intel lan has code 10’d with some error at start up about the pxe rom. It’s now being detected as a i219-M when it should be a v. After some searching it seems my motherboard’s intel GbE region is corrupt because it detects no firmware in that region. How do I flash it back to fix this? I’m using Asus’ latest bios for this motherboard- 3703.

This issue is not related to Intel Engine. Try re-flashing the stock ASUS BIOS from the in-BIOS menu or from USB Flashback. If it doesn’t help, you’ll need to manually re-flash the GbE region of the SPI chip via Flash Programming Tool’s command “fptw -gbe -f gbe.bin” where gbe.bin is the extracted GbE Region from the stock ASUS SPI/BIOS image when via UEFITool. To do that, you must first make sure that you have access to the GbE region.

Unfortunately, flashback did not work. I will read the link you have posted, it’s a lot to process!

Hi, is this the same UEFITool you have referred to?
I was able to extract an 8KB GbE.bin from both spi.bin and asus’ .cap file. Does that sound alright?

I read your “Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing” thread and this is the output when I ran fpt -d spi.bin.
It seems that the GbE region is accessible and I can use the extracted GbE.bin from the asus bios file I downloaded from their website? How do I set the Mac address?

It is very likely that you have read but not write access, try flashing to verify. Everything else you said is correct. There is a parameter to save the MAC address.

I have wonderful news- it worked :slight_smile: My ethernet is working. I am typing this post whilst connected to the internet via my lan for the first time in months :smiley: Only downer is the Mac address is wrong (I don’t even know what the original was anyway) but if everything else works, I think I needn’t worry?

@kavi :
The original MAC address is usually printed on a sticker on the motherboard, possibly on the side of a connector or socket.

On my Asus board the MAC sticker is on the ATX power connector. I lately reentered the MAC with eeupdate.exe.
In this package At ASRock ‘MAC Address Writer 2.07A’ are many recent eeupdate versions.

I checked that area of my motherboard and there is a sticker on it with 12 characters, I assume that’s the mac address. There is however no label for it nor are there any separators, I assume to save space. Any way to validate these characters as my original mac address?

@kavi :
You can validate motherboard manufacturer match by one of the MAC address vendor lookup tools, for example:

Exactly. There are no seperators on the sticker text. It starts with B06E…

30:5A:3A AsustekC ASUSTek COMPUTER INC. for me … seems valid! I’ll try it soon.

I downloaded the tools from the ASrock site and copied the folder relevant to my NIC from the archive (i219) and ran eeupdate with instructions from…spx?formid=2993 . Everything went through perfectly, my NIC is fully functional and has its original MAC address. Thank you everyone for the help provided! I’m very pleased that my motherboard is working 100% again.

I have a code 10 on a Lenovo M93p Q87 board with a I217-LM. Reading your post I thought maybe it will help to reflash GBE. I just dumped the GBE and compared it to the GBE I did some time ago when everything was working fine and the GBE’s are identical. So I doubt that GBE is causing the COde 10 in my case.

How did you conclude that in your case it was a problem with the GBE?