How to add VCCIO and VCCSA settings in setup Asrock Z270M-ITX

Hi folks!
I am trying to oc my ddr4 modules but my motherboard has no vccio/vccsa settings in setup. There are even no hidden settings to show.


Better version of this motherboard - Asrock Z270M-ITX Gaming - has these settings.
Is it so simple just to insert such a lines copied from similiar motherboard bios? I can try but does it make sens? Do I risk any damage in case of flash modified this way?



@pacuro - Do you have flash programmer? If yes, then a swap out test can be done (Setup, AMITSE, AMITSE/SetupData) No, it’s not just simple copy and paste, and yes there is risk to test what I mentioned above, unless you have a flash programmer.
If you don’t have one, order now, they only costs $2.50 on ebay (CH341A) + you need SOIC8 test clip cable another $2.50, if you need links to those let me know.

I assume this is your board?

@Lost_N_BIOS - Yes, I have CH341A programmer, and I successfully did few modifications on my bios. It is easy because there is spi connector although spi is soldered. I have dump full backup, removed regions lock and flashed it with programmer. Then modified with CoffeeTime and also disabled ME with me_cleaner. Now flashing modified bios with FPTW64. You assume right, that is my board.
“swap … (Setup, AMITSE, AMITSE/SetupData)” - completely have no idea what you are talking about. Could you just take a look in my bios dump and see if such a modification is possible.
Maybe instead of swap there are necessary data within - I found vccio setting with IFR in PE32.
(original full dump with ME enabled, my nick is archive password)

Thanks a lot in advance.

@pacuro - Great you have programmer! Send me a dump of the mod BIOS you are using now, that way CPU swap etc not required, since you’re using CoffeeTime mod BIOS and all that.
When I commented, I was speaking in general, I had not looked at your BIOS since I was not sure of the exact model (only that guess)

The stuff I mentioned are modules within the BIOS that control what you see, what options are there etc.

I checked now, and the VCCIO in setup IFR is under/within DRAM Configuration, so it’s DRAM VCCIO. This setting is visible in AMIBCP, probably your BIOS too @ Advanced >> OC Tweaker >> Dram Config, towards bottom under all the timings
May or may not be visible in your BIOS, but it could be if we want to change that. But this is why you find VCCIO in IFR, from your IFR go to VCCIO, then search “Form:” up and you’ll see first result is DRAM, meaning VCCIO below that is inside this section.

No VCCIO or VCCSA aside from that in setup IFR, or in hidden areas of the BIOS. So some module swapping tests will be first step at getting this ported to your board, if that does not work then more involved methods need to be used next
This is the “Other” board correct?…ITXac/index.asp

VCCIO x4 in the above boards setup module IFR
VCCSA x3 “” “” (zero in your boards BIOS)

I will work on test BIOS for you shortly, little busy tonight so may not have time.

@Lost_N_BIOS - Yes, DRAM voltage regulation is available in setup. So only swap from "Fatal1ty" left. And again you found correct board as donor :slight_smile: Sorry, I should post both links myself in first post.
Bios dump in previous post is my backup dump of current config so do not hesitate to use it.
That is great news you can try that swap. And there is no need to hurry. Please take a rest well.

Yes, the only way this may work is swapping from the other board, there’s nothing to enable/make visible etc in your current BIOS itself.
Are you sure to go ahead with BIOS you linked, not the Coffeetime mod BIOS? You have made and confirmed your backups can be programmed back correct? Need to be sure, in case recovery is needed.
It’s not too hard to do the mod I mentioned, unless a direct swap fails. If that doesn’t work, then doing other mods instead will be tougher to do, but maybe still possible.

Do you know anyone with the Fatal1ty Gaming board? If yes, can you please ask them to send you a dump or backup BIOS, using AFU or FPT, or if BIOS Instant Flash tool can save BIOS that would be fine too, I need to look at a dumped BIOS NVRAM from that board.
Maybe I can find one, I’ll look around. * Never mind, found one! * Never mind again, it wasn’t a dump So still need if you can find

@pacuro - here, try M1 first, then if fail try M2 - either one, be ready to recover just in case!…780045811319879

If they boot OK, but still no setting, it’s OK, let me know, settings may be suppressed and I need to make visible is all.

That was really quick! I am impressed.
Bios I have linked and you have modded is already CoffeeTimed :slight_smile: I do confirm I can restore previous version with programmer if motherboard will not up.
I will keep you informed today evening once back from work.

@pacuro - You’re welcome, hope it works, that was the easy edits that’s why it was quick

* Hope you just got busy or tired, or didn’t have time to test, so no update… Hope it’s not a sign things went badly

@Lost_N_BIOS - well, yes, I had no time nor power to play around on Thursday. I flashed mod1 with fptw64 yesterday and:
1. Mainboard wakes up and allows to enter setup. Monitoring and setting of vccio and vccsa appear in setup. Although there are some visible errors in visual layout (red elements from Fatality series and some "dirt" on tabs. Take a look at screenshots below:

mod1 monitoring.png

mod1 settings.png

2. Can not boot - "some (I do not remember now and did not write down) address error" on post screen does not allow to boot windows. Enter to setup only works.

3. Something went wrong while going back to working backup bios. Probably not related each other. Erasing and flashing spi with programmer with success. After few tries: programming done with removed ram and power cord, but bios battery attached. I had to plug and unplug power cord about 10 times. When final pluging power cord I heard some "short circuit sound", no bad smell, no smoke. Maybe some fuse in psu. No response to power button at all. I hope motherboard/ram/cpu/gpu have survived. My case is Silverstone Sugo SG-05 and it was about 10 years old 350W Chieftec sfx psu. Maybe its time came right now :slight_smile: I have ordered Corsair SF 450W Gold Plus psu. Delivery on Tuesday. Of course will let you know if it was only psu (I hope).
Have a nice weekend!

@pacuro - good to see it works, to some degree anyway. Did you load optimal defaults? Try clearing CMOS and then loading optimal defaults, then recheck your SATA/Boot settings etc and make sure all is correct to get into windows.
If that doesn’t help to get into windows not sure what would cause that unless maybe there is some SATA differences between the two board. If nothing works, I can try to individually cut and add those parts from the other BIOS into your modules, but that’s tough to get correct so it may need a few tries.

Ouch! Yes, sounds like something shorted. Do you mean your PSU wont turn on at all now? Hopefully it’s only PSU!!!

While we wait, I will try to work on transfer of the individual settings and see if I can get it at least on my end (I can tell if BIOS breaks or not due to those kind of edits, at least in one way)

@Lost_N_BIOS - fortunatelly it was only PSU. New one works like a charm. I am going to flash MOD 2 now. Could you please tell me is this much different than MOD 1 ?
I also have some thoughts about MOD 1:
- Monitoring shows strange numbers on VCCIO (0,136V) and VCCSA (0,192V). Too low in my opinion as these should be kind of 1,00V. Anyway HWInfo64 shows exactly the same numbers so it looks as bad monitored at all on that mainboard. Althought settings numbers are OK.
- DRAM V monitoring shows 1,820V which is completely wrong. DRAM is set to 1,2V and it can be seen on settings.

@pacuro - I forgot about this mod, happy to see it about to be tested. And it’s great your PSU was only thing damaged

Please try M1 first as mentioned, yes M2 is different. I don’t remember, would have to dig into the files I have on this and see if I could figure that out, or if I kept notes etc. But I see above I said do M1 first, then if no luck do M2, so please do that way.
Ohh, you already tried M1, I see, sorry about that! The monitoring may always be that way, since this was files not from your system, your board may not be setup to monitor those.
It may not have sensors connected, may not be connected using same paths etc, or may need some other modules transferred to, whatever controls the sensors, and doing that may cause worse issues, hard to say.

I’ll check now and see what difference is between M1 and M2, maybe M2 is more modules transferred so may work better, not sure, I’ll let you know if I can tell from my end easily or not.

* Edit - difference between M1 and M2 is M2 has within the main BIOS volume (Not normal NVRAM volumes), the NVRAM external default module changed out for the other boards module, and M1 does not.
That may make all the difference, or it may not matter at all and things will still be the same.

Can you adjust the values and the monitored amounts change, that’s what really matters.