How to enable AHCI/RAID on x79 in Windows XP 32-bit?

I have 2 HDDs with XP 32-bit installed which used to run in Raid 1 on a x58 mainboard. Now I tried to move the HDDs to a x79 mainboard. The only way I was able to enter the OS was when I selected IDE in bios, AHCI/RAID gave me a bsod. So far this behavior was expected.
After some reading I became aware of a RST driver which was able to run under XP 32-bit and support the x79 chipset: http://www.msfn.org/board/topic/107504-i…drivers/page-47 post #1165. Now, I have seen people selecting RAID/AHCI at the time of OS installation, but it also has been done by moving iastor.sys into the system32/driver directory and editing the registry: http://forums.hexus.net/motherboards/112…ich9-ich9r.html , after the OS was already installed under IDE. Besides, my system was a RAID system to begin with. In the device manager there was an unknown entry under SCSI and RAID controllers so I installed the compatible driver mentioned earlier (RST 10.5.2.1010). This should have placed the compatible iastor.sys into the system32/driver folder and create the appropriate registry entries. When trying to boot, having RAID selected, I still get a bsod 0x0000007E mentioning a problem with iastor.sys. I don’t understand why, after all is this iastor.sys supposed to work with x79/XP 32-bit.

@ JC:
Welcome at Win-RAID Forum!

Before I am trying to help you, I need some additional informations:
1. Which X79 chipset mainboard do you use?
2. Has the mainboard the option to choose "RST mode" within the BIOS?
3. Is a fresh OS installation an option for you?

Regards
Fernando

Thx Fernando! I’m glad to be here.

1. EVGA X79 SLI
2. There are UEFI and Legacy settings but no RST mode; option ROM is RSTe.
3. I am not sure, I am reluctant considering that I am not sure what the source of the error is. If the registry entries and the driver is correct it should work and not differ from an f6 installation. The previous RAID system i did create from an IDE system using the method I linked earlier. If this is relevant: The earlier Raid system used Intel matrix storage. (Maybe I should uninstall that? but idk how this would interfere since the driver is in the system32/driver directory)

Do you think RSTe option ROM version 3.6.0.1023 might create this bsod in conjunction with RST drivers? I was not able to find any documentation as to what this option ROM does support.

@ JC:
Thanks for the quick reply.
I think, that your problem is caused by the fact, that the old RAID1 array had been created by an Intel MSM RAID Utility, which had been designed just for DEV_2822 Intel Desktop Express SATA RAID Controllers, whereas your new X79 system has a DEV_2826 Intel C600 Series Chipset SATA RAID Controller.
So it may be a good idea to break the old Intel RST RAID array and to create a new one using an Intel RSTe RAID Utility.

@ Fernando:
yw, thx for your help!
So do I understand you correctly that I should uninstall MSM and install RSTe management utility? Assuming the RSTe management utility works while bios is set to IDE/installs under XP 32-bit, doesn’t breaking a RAID array cause data loss?

edit: RSTe System Management Utility for Windows does definitely not install for XP 32-bit

@ JC:
This is what I recommend to do:
1. Backup your important data.
2. If the X58 system is still available, insert the 2 HDDs into it and break the RAID1 array by using the old Intel MSM RAID Utility.
3. Update the Intel RSTe RAID ROM of your X79 mainboard BIOS to v3.8.0.1029 by using the UBU tool (look >here<) and flash the modded BIOS.
4. Re-insert the 2 HDDs into the X79 system, set the Intel SATA Controller to “RAID”, hit CTRL+I while rebooting and create a new RAID1 array.
5. Set the Intel SATA Controller to IDE and boot into Windows XP (I am unsure, if this will be possible).
6. Open the “IDE ATA/ATAPI Controllers” section of the Device Manager, right click onto the listed IDE Controller > “Properties” > “Details” > “HardwareIDs”. The shown VendorID should be VEN_8086 (if not, stop the procedure at this point).
7. Right click onto the just found Intel SATA IDE Controller, choose “Update Driver Software” > “Browe my Computer…” > "Let me pick…"
8. Hit the “Have Disk” button, navigate to the Intel RST driver v10.5.2.1010 WHQL and choose the file named iastor.inf.
9. Force the installation of the device “Intel(R) C600 Series Chipset SATA RAID Controller” despite all warnings.
10. Enter the BIOS while rebooting, set the Intel SATA Controller to “RAID”, save the new BIOS settings and reboot.
If you are lucky, you will be able to boot into Windows XP in RAID mode. If not, you probably have to do a fresh XP installation onto the RAID1 array.

@ Fernando:
1. I don’t have the possibility to backup my data so I have to take a certain chance.
2. The X58 mainboard is no longer available.
3. I will have to skip this step (too risky), I have to assume for now that the BIOS is not the problem.
4. I never mentioned but I only had 1 HDD plugged in at all times, but when trying this step the option ROM reports: “not enough storage space”, or something to that effect.
5. -
6. Now it gets really interesting, I had to attach a picture for you to see it: under “IDE ATA/ATAPI Controllers” there are 6 entires, the first 2 have Hardware ID VEN_8086. Also as you can see, under “SCSI and RAID controllers”, there is the entry for the c600 which I installed with a modified driver of yours (11.2.0.1006).
7. 8. 9. 10. Should I still proceed?

untitled2.JPG

I meant the personal data. The OS can be recovered by doing a fresh XP install.

That is a pity, bacause you probably can only break the old RAID by using an Intel MSM or RST RAID Utility.

You are right, but I generally recommend to create a new RAID array by using the best suitable Intel RAID ROM.
Another thought:
Maybe we can solve your problem by flashing a BIOS, which contains the Intel RST RAID ROM v11.2.0.1527, which has been customized by me for being usable with your X79 SATA RAID Controller (DEV_2826). If you want to test it, I will give you the link.

This verifies, that the needed Intel RAID driver is already present for the OS. As a consequence the listed Intel SATA IDE Controllers don’t need to be updated.

No, that wouldn’t make any sense.

Another idea:
Maybe the last try to boot into Windows XP in RAID mode failed because of the wrong boot order.
So you may enter the BIOS, set the Intel SATA Controller to “RAID” and then try another boot order.
By the way: Have you ever tried to hit CTRL+I while booting after having set the Intel SATA ports to “RAID mode”? If yes, what happened?

  1. Even though this might work, I rather upgrade my OS since this is long overdue. Thx for the offer though.

    I will try to change the boot order while attempting to start XP. I will give you an update tomorrow. And yes, I did try CTRL-I, it gave me the options to create a new RAID Volume, delete a Raid Volume ,and revert to non-RAID Volume. The first option gave me a message which read that I did not have enough space to create a Raid Volume. The other 2 options would cause data loss so its a no go.

    The problem appears to be as you said, that the old RAID needs to be broken using the MSM Raid Utility. Reverting to non-RAID from the Option ROM would cause data loss.

    Thank you so much for your help!

    edit: Changing the boot order did not help.

I am trying to dual boot XP and Windows 10 on a Lenovo Flex 14-2 laptop. It has an Intel i5 processor and Intel 8 Series controller. I have downloaded and expanded the “Universal 32bit Intel RST AHCI+RAID driver v11.2.0.1006 mod+signed by Fernando” and and put it on a floppy disk. I am installing from a DVD onto a partition I created on a Seagate 1TB drive that has 8GB SSHD integrated. My controller ID is DEV_9C43 which is not listed in the list of IDs so I can’t install the driver. I attach a screen grab of the relevant info. Any suggestions would be welcome.

Flex2-14 Inte 8Series cttlr.jpg

@Miles529 :
Welcome at Win-RAID Forum!

Only Intel SATA AHCI and RAID Controllers are supported by the Intel RST/RST(e) drivers.
The Intel SATA Controller of your system is currently neither running in AHCI nor in RAID mode.

Regards
Dieter (alias Fernando)

hey fernando,

you seem to be the holy grail for this topic, i hope you can help.

i have a recording studio and more programs run only on win xp, also a context menu tool with which i color tagged samples and a lot of other documents, therefore running win xp in virtual box is not an option.
since i do also some video editing i searched for the latest, still win xp supported chipset, in order to set the pc in dual boot mode with win xp for audio editing and win 7 for video editing.

after extensive research i chose following components:
mobo: asus P9X79 PRO
cpu: Intel Core i7-3930K
ssd: samsung evo 850 250gb
ram: 4x4gb quad channel kit G.Skill TridentX 2400mhz F3-2400C10Q-16GTX
gpu (passive cooled): Palit GeForce® GTX 750 Ti KalmX (2048MB GDDR5)
cpu cooler: noctua nh-c14s
psu (passive cooled): nofan p-500a
case: Nanoxia Deep Silence 2

the asus homepage states clearly in its specs that the mobo is supported by win xp and the ahci drivers are available.
link: http://www.asus.com/Motherboards/P9X79_P…pDesk_Download/
driver: Intel Rapid Storage Technology enterprise driver software V3.2.0.1126 for Windows 64bit XP & 32/64bit Vista & 32/64bit 7.(WHQL)

but when i burned my win xp boot cd with nlite including the ahci drivers i got a bad surprise like may others: iaStorA.sys is missing
since i first try installed it with an external dvd drive connected by usb i though that could have been the cause of error.
therefore i connected a common dvd drive to the same intel sata port like the ssd: iaStorA.sys missing again

where can i download your modded drivers and which procedure should i follow?

i need only ahci, no raid. bios is set to ahci.

thank you!

@stefano :
Welcome at Win-RAID Forum!

You can find everything what you will need within the start post of >this< thread.
I recommend to integrate the 32bit Intel RST driver v11.2.0.1006, which had been modified and digitally signed by me. This driver will support the Intel SATA AHCI Controller of your X79 Chipset system.

Good luck!
Dieter (alias Fernando)