How to flash modded BIOS on AsRock X99 OC Formula?

Hello guys!
I am not totally new in modding BIOS files and I’ve done quite a few successfully like back in the early 2000s when I added microcodes and updated Highpoint Raid ROMs in my ABit BX133 RAID to support Tualatin CPUs. Lately I’ve been using UBU to modify some socket 1155 and 2011 (X79) boards.

My main PC has a AsRock X99 OC Formula board and I am using the latest BIOS (3.40). Now I want to update the microcodes since the ones in there are outdated and stupid Windows 10 Build 1903 breaks my overclock since a MS patch adds new microcodes and my OC settings in BIOS are ignored in Windows.
So my plan was to update the microcodes with UBU since the latest are newer than the onces AsRock has in the BIOS and even as MS added with their patch in Windows.
I am using a Broadwell-E CPU (CPUID 406F1)
Microcodes in
Stock BIOS 3.40: B00002A
MS Windows Patch: B000031
Newest from UBU that I want: B000038

Okay so what I tried - I loaded the stock BIOS in UBU (using v1.75.0.1) with MMTool 5.007 renamed to mmtool_a4.exe and MMTool 5.02.0024 renamed as mmtool_a5.exe as UBU requires. (I also tried with MMTool 5.02.0024 MOD and 5.02.0025 as mmtool_a5.exe).
So I updated all microcodes successfully in stock BIOS with UBU, nothing else modded, and tried to flash the BIOS using Instant Flash. But the program doesn’t recognize the BIOS file - it searches for it and says “No BIOS file found”.
The USB stick works. It isformatted as FAT32 and I used the same to flash the stock BIOS, I even tried the stock BIOS with that stick and it works so the USB stick isn’t the problem. I renamed the modded BIOS file like the stock but it still doesn’t find it using Instant Flash.

As I am a little old school I thought of flashing using DOS, but ASRock states on their website that it is NOT recommended to use a third party flash tool as it will damage the board. The DOS BIOS files that AsRock offers are .EXE files.

Then I read in some threads here that I might use FPT since I already have the latest BIOS and just want to update the microcodes.
So I made a dump of my BIOS using

fptw64.exe -bios -d biosreg.bin

I then get a 14Mb file (full BIOS is 16Megs)
When I try UBU on that file I get to the point when I try to update the microcodes and press R to apply it goes as far as:
[Preparing for replacement]
BIOS file backup
Dummy GUID: GUID replaced
mCode GUID: GUID replaced
mCode FFS:

and then a window pops up: mmtool_a5.exe with the message "error in saving".

As far as I understand I should not use FPT to flash the stock BIOS because I would loose some specific info of my board (MAC, UUID ...).
But why can't I use the modded BIOS with Instant Flash? Did UBU not remove bios protections?
Why can't UBU mod the FPT BIOS dump file?

Can someone help?
Here are the files, stock BIOS, my UBU modded BIOS and the FPT dump.

properly modified you can flash it within the bios.

Hello oldirdey, okay then tell me what did I (or in that case UBU) do wrong?
I downloaded the BIOS (Instant Flash version) off the AsRock homepage - loaded it up in UBU - just went to section "5" (Microcodes) - "F" to check for updated Microcodes - "R" to apply changes and save it.

You don´t need to use ubu at all.

Okay … Instant Flash is very strange. So I fired up MMTool as you stated before you edited your post, replaced the microcodes for my Broadwell-E CPU and saved the file. Then I copied the file to the USB stick that already had the UBU modified stock BIOS on it - fired up Instant Flash and it would not find the file I modded with MMTool but instead it found the one modded by UBU that did not show up before when I tried.
I flashed it and it worked.

Maybe Instant Flash doesn’t really like my USB stick? I don’t know … anyway thanks for you help oldirdey.

I edited the post cause I wanted to add some pictures, but forgot it in a hurry. It´s possible that you flash drive is the problem, some newer ones are not working. But if you have the microcode files available you only need mmtool to change the microcode.