[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

If the guide was read correctly, you would know why bios doesn’t show nothing or it can show a PATA_SS device in some motherboards with CSM enable, CSM only for this detail, not for OS install.
Assuming the flash mod was successful…
What matters here is the OS installation and bios settings.

Welcome to the Win-RAID Forum!
Provided, that you flashed the modded BIOS by using the ASRock BIOS own InstantFlash utility and didn’t get any error message while executing the action, you should be able to get Win10/11 installed onto the NVMe SSD by following my guide.
Note: To be able to get a modded AMI Aptio IV ASrock BIOS properly flashed by using InstantFlash, the BIOS header (it contains the ASRock BIOS protection) has to be removed. The UBU tool does it automaticly.
Good luck!
Dieter (alias Fernando)

  1. original bios extracted with Backup ToolKit 2.0 (because is already the last version 3.10): AmericanMegatrendsInc.-P3.10.rar | Files.fm.
  2. moded bios with uefi tool 0.2.80: AmericanMegatrendsInc.-P3.20.rom | Files.fm.
    I use the modded bios with the same name, 3.10 because i didn.t know if is ok or not to rename it. After i checked with the ssd into adapter connected, the bios was identical, like before, nothing was inserted. The second procedure, with ubu tool seems to be complicated, i never use those programs, i’m affraid to make a big mistake and to stay almost a month without computer if something goes wrong, until will came the already modded bios, if i decide to buy one. Probably you have right, the bios is protected and is no way to flash it in the usual way… Studying the procedure you recommend me, honestly, i don’t understand nothing, no description as how to insert the NVMe driver, just few examples that has nothing to do with this, i’m already confused about ubu tool/mmtool/uefi tool…Probably for someone with few programming skill is easy, that’s why you have to explain the procedure for everyone, not for particular examples, if you decide to help people, not to become another guru who speak for himself, and for other clever minds who wants to show the distance between a computer home user and a professional one. I decide to give up and let behind this crazy solution. I will aaccept that this is what this motherboard can and that’s it. Probably are just 2 alternatives, use the ubu tool - wich i can’t understand how to use or buy a modded chip…or someone with more skills, help me to prepare a modded one and post it somewhere…My last impression is like the first one, when you put me on hold for 3 days, after i create the account, i was asking for help in the wrong place, to a much higher class of computer users.

I checked both *.ROM files.

  • The BIOS named AmericanMegatrendsInc.-P3.10.rom doesn’t contain the header with the BIOS protection. So if you trust the Backup Toolkit 2.0, you can insert the natively missing NVMe module, rename the BIOS file and then flash it by using the BIOS in-box InstantFlash tool.
  • The BIOS named AmericanMegatrendsInc.-P3.20.rom will not work or may even brick your mainboard, if you try to flash it, because you have inserted the NVMe module into the wrong location. Here is the related picture:

    If you want to insert a natively not present NVMe module by using the UEFITool, you have to do it at the bottom of the related “DXE Driver Volume” beyond the undermost listed module with GUID. You inserted the module directly beyond the “CSMCORE” module (which was only mentioned within my guide to find the correct target Volume of the BIOS. Please re-read the related part of my guide.
    This is how the bottom of the “DXE Driver Volume” should look after the insertion of the NVMe module:

Note: After the removal of the header the BIOS file is 4 KB smaller than the original BIOS. Don’t worry about it. The smaller BIOS will be flashed by the InstantFlash tool without any problem, because its “body” has the same size as the original one.

I don’t have other source to get other bios, what i download from the motherboard page, 3.10 and 2.31 Beta, are not opennig. So i use backup toolkit. Shall i rename it or leave it like the original 3.10 or 3.20? I’m tired, nervous and completly jaded and unsatisfied…i,m trying for almost one month to find a solution, i read tons of explanations…

Which “other” BIOS do you mean? And which BIOSes cannot be opened (by which tool)?
Please re-read carefully my guide.

EDIT 1: It is not my fault, that you are unsatisfied. A BIOS modification is not as easy as playing cards and flashing a wrongly modded BIOS may brick your mainboard. If you strictly follow my guide, you will succeed, but you should stay patient.
Yes, before you flash it, you should give the modded BIOS the exactly same name as the original one had.

EDIT 2: If you don’t know how to flash a modded ASRock Aptio IV BIOS, please read the related chapter within the start post of >this< thread.

Yes, probably i become unpatient, and after i read what you tell me, i’m happy that my motherboard still working…Can you check again the modded bios? F288HDP3.rar | Files.fm. - i use the 3.10 version downloaded from mainboard page
MMTool and UEFI tool can’t see the bios version 3.10 and 2.31 like image files, and not opening (have to choose in properties of each one, wich program can open them, and after only with right click/open with). Or this one, base it on the saved existing bios with backup toolkit - AmericanMegatrendsInc.-P3.10.rar | Files.fm.

This time your modded BIOS seems to be fine, but the capsule header with the ASRock flashing protection is still present. You should remove the header before trying to flash it.
By the way - it is very easy to open all “pure” BIOS files by using the AMI MMTool or the UEFITool, if you click onto the “Open Image file” box and choose the option “all files”.

Finally i found the solution to remove the bios protection/capsule header! It was here on the forum, where you gave me the link, and i don’t know why the first time, when i fallow it, it displayed something else with ubu. It was impossible to don’t understand what i have to do. Sorry for my words. If you can edit or delete it my posts, after you check the files that i’ve linked to you, please feel free to do it. Didn’t flash it yet, i’m waiting day light, and i will check after if can use for booting from the ssd. Anyway, i owe you! Many thanks!
bios source: F288HDP3.rar | Files.fm.
modded bios with capsule header: F288HDP3.rar | Files.fm.
modded bios without capsule header: mod_bios.rar | Files.fm.

Does anyone have the NVME mod for a GA-X79-UD3 ver. 1.0 available. I have tried the ver. 1.1 but was getting the bios boot error screen and problems with IMEI. :smiley: :smiley:

Do you seriously think, that you may get your desired NVMe modded BIOS this way?
This is the thread for users, who want to do the required BIOS modification themselves.

@Fernando Thanks for the great work here. I’m contacting you because I’m unsure about a padding issue.

Can you check the modded bios? You’ll find the files here: BIOS_v1.zip - Google Drive

Thanks a lot in advance.

@Mazar Are you still on this forum? We have the same motherboard, you seem to have a success.

Mod is not ok, its not checked with AMItools, its with UEFItool, as explained in the guide, and will see that your mod as created a new pad file on the volume.
Every bios is different, so try the method with the 2 AMI MMtools versions 4.x or 5.x and the UEFI method with 0.25 or 0.28, but to check it is always, in most cases with the UEFI tool.

Welcome to the Win-RAID Forum!
You are right - neither the UEFITool v0.28.0 nor the AMI Aptio MMTool v4.50.0023 are able to insert the “small” NVMe module properly into the latest BIOS of your specific SuperMicro mainboard.
After having tried various other options I found a solution for your specific mainboard BIOS. This is the way how to succeed:

  1. Do a Google Search for “MMTool Aptio 5.00.0007” and download the tool from the first offer you will get (tweaktownforum.com).
  2. Run the MMTool v5.0.0.7, follow my MMTool instructions, insert the “small” variant of the NVMe module and store the modded BIOS.
  3. Open the just modified BIOS by using the UEFITool v0.28.0 and compare it with the original BIOS.
  4. If you should realize, that the only difference is, that the “small” NVMe module has been inserted at the bottom of the “DXE Driver Volume”, rename the modded BIOS as the original one and then flash it the usual way.

Good luck!
Dieter (alias Fernando)

Padding issue happens if any padding is removed and it causes no boot and/or any problems during the use of the system.

This happened to my MSi Z68’s and the only way to do it is using MMTool, well sucessfully updated the nvme using dxe5 also adding samsung ahci m.2 even if ever find the need to.

Thanks a lot for trying it out and the detailed instructions.

Did you follow my recent advices? Did you finally succeed? Were you able to get Win10/11 installed onto the NVMe SSD and to boot off it?

I postponed it, as I think the motherboard does not support pcie bifurcation. My use case would be multiple m.2 in one extension card.

In separate adapters can be possible, but only 1 will work as OS boot, all the others will be as storage devices.

Hi @Fernando + community - this is an excellent resource, but I am a bit stuck

I have an MSI Z85-G45 motherboard, and have installed a Samsung 970EVO Plus SSD via a PCIE card.

Although I went through the original steps, I saw that Fernando had provided a modded BIOS specifically for my board, so used this.

The SSD is visible in Windows, and I have used 2 ways of replicating my OS and the contents of my current boot drive onto the SSD (Disk Genius and also the Samsung Data Migration software). The SSD is also recognised by the BIOS, as it shows a PATA, but for some reason, even if I select this as the boot device, it still loads from the original disk and not from SSD. There seems to be no options to go into CSM or Advanced settings which would enable this.

Hopefully I am doing/not doing something stupid, but can anyone suggest what I should try next so I can boot from SSD?



Original BIOS - E7821IMS.190

Modded BIOS - E7821IMSmodbyfernando.190