[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

Hi! I followed your guide to add “NvmExpressDxe_5” into a bios file on my Asrock X79 Fatal1ty pro motherboard. I am a newbie to this sort of things but I must have done something right. The disk shows in UEFI as PATA. Been workin for about two weeks trying to install a linux os on the disk, no go…until yesterday, success. Although it isn’t as fast as I imagined. The disk is an Intel ssd nvme 670p. I thank you for your time an enthusiasm about this. It is funny when everywhere it is said that this disk do not boot on my motherboard, and here we are. -Sam


Welcome to the Win-RAID Forum and thanks for your feedback!
It is fine, that got it working your own by just following my Guide.
Enjoy it!
Dieter (alias Fernando)

Hi, just wanted to ty for the great write-up. Got my Gigabyte Z77X-UD4H working with nvme and it worked with a previous sata ssd (840evo > 970nvme), just cloned directly using macrium usb. Please correct me if i’m wrong, but i read that cloned drives wouldn’t work properly, don’t want to mislead others. Will continue testing and report back. Also, is there a thread i can link my bios file to, for others with same board?

Welcome to the Win-RAID Forum and thanks for the feedback! It is fine, that you succeeded and now can boot off an NVMe SSD with your old system.
If you want to offer your modded BIOS for other users with the same mainboard model, you can start a new thread within >this< Forum section.
Enjoy this Forum and your updated system!
Dieter (alias Fernando)

wow hey everyone. I’m really sorry. was in the hospital and couldn’t come online.
now that i’m home again I’ll get back to that in a moment.

5 posts were merged into an existing topic: [Guide] How to flash a modded AMI UEFI BIOS

I’ve successfully patched Supermicro X9DR3-F 3.4 BIOS and was able to boot from bifurcated x16 slot. Here’s patched bios with “NvmExpressDxe_5.ffs” module: https://mega.nz/file/h1pBSDxS#T_sHlVDE7kH7rwNiBDdm7qwhXnOJlzRjgDETH9yh-f4

Welcome to the Win-RAID Forum and thanks for your feedback!
It is fine, that you succeeded and want to offer your modded BIOS for other interested users with the same Supermicro mainboard model.
To make it easier to find your offer, I recommend to start a separate thread within the “BIOS Modding Offers” section.
Enjoy the NVMe booting with your old mainboard!
Dieter (alias Fernando)


First of all thanks for the guide. I retrieved a Apple SSD from a MacBook that I attached on a PCIe-4x adapter. My modern PC sees it and I could install and boot from it.

But now I inserted that adapter on a HP Pavillion desktop tower with 3rd gen Intel Core i7 (see : HP Pavilion p6-2393ef Desktop PC | HP® Customer Support) and I tried the Clover method to not avail.

I tried modding the BIOS with UEFITool with both the v5 and small NVMe drivers but both ways add a pad-file to my work…

Any idea?
Cheers and have a good day/night

PS: I could boot the USB windows 10/11 setup and install windows on the SSD but I cannot boot from it after that on Clover… that’s why I wanted to try this guide instead.

Welcome to the Win-RAID Forum!
Please attach the extracted “pure” original *.ROM BIOS as *.zip archive. Then we may be able to search for a solution.
Dieter (alias Fernando)

1 Like

Thank you for a fast answer Fernando.

Here is the original untouchable BIOS:

You can also download the .exe from HP’s website and open the .exe file with WinRAR and retrieve that same file here:


Again, thank you for your help. Trying to make that good HP tower to a use. I know I could use a SATA SSD but I just got THREE Apple PCI-E NVME SSDs for 0 bucks.


Hello, thanks to everyone for this awesome guide :smiling_face_with_three_hearts:
I was using method #1 with AMI’s MMTool and I had to use the NvmExpressDxe_Small module.

My MB is the ASRock Z77 Extreme4-M.

I use the Samsung 980 with Icy Box PCIe Adapter:

ASRock was releasing NVME Bios support for the Extreme4 but not for the Extreme4-M variant.


Thanks for the upload of the oribinal BIOS file.
Although I tried several different MMTool and UEFITool versions, none of them were able to insert any NVMe module without creating a natively not present Pad-file.
Nevertheless I succeeded finally by doing the following:

  1. As first step I opened the original BIOS with the AMI MMTool 4.50.
  2. To get more space within the extremely compressed DXE Driver Volume I deleted the biggest listed Network DXE Driver named Ip6Dxe (Volume: 03:02-00, Index: AD). As the other network modules this DXE Driver is only required for the “Wake-on-LAN” feature (booting by a LAN command). So the missing Ip6Dxe module will not harm any other BIOS function.
  3. After having saved the work of point 2 I opened the pre-modded BIOS again with the AMI MMTool 4.50 and inserted the NVMe module according to my guide with the NVMe module named NvmExpressDxe_5.ffs.
  4. After having saved the finally modded BIOS I compared the content of the original BIOS with the content of the modded one. Result: I could not find any freshly created or moved Pad-file.

Good luck!

Welcome to the Win-RAID Forum and thanks for your feedback!
Did you succeed and are you now able to boot off the NVMe SSD?
If yes, enjoy it! If not, please let us know it.
Dieter (alias Fernando)

1 Like

I have been using NVME version 4 for a long time on my X79 board. why does it not want to work in the NVMEXPRESS_5 version?
Greetings everyone! I like the new website! :slight_smile:

Everything works perfect:)

1 Like

To be able to answer your question we need both modded BIOSes.
Why did you try to replace the NVMe module of a fully NVMe supporting BIOS?
You cannot expect any noticeable functional benefit.

Thank you for your time and efforts,

I tried the same procedure on UEFITool but just after removing the Ip6Dxe tool and saving, it inserted a Pad-file. So I guess I can only do these manipulations that you did on MMTool?

Thank you for your time

Each BIOS modding tool works and behaves differently.
Since I tested the procedure of my last post only with the MMTool v4.50.0.23 and succeeded at first try, I recommend to use the same tool.

1 Like

Thank you, I 100% managed to make the modded ROM. Sadly there is no way to flash it because the HP tool is within an .exe file and it won’t do it. Thanks for the help nonetheless. Sad to see that computer not being used